Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 09-22-2002, 10:51 AM   #1
Registered: Aug 2002
Distribution: Slackware 8.1
Posts: 750

Rep: Reputation: 30
Lightbulb VESA framebuffer

I am confused with one thing!!! It is VESA framebuffer!
For instance my card ( intel 820815 ) can stand out X-Windows ( 1024x768 24 ), but why it can not stand out simple console with 1024x768 24bit is a big MYSTERY for me!!!
I can't believe 4MB of video memory is too small for 'beatiful'
konsole and a pengy above!!!???
I think you understand me. . .
I will be very glad to hear you opinion about this thing.....

regards Nautilus. . .

PS. Is Slackware the only distro supporting VESA framebuffer support?
Old 09-22-2002, 11:56 AM   #2
LQ Guru
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
No it's kernel, not distro related. And it's probably not the amount of RAM that is prohibiting you, but the cards abilities. I really don't like using FB, even though I am able to, so I disable it when I recompile my kernel(s). Too bad the situations aren't reversed I guess, since I don't want it but can use it, and you want it, but can't use it.

Old 09-22-2002, 08:38 PM   #3
Senior Member
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 46
Isn't this configured in the /etc/lilo.conf? I checked all my lilo.conf files and I deleted all the stuff for FB. I use "vga = normal" on all my machines. But it seems to me that the default lilo.conf file ahs a lot of settings that can be enabled by removing the remark. The following was copied from the /usr/doc/lilo-22.2/README file.

VGA=<mode> Specifies the VGA text mode that should be selected when
booting. The following values are recognized (case is ignored):

NORMAL select normal 80x25 text mode.
EXTENDED select 80x50 text mode. The word EXTENDED can be
abbreviated to EXT.
ASK stop and ask for user input (at boot time).
<number> use the corresponding text mode. A list of available modes
can be obtained by booting with vga=ask and pressing [Enter].

If this variable is omitted, the VGA mode setting contained in the
kernel image is used. rdev supports manipulation of the VGA text mode
setting in the kernel image.

Perhaps it will help, if I understand what you are attempting to configure.
Old 09-26-2002, 12:13 PM   #4
Registered: Aug 2002
Distribution: Slackware 8.1
Posts: 750

Original Poster
Rep: Reputation: 30
No Excalibur I didn't wanted to confgiure VGA, I just think that VESA FB must be developed....


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
VESA framebuffer vs Intel framebuffer in Slackware 10.0 with default kernel brancalessio Slackware 3 01-20-2005 03:21 PM
problem with VESA framebuffer driver alinsoar Linux - Hardware 1 11-30-2004 08:05 PM
VESA Framebuffer Driver hubabuba Linux - General 1 10-02-2004 07:37 AM
got vesa framebuffer console working teacup Member Success Stories 0 05-26-2003 01:16 PM
vesa framebuffer ... failed to open pbhj Linux - Newbie 2 02-13-2003 07:52 PM > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:59 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration