-   Slackware (
-   -   vbetool vgamode WHAT NUMBER? Or where is the rdev command? (

stf92 11-14-2012 03:01 AM

vbetool vgamode WHAT NUMBER? Or where is the rdev command?
Slackware 14.0

I run 'apropos' and find two programs: rdev and vbetool. But rdev is nowhere to be seen. So I fall back on vbetool. But vbetool does not behave as explained in the man page. But first, to the point. Having at this very moment /dev/ttyN for any N in a high resolution state, I want to have it as I had it under 12.0, which I think is no VESA BIOS mode at all, but normal vga.

To add the line 'vga = normal' in lilo.conf won't do. So I am trying with

$ vbetool vgamode <some_number>
But if I use some_number = -1, which seems to be normal vga, I get:

$ vbetool vgamode -1
Real mode call failed.

Where do I get a list of valid numbers for the argument to vgamode, that is, for some_number?

malekmustaq 11-14-2012 09:19 AM

Have you tried 'vga = 773'
'vga = 790' or
'vga = 791'

What came out?

Didier Spaier 11-15-2012 06:04 PM


stf92 11-15-2012 11:32 PM

In some other thread I was directed to wikipedia, which has an article on the VESA BIOS,where there is a list of the VESA modes. But the solution came from another quarter. It is contained here but, briefly, I put


in lilo.conf

Remember the whole thing was about having the video card in the mode it is in when the boot prompt is printed on the screen and you booted from slack disk #1. At some point between 12.0 and 14.0 a change was made by the guys at slack as a result of which after the boot process is complete you find yourself in one of the VESA modes.

All times are GMT -5. The time now is 08:33 AM.