-   Slackware (
-   -   various Slackware 14.1 problems. (

dchmelik 11-11-2013 10:08 PM

various Slackware 14.1 problems.
I am having various problems with Slackware64 14.1, after downloading the torrent, verifying the ISO md5 sum (but not GPG .asc, which I had not done before but may have a problem.) First, I suggessfully upgraded from 14.0, but reinstalled when someone on Freenode ##slackware said installing SlackBuild packages I had made from could be the problem. Then I also upgraded Slackware64 on my laptop (which never could boot Free/Libre Software from hard drive, but the DVD would not boot on it, so I had to remake the ISO without GRUB and without it being for UEFI.) The following problems occur with Slackware64 14.1 on two different machines (the Mozilla ones also reported by several others and maybe listed as an unresolved bug, and when I booted a Slax 7.0.8 live CD afterwards, I did not have these problems with Firefox, the only of these I tried so far on Slax.)


d@cosmos:~$ firefox
(process:5335): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed
Segmentation fault
d@cosmos:~$ seamonkey
(process:5351): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed
Segmentation fault
d@cosmos:~$ thunderbird
(process:5363): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed
Segmentation fault
d@cosmos:~$ emacs
Fatal error 11: Segmentation fault
Segmentation fault
d@cosmos:~$ gimp
Segmentation fault
d@cosmos:~$ geeqie
Segmentation fault

ReaperX7 11-11-2013 10:13 PM

How exactly did you burn the disk?

Did you burn the disk at maximum speed or slowest speed?

dchmelik 11-11-2013 10:20 PM

For the one I actually used a DVD disc on, I used K3B at one of the slowest speeds I could, and used K3B's option to verify the disc was written correctly. For the main computer, at least the second time, I installed from a hard drive partition I had copied the ISO's contents to after mounting it with loopback.

ReaperX7 11-11-2013 10:42 PM

Okay, so which computer exactly had the issue?

dchmelik 11-11-2013 10:47 PM

both (as I said, the error rresults are from both, except for one Mozilla program also doing three of the segmentation faults in a row from one program on the laptop.) Someone on IRC said this may be a problem with glib or something, because of not using UEFI... I never expected to see GNU glib depend on UEFI, but I guess the thing may be that now manufacturers do not care so much about making the non-UEFI BIOS part work properly.

ReaperX7 11-11-2013 10:54 PM

It might not be UEFI directly. Sometimes it can be a package that has a problem and needs to be rebuilt.

Check the Slackware64-source archive and see if you can get the slackbuild and sources for packages that are corrupted somehow and attempt to rebuild them. Any error should indicate a library might be missing, corrupt, or not installed.

How much exactly did you strip from the system when you removed Grub2?

dchmelik 11-11-2013 11:09 PM


Originally Posted by ReaperX7 (Post 5062926)
How much exactly did you strip from the system when you removed Grub2?

I meant I made the DVD boot only with lilo; I did not actually remove grub or any packages. On my PC that I made this year, I think the USB installer booted from UEFI, or if it did not, my DVD from the original ISO did with that (but I thought I had UEFI off because I want a BIOS POST)... for my older (but still 64-bit) laptop, I just made the ISO with the command like described in Slackware 14.0's documentation for making an ISO (except "-m 'source.''') Since I used's torrent, verified the ISO and disc, and used everything from the ISO (just made the DVD not use grub), besides an unmodified USB install as well, I think there is nothing missing (or not installed) or corrupt, unless this happened to everyone... so maybe you mean check Slackware current source.

Richard Cranium 11-12-2013 02:00 AM

Have you run memtest on any of those machines lately?

dchmelik 11-12-2013 02:24 AM


Originally Posted by Richard Cranium (Post 5062983)
Have you run memtest on any of those machines lately?

Though one machine is relatively new, yes (and it at 100%, memtest said there were no problems,) but maybe you missed that after the problems, I ran Slax 7.0.8 live CD, and Firefox worked fine. If this were really a memory problem, I think Firefox would have had the same memory problem that time.

ReaperX7, I downloaded the Firefox source and build from, compiled and installed it, and had the same problem.

I am switching back to Slackware 14.0 until I hear something more about this. I will keep 14.1 on a laptop, or install 32-bit 14.1 on an old PC, in case there is anything else I can try.

dchmelik 11-12-2013 06:56 AM

Slackware 14.1's Firefox works fine for me on Slackware64 14.0, though it does give a message I do not understand, below.


d@cosmos:~$ firefox
GLib-GIO-Message: Using the 'memory' GSettings backend.  Your settings will not be saved or shared with other applications.

Though I ran memtest86+ for an hour until it went through eight tests and showed 100% as being finished, it was still going, and when I looked at the configuration, it said there were 11 tests, so I am not really sure, but the problem does seem to be something other than the RAM messed up on both my military-grade laptop, and several months old PC at once, since, besides what else I said (Slax working, other people having this problem, reportedly listed as an unresolved Firefox bug) this version of Firefox works on Slackware64 14.0.

Another thing I forgot to mention is while Slackware 14.0 can detect my second hard drive (used for data) as having an EXT4 partition, the Slackware 14.1 installer did not detect it, and said there were FAT or NTFS partitions (which has never been the case on these drives), so I had to edit fstab to have that partition mounted.

dchmelik 11-16-2013 03:11 AM

After re-downloading from rsync, and re-upgrading, Slackware 14.1 seems to work fine on my laptop with all those programs (though not tried with my profiles or on the 'net, but that is all likely irrelevant), even after either restarting the whole system for another check, or at least restarting KDE--maybe both. One of the first failures mentioned did let some of those programs start and display, but then crashed them, or never displayed again, then always crashed, so I wanted to double-check.

Most likely, I had finally used my second disc from cdrecord, that was not verified (though the original ISO was), because I do not know how to. When I saw the standard one say GRUB and/or UEFI, I am not sure I installed, or if it worked, or how much I tested, come to think of it. I will have to be more thorough in the future. At least for all my optical disc trouble (mentioned in other threads), I now plan to subscribe to Slackware (when I have a permanent job), also because I never want to see it disappear. Though I wish it were more 'Libre' and that prevented me in the past, even as an associate FSF member, I cannot fully agree with FSF it is more 'moral' to use their less serious, less simple recommendations that feel unusable for me, rather than the most serious & simple (Free) POSIX-based system that fits the computer science definition of user-friendly (not 'idiot-friendly' nor 'user-proof', if the latter or whatever is the common misdefinition).

It may or may not be too difficult for me to make a 'Libre' version (not too difficult to try, but probably too difficult to complete or not burn out on, as one of the not very most advanced users), but I do not see the point, rather than supporting FSF and hoping some more 'Libre' hardware is made, which is more important now than software philosophy/license wars. On one hand, it would be nice for Slackware to be Libre, but that would make things difficult for average users who do not want to spend time debugging drivers and missing software that is only public domain or gratis (the latter two maybe not in Slackware, but unofficial builds/packages). Most/all FSF's recommended alternatives are based on distributions they do not recommend, but I am still waiting to see if they produce something that becomes used more than Linux or that is nicer than the old BSDs, Slackware, or openSolaris/openIndiana, for hackers. I have contributed Free Software bug fixes including one that specified necessary code, but I am not so involved now (as other things) though I wish I was... but I am getting a bit off-topic. Anyway, if I had not gotten 14.1 working finally, I would have wondered what to do, like switching to FreeBSD or investigating the errors and then code in more detail. Looks like, again, Slackware is once again basically perfect, and I made a fool of myself.

I do think it almost became too 'bleeding-edge', as 14.0's first 'stable' kernel update did not boot for me once I installed it with slackpkg and updated the links, ran mkinitrd from the readme, all at least on two occasions... maybe a particular hardware problem, or I was not careful enough... and once, a Perl update made an unofficial package I use (sbotools) to stop working... but that is all another topic.

Thanks for what now I am pretty sure is a nice update to 14.1, and I marked this thread solved.

All times are GMT -5. The time now is 10:24 AM.