LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   util-macros-1.9 install problem (https://www.linuxquestions.org/questions/slackware-14/util-macros-1-9-install-problem-897278/)

steviebob 08-14-2011 03:43 PM

util-macros-1.9 install problem
 
Alrighty, here I am with a newly traded laptop, trying to get the video drivers for it to work (x86-video-ati) to replace proprietary ones and it says it needs xorg-utils 1.8 or higher, and that I have 1.7 installed. Okay, I get that, it's happened before, but I don't remember how I fixed it. So, guessing along the way (as I usually end up doing) I went and downloaded util-macros-1.9, installed it, ran this x86-video-ati installer again, and lo and behold, it still says I only have 1.7 installed. I tried this again, except downloaded and installed util-macros-1.8 but to no avail. Any help would be appreciated

~Steve

kostya 08-14-2011 04:17 PM

And when you run pkgtool, which version of util-macros is it showing? Well you can, after all, uninstall ALL versions and then install version 1.9 after you make sure earlier versions are removed.

PS: and why would one need to replace proprietary video drivers, which are (as a rule) much better then them free ones?

steviebob 08-14-2011 04:24 PM

It says I only have 1.7 noarch installed. And I want to install the open source ones because they tend to be more flexible, and in this case, the free version of the catalyst drivers are just as fast as the proprietary ones, only, you know, open source. I'll try uninstalling all the util-macros. I'll say if it works

steviebob 08-14-2011 06:47 PM

Alright, I uninstalled xorg-macros 1.7 through pkgtool, made a SlackBuild script for 1.9, installed it and it all worked out fine. Thanks for your help :)

kostya 08-15-2011 03:24 AM

Welcome :)


All times are GMT -5. The time now is 12:57 PM.