-   Slackware (
-   -   Using Slackware-Current kernels in Slackware-11 (

davimint 06-05-2007 08:54 PM

Using Slackware-Current kernels in Slackware-11
Hello all,

I would like to see if anyone could help me out understanding why I keep getting a kernel panic-not syncing VFS unable to mount root fs or unknown-block on my system.

The reason for my subject of this post is first I would like to make sure that all of Pat's Current kernels are good to go on a fresh installed version 11 of slackware. I know he's got a new glibc and I wasn't sure if that had any effect on the kernels and if the kernel-headers would play any part on the boot process.

I've got the following working kernels on this partition.
a) vmlinuz-ide-
b) vmlinuz-huge-smp-

I've tried the generic & generic-smp and they both produced the kernel error. I had to try each of them individually due to the fact they both required a initrd and I wasn't sure if two initrd's could exist on the box.

First is the generic.( none smp )
Packages installed.
a) kernel-generic-
b) kernel-modules-
My format is rieserfs so I checked the /lib/modules to make sure I used the correct modules.
mkinitrd -c -k -m reiserfs
Updated lilo.config and ran lilo but still have the kernel panic.

Second is the generic-smp
Packages installed.
a) kernel-generic-smp-
b) kernel-modules-smp-
Checked lib/modules and used these modules.
mkinitrd -c -k -m reiserfs
Updated lilo.config and ran lilo but still have the kernel panic.

I did install the none-arch source just to make sure it was not that and checked both again. My box is a amd64 with nvidia geforce 6100 gpu with ide bus and hard drive.

I will be more than glade to post anything necessary to help me understand this problem.

Thanks for reading such a long post but I'm lost at this point with this error and have not found any post that explains what I may be doing wrong

rworkman 06-06-2007 12:16 AM

The mkinitrd in -current takes care of module dependencies for you, but the one in 11.0 does not; therefore, your initrd is missing some needed modules. Add the mbcache and jbd modules and it should work (assuming I didn't forget one) :-)

As for two initrd's - not necessary -- if you don't pass the -c flag, you can install modules from more than one kernel into the same initrd. The -c flag clears the /boot/initrd-tree/ before doing anything, so if you omit that flag, you keep the existing contents.

davimint 06-06-2007 12:50 AM

Thank you for taking the time to help me understand and I appreciate the points you made. Now,I better understand the course of action that should be taken and the options that are available.

rworkman 06-13-2007 04:23 PM

A bit more information about kernel package incompatibility with -current on 11.0 (it's a post on alt.os.linux.slackware usenet group):

All times are GMT -5. The time now is 09:13 AM.