-   Slackware (
-   -   Using MPlayer with CoreAVC codecs (

0zMe 11-01-2010 08:28 PM

Using MPlayer with CoreAVC codecs
hy everybody,
i'm running a 32bit system installed slackware 13.1.

i'd like to watch a 720p movie but it doesn't run smoothly.
so i tried to install the coreavc codecs.

Did all these instructions step by step:

never got an error mesage.
In my ~/.mplayer/config file I also added vc=coreserve,.

If I start the 720p movie, there aren't any changes. It is still jerking.

I'm not sure that MPlayer is really using the codecs, how can I look if it is using it or not?

Mark Pettit 11-02-2010 02:46 AM

Can you tell us a bit more about your system : graphics card, CPU, memory, other tasks running etc. Are you reading the movie from disk or over network. How is the movie encoded (mp4,h264,divx etc).

Personally i've had great results on my Nvidia card using the vdpau libraries (all from aliens packages). But then my laptop is 64bit with dual core 2.4 ghz and Nvidia graphics. I would expect good results. If you're using a very old machine with ancient graphics (agp) you can't expect miracles.

H_TeXMeX_H 11-02-2010 04:00 AM

For movie encoding just run the movie in mplayer on the CLI and post the output or 'ffmpeg -i movie'.

Indeed, if you don't have a good nvidia card with vdpau, you may have problems. Technically you don't need vdpau, but it helps a lot.

Also, what filesystem do you use ?

0zMe 11-03-2010 11:42 AM

I'm using a Pentium-M 740 1.73GHz laptop with 1gb ram. the graphic card is NVIDIA GeForce Go 6400.

I'm starting the movie from disk. There are movies encoded with h264 and mp4 but both aren't running smoothly.

H_TeXMeX_H 11-03-2010 01:50 PM

That processor is weak. The video card does not support vdpau.

Are you using the nvidia drivers ? If not, install them.

If you are using mplayer, make sure to use the 'xv' video drivers, or 'gl'.

Is CPU usage at 100 % when you run the video (even with above recommendations) ? If so, then it's not good, you probably can't run the video. Make sure to have the processor running at max frequency (turn of frequency scaling, or crank it up). If it isn't, then what filesystem are you using ? (I got stuttering on a very powerful machine using JFS + CFQ scheduler, the fix was to change to deadline, it's probably not in your case, but still).

igb 11-04-2010 10:10 AM

I had similar problem on my asus eeepc 1215N.
As some of you may already know, there are no working drivers for its NVIDIA card(I havent checked it for some time. So if the driver is out there tell me :D ).
For playing HD video I use mplayer-mt (multiThreaded). But your cpu has 1 core. So it probably wont work for you. But if your CPU usage is not at 100% then you may give it a try.

H_TeXMeX_H 11-04-2010 10:21 AM

I think the nvidia drivers do support it, it is listed here:

in fact it is listed twice.


GeForce Go 6400 0x0166 -
GeForce Go 6200 0x0167 -
GeForce Go 6400 0x0168 -

pg99 11-04-2010 11:09 AM

If you run mplayer from command line it tells you which codecs it is using.

You could try the skiploopfilter option which gives mplayer less to do, so may help with juddering, maybe
mplayer -lavdopts skiploopfilter=nonref file.mp4
mplayer -lavdopts skiploopfilter=all file.mp4

0zMe 11-05-2010 06:32 PM

Did install nvidia-kernel and nvidia-driver from and edited my xorg.conf like this:

Section "Device"
Identifier "VESA Framebuffer"
Driver "nvidia"
VideoRam 4096
I started a video from terminal and saw this message here:

Forced video codec: coreserve
Requested video codec family [coreserve] (vfm=dshowserver) not available.
Enable it at compilation.
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
Can't understand why dshowserver isn't available. I didn't get any errors during the installations here (

kite 11-06-2010 07:12 AM

You need a valid license key which cost money. Did you do the step?

0zMe 11-06-2010 02:47 PM

Isn't this version for linux open source?

All times are GMT -5. The time now is 12:28 AM.