LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   using backspace or delete in vi (https://www.linuxquestions.org/questions/slackware-14/using-backspace-or-delete-in-vi-132091/)

Mugatu 01-06-2004 12:22 PM

using backspace or delete in vi
 
i'm used to using vi in other distros. how do i use the backspace or delete key when using vi in slackware 9.1? when i press them nothing happens at all. is there a better CLI editor i should be using?

trickykid 01-06-2004 12:45 PM

Use or try these while in command mode:

x - deletes one character at a time
dd - deletes the whole current line

gnashley 01-06-2004 02:42 PM

You might try using the text editor 'joe'.
I use vi all the time as it's fast and present in all distros in some form or another. In Slackware it is actually 'elvis' in others maybe something else which is wha they don' always act the same. Something I only found out recently is that vi will render html files as well!
'x' deletes characters under the cursor and to the right of the cursor(one at a time)

Kovacs 01-06-2004 06:35 PM

Personally I link vim rather than elvis to vi. As root:
rm /usr/bin/vi
ln -s /usr/bin/vim /usr/bin/vi

Then as your regular user make a file called .vimrc in your home directory, with these contents:

set backspace=indent,eol,start
fixdel

And you can now use backspace when you run vi (which is now really vim).

In my .vimrc I also have:
syntax enable
set number
set autoindent
set tabstop=4

which enables syntax highlighting, shows line numbers, autoindents your code and sets the tab length to 4 characters. There are tons of other options, have a look on the vim website.

There is also an integrated tutorial in vim, it takes about 30 mins and is well worth it to introduce you to some of vim's less than intuitive features... it's a great editor once you get the hang of it.

gnashley 01-07-2004 05:24 AM

Yes vim is also nice. Maybe it was 'jed' I meant to suggest instead of joe. I haven't used them, just know that thex are there in Slack 9.1. One other trick, though for vi- it can be called from within 'less'. This is nice for viewing and then editing files, since if you make a typo in vi, a file will be created with the name you typed. So instead of directly calling a file in vi: vi /etc/X11/XF86Config, I call it with 'less':
less /etc/X11/XF86Config then when i find the section I want to edit just type 'vi' (within less). After exiting vi witn ':q!' or ':wq' it returns you to 'less'. a much safer way to quickly edit files. You have posted are probably familiar with these tricks, but I post them for the benefit of others who may not know.

Mugatu 01-07-2004 07:45 AM

joe worked, and at least it will let me use my backspace and delete keys :D i'll give vim a try as well. thanx for all the input

malo_umoran 01-07-2004 09:51 AM

Re: using backspace or delete in vi
 
Quote:

Originally posted by Mugatu
i'm used to using vi in other distros. how do i use the backspace or delete key when using vi in slackware 9.1? when i press them nothing happens at all. is there a better CLI editor i should be using?

backspace or delete are not standard vi commands.

* ctrl+x deletes char
* d$ deletes rest of the line
* dG deletes rest of the file
* dd deletes line and puts the line in the clipboard
* 5dd deletes line + 4 next lines

etc.

M.

ringwraith 01-07-2004 11:42 AM

I think the most userfriendly of the console based text editors is pico or nano. Just be sure to use pico -w on the config files. I use both it and elvis for all my text editing needs :)

Astro 01-07-2004 03:13 PM

I grabbed a very very nice .vimrc file from somewhere and I can't remember the site or I would post it. It seems to be a problem with terminal emulation as to the backspace problem... for instance.... in console you can backspace fine, however in say Gnome-terminal it doesn't work so well where as in rxvt it works fine. Not sure how to correct this though, and I havn't had much time, but theres my $0.02

Kovacs 01-07-2004 07:42 PM

You should be able to fix that with these two lines in .vimrc:

set backspace=indent,eol,start
fixdel

slackwaresux 10-20-2004 02:46 PM

Quote:

Originally posted by Kovacs
Personally I link vim rather than elvis to vi. As root:
rm /usr/bin/vi
ln -s /usr/bin/vim /usr/bin/vi

Then as your regular user make a file called .vimrc in your home directory, with these contents:

set backspace=indent,eol,start
fixdel

And you can now use backspace when you run vi (which is now really vim).

In my .vimrc I also have:
syntax enable
set number
set autoindent
set tabstop=4

which enables syntax highlighting, shows line numbers, autoindents your code and sets the tab length to 4 characters. There are tons of other options, have a look on the vim website.

There is also an integrated tutorial in vim, it takes about 30 mins and is well worth it to introduce you to some of vim's less than intuitive features... it's a great editor once you get the hang of it.


After hours of frustration, that worked!!! You're a genius, thanks man!!! :D

slackwaresux 10-20-2004 05:28 PM

Actually your solution worked but then I had to start from scratch, when I created the .vimrc file, now the "delete" key does not work. Could you explain the reason why?

Thanks for the help.

levicc00123 10-20-2004 09:04 PM

Here's what did the trick for me:

Code:

:set nocp
:map <BS> ^H
set backspace=indent,eol,start
fixdel
:syntax enable
:set number
:set autoindent
:set tabstop=4


gbonvehi 10-21-2004 12:01 AM

What I would recommend is to copy /usr/share/vim/vim63/vimrc_sample.vim to ~/.vimrc
That will give you all nice things :)

stf92 06-01-2018 04:16 PM

A question: what has .vimrc to do with vi?


All times are GMT -5. The time now is 03:57 AM.