-   Slackware (
-   -   using autofs to auto mount my usb drives (

DesertWolf0132 07-29-2004 01:39 PM

using autofs to auto mount my usb drives
I have recently moved from MDK 9.2 to Slack 10. I have finally gotten everything working save two devices. My Maxtor onetouch USB external hard drive and a cheap little USB pen drive I got free from a vendor. The autofs setup was handled by MDK automatically so this is my first forray into it. Both drives used to automount in MDK so I know they function with Linux. My current kernel is the adaptec.s (I have an adaptec 2940U2W for my cd burner, wich I must say works far better under Slack than MDK) kernel included in the Slack 10 CD. I have read the various previous posts on the topic and here is where I am at.

First I have created an /etc/auto.master, an /etc/auto.removable, and a /etc/auto.removable2 each containing the following:

auto.master contains:
/mnt/removable /etc/auto.removable --timeout=1
/mnt/removable2 /etc/auto.removable2 --timeout=1

auto.removable contains:
usbdisk -fstype=vfat,umask=000 :/dev/sda

auto.removable2 contains:
usbkey -fstype=vfat,umask=000 :/dev/sdb

I also found the rc.autofs script for Slack 10 which basically reads from my auto.master. I then added the following to my /etc/rc.d/rc.M:

/etc/rc.d/rc.autofs start

On boot it starts autofs without error but neither usb drive is mounted. I know I am probably making a newbie mistake and just missing something minor (for instance, are sda and sdb the correct devices?)

gnashley 07-29-2004 03:10 PM

adaptec.s doesn't have compiled-in support for USB, so you may need to load some modules, usb-core and others.
You could also try installing the kernel meant for the wrongly-deprecated ZipSlack. ZipSlack has lots of secrets, including zipslack.s that has support for both adaptec and USB! Also has support for parallel-port IDE and lots of other stuff, so your dmesg is long.
Either that or load the modules before automounter gets called.

DesertWolf0132 07-29-2004 03:58 PM

Thanks for the quick reply.
Checked that. I can now manually mount them with these commands:
mount -t vfat /dev/sda1 /mnt/removable -o
USB Key:
mount -t vfat /dev/sdb1 /mnt/removable2 -o

I have changed auto.removable and auto.removable2 to reflect these changes and ran

/etc/rc.d/rc.autofs restart

still no automounting ability

gnashley 07-30-2004 01:09 AM

I'm not an atuomount user, so I can't really help more, sorry

WMD 07-30-2004 03:08 AM

adaptec.s is a kernel for Adaptec SCSI controllers. Do you actually have a SCSI system? (I think you may be confusing CD-RW SCSI emulation and actual SCSI devices.)

gbonvehi 07-30-2004 03:27 AM

Well if you want them to mount on boot why not use fstab?

DesertWolf0132 07-30-2004 11:10 AM

to WMD: I have an Adaptec 2940 U2W (which is SCSI2 Ultra Wide). I have loaded the USB modules succesfully as shown by the results of the lsmod command (pertinent lines shown here):
usb-uhci 22256 0 (unused)
usbcore 59308 1 [usb-storage usb-uhci]

to gbonvehi: these drives are not always connected to my system. While I can mount and umount them manually, I know the automount system works if I can just work out the details. It would be un-Linux-User-like for me to not try to solve this problem. Who knows, maybe another newbie might read this and find that he has the same trouble and we solved it for him.

to all: thanks for putting up with me. I know the solutions is so close I can taste it.

gbonvehi 07-30-2004 11:21 AM

Maybe you should take a look at /usr/doc/autofs-3.1.7/samples there you have sample configurations to use with autofs (i haven't used autofs and don't have any usb storage to test this stuff, but it should guide you).
Never give up, it's just a matter of time to solve things :)

DesertWolf0132 07-30-2004 11:27 AM

Thanks, I'll tell you how the hunt goes.

All times are GMT -5. The time now is 04:31 AM.