LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 12-20-2007, 07:14 PM   #1
dasoberdick
Member
 
Registered: Aug 2004
Location: Michigan
Distribution: redhat 9.0
Posts: 99

Rep: Reputation: 15
usbserial issues with vendor parameter


I am trying to get my Atmel AT91SAM7S-EK development board working. For this I need the usbserial module. On my other computer, all I had to do was type:

modprobe usbserial vendor=0x03EB product=0x6124

and everything worked fine. On my desktop machine I get the following message:

FATAL: Error inserting usbserial (/lib/modules/2.6.23.8/kernel/drivers/usb/serial/usbserial.ko): Unknown symbol in module, or unknown parameter (see dmesg)

When I go to dmesg I see:

usbserial: Unknown parameter `Vendor'

My kernel is 2.6.23.8 and my distro is Slackware 12. Can someone please help me?
 
Old 12-20-2007, 10:33 PM   #2
Nille_kungen
Member
 
Registered: Jul 2005
Posts: 480

Rep: Reputation: 154Reputation: 154
Is CONFIG_USB_SERIAL_GENERIC=y set in your kernel?
 
Old 12-20-2007, 10:41 PM   #3
dasoberdick
Member
 
Registered: Aug 2004
Location: Michigan
Distribution: redhat 9.0
Posts: 99

Original Poster
Rep: Reputation: 15
it was not but i enabled it. I changed several things though and then it worked. I wasn't sure what i changed to make it work. Would that be it?
 
Old 12-21-2007, 02:17 AM   #4
Nille_kungen
Member
 
Registered: Jul 2005
Posts: 480

Rep: Reputation: 154Reputation: 154
It's usually that option.
Good to hear that you solved it.

Last edited by Nille_kungen; 12-21-2007 at 02:18 AM. Reason: Typo
 
Old 08-28-2008, 10:56 AM   #5
twgbonehead
LQ Newbie
 
Registered: Aug 2008
Posts: 1

Rep: Reputation: 0
Thumbs up Thanks

Thanks, Nille_kungen, your answer helped me as well.
 
Old 08-29-2008, 08:07 PM   #6
mahes173
LQ Newbie
 
Registered: Aug 2008
Location: Perth Australia
Distribution: Linpus Lite
Posts: 1

Rep: Reputation: 0
Quote:
Originally Posted by Nille_kungen View Post
Is CONFIG_USB_SERIAL_GENERIC=y set in your kernel?
Could someone tell me how to set this in the kernel? I am having the same problem with a Prolific USB serial converter
 
Old 05-25-2011, 10:29 AM   #7
searchingfortao
LQ Newbie
 
Registered: May 2009
Location: Vancouver, Canada
Distribution: Gentoo
Posts: 10

Rep: Reputation: 0
I know that this is an old thread, but there's no sense in leaving a question unanswered

You've got two options: set it manually by editing `.config` and setting it to =y, or use menuconfig:

Option 1
Code:
vim /usr/src/linux/.config

Option 2
Code:
cd /usr/src/linux/
make menuconfig
Navigate to Device Drivers > USB Support > USB Serial Support > Generic USB Serial support
Enable it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
usbserial, nokia6100 stellarboy Linux - Hardware 7 09-20-2007 08:13 AM
LXer: Linux Certification: Vendor-Specific or Vendor Neutral LXer Syndicated Linux News 0 01-19-2007 09:33 AM
linux bash - how to use a dynamic parameter in shell parameter expansion expression nickleus Linux - General 2 08-21-2006 04:54 AM
modprobe usbserial vendor=0xdf7 product=0x88 failed error -5 ricardo_duncan Linux - Newbie 0 10-11-2005 08:18 AM
usbserial doesn't create a device spuzzzzzzz Linux - Hardware 2 11-23-2004 03:48 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 05:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration