LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 12-17-2010, 02:20 PM   #1
adtf01
LQ Newbie
 
Registered: Oct 2010
Location: Gweru, Zimbabwe
Posts: 29

Rep: Reputation: 0
USB Wireless Card recognised but cannot connect to network


Hi I have istalled a D-Link wireless adaptor - with the help of this forum.

It is up and running - the light flashes and lsusb identifies it correctly, so does iwconfig.

I can, however, not connect to the network, and I noticed the following errors on boot up.

Trigering udev events: /sbin/udevadm trigger -- type: failed
/etc/rc.d/rc.M: wlan0 Error for wireless request; "Set Nickname" (8BIC) information; "Any ESSID" Set failed on device wlan0; operation not supported.

Lower down I get

Starting rt2870 drivers . . . /etc/rc.d/rc.inet1: wlan0 information "Any ESSID"
Error for wireless request "Set Nickname" (8BIC) set failed on device wlan0 : Operation not supported

What am I doing wrong?

I have on two occassions seen sugstions to use wicd, but how do I use that?

Last edited by adtf01; 12-17-2010 at 02:22 PM.
 
Old 12-18-2010, 09:36 AM   #2
yooy
Senior Member
 
Registered: Dec 2009
Posts: 1,387

Rep: Reputation: 173Reputation: 173
try installing nm-applet or wicd to config wi-fi card graphically (in GUI)

please tell you linux distribution for more help
 
Old 12-18-2010, 10:32 AM   #3
adtf01
LQ Newbie
 
Registered: Oct 2010
Location: Gweru, Zimbabwe
Posts: 29

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by yooy View Post
try installing nm-applet or wicd to config wi-fi card graphically (in GUI)

please tell you linux distribution for more help
I am new to linux - how do I istall wicd?
 
Old 12-18-2010, 10:34 AM   #4
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
There's a Slackware package for it on the mirrors, or on the CDs/DVD, in the "extra" directory I believe. Find the package (ending in .txz) and do "installpkg filename" as root. Here is one mirror with the package for 13.1.

Last edited by Nylex; 12-18-2010 at 10:35 AM.
 
Old 12-20-2010, 01:20 PM   #5
adtf01
LQ Newbie
 
Registered: Oct 2010
Location: Gweru, Zimbabwe
Posts: 29

Original Poster
Rep: Reputation: 0
Ok since I am new at Linux, and have not got anything significant on the machine yet I decided to re-install and start again.

The last message I get on boot is
Starting rt2870 driver ... /etc/rc.d/rc.inet1 ; wlan0 information ; 'Any ESSID'
SET failed on device wlan0 ; Operation not supported.

The light on the stick is flashing.

I installed and ran wicd and it did not pick up any wireles network, yet there is definitely one here.

Any help to get this thing going would be much appreciated!

Last edited by adtf01; 12-20-2010 at 01:24 PM.
 
Old 12-21-2010, 01:45 AM   #6
yooy
Senior Member
 
Registered: Dec 2009
Posts: 1,387

Rep: Reputation: 173Reputation: 173
maybe you should try with different dongle as this tutorial suggest. I think that all atheros chipsed based cars should also work out-of-the-box.
 
Old 12-21-2010, 10:35 AM   #7
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib."
Posts: 4,058
Blog Entries: 1

Rep: Reputation: 1358Reputation: 1358Reputation: 1358Reputation: 1358Reputation: 1358Reputation: 1358Reputation: 1358Reputation: 1358Reputation: 1358Reputation: 1358
Quote:
Originally Posted by adtf01 View Post
Ok since I am new at Linux, and have not got anything significant on the machine yet I decided to re-install and start again.

The last message I get on boot is
Starting rt2870 driver ... /etc/rc.d/rc.inet1 ; wlan0 information ; 'Any ESSID'
SET failed on device wlan0 ; Operation not supported.

The light on the stick is flashing.

I installed and ran wicd and it did not pick up any wireles network, yet there is definitely one here.

Any help to get this thing going would be much appreciated!
In wicd, under preferences, general settings, did you put, "wlan0" (without the quote marks) in the box to the right of the label, "Wireless interface"?
 
Old 12-22-2010, 12:49 AM   #8
adtf01
LQ Newbie
 
Registered: Oct 2010
Location: Gweru, Zimbabwe
Posts: 29

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by cwizardone View Post
In wicd, under preferences, general settings, did you put, "wlan0" (without the quote marks) in the box to the right of the label, "Wireless interface"?
Yes wlan0 is in the general settings tab but it does not show under the network tab, message is no wireless networks found. Windows machines and my phone all find the network
 
Old 12-22-2010, 02:45 AM   #9
ChrisAbela
Member
 
Registered: Mar 2008
Location: Malta
Distribution: Slackware and Debian
Posts: 524

Rep: Reputation: 110Reputation: 110
Before delving into wicd - which personally I found very user-friendly and reliable, the kernel/modules have to detect propserly your hardware. So, first post the response for:

$ /sbin/ifconfig -a
 
Old 12-22-2010, 05:39 AM   #10
Ramurd
Member
 
Registered: Mar 2009
Location: Rotterdam, the Netherlands
Distribution: Slackwarelinux
Posts: 682

Rep: Reputation: 105Reputation: 105
That the LED flashes is a good sign; The errors you may ignore for the moment, I have them as well, as I never bothered to get them removed.

With Slackware by default the program "wpa_gui" is installed, I would go with that one, it should do the job just fine. In KDE go to Applications -> Internet -> wpa_gui

- If you open that one, is there a 'wlan0'? Adapter? If so, you have an adapter.
- Are there any networks listed in the dropdown menu for network? If not: open the tab "Manage Networks" and press the button "scan"
- Do any networks show up?
- Is yours in the list?

If networks show up, but yours doesn't: what frequency are you running at? I noticed I had some issues with detecting networks on 5GHz. If you can, try to set it to 2.5GHz and see if that yields any results.

If things still don't work, please give the information you get by running the following command in a shell (probably as root):
Code:
iwconfig
 
Old 12-22-2010, 09:15 AM   #11
adtf01
LQ Newbie
 
Registered: Oct 2010
Location: Gweru, Zimbabwe
Posts: 29

Original Poster
Rep: Reputation: 0
There is no wlan0 listed in wpa_gui.

iwconfig returns

wlan0 IEE 802.11bgn Mode: Managed Access Point: Not-Associated
TX Power = 13dBm
Retry long limit: 7 RTS thr: off Fragment thr : off Encryption key; off Power Management : on
 
Old 12-22-2010, 09:26 AM   #12
adtf01
LQ Newbie
 
Registered: Oct 2010
Location: Gweru, Zimbabwe
Posts: 29

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by ChrisAbela View Post
Before delving into wicd - which personally I found very user-friendly and reliable, the kernel/modules have to detect propserly your hardware. So, first post the response for:

$ /sbin/ifconfig -a
wlan0 link encap:Ethernet HWadd 00:26:5a:11:ca:59
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txquelen:1000
RX bytes:0 (0.0B) TX bytes:0 (0.0B)

The mac address listed above is the mac address of the stick

Last edited by adtf01; 12-22-2010 at 09:34 AM. Reason: correct typo and add information
 
Old 12-22-2010, 10:03 AM   #13
Ramurd
Member
 
Registered: Mar 2009
Location: Rotterdam, the Netherlands
Distribution: Slackwarelinux
Posts: 682

Rep: Reputation: 105Reputation: 105
getting the feeling wpa_supplicant is not running for some reason.

check: /etc/rc.d/rc.inet1.conf
IFNAME[4]="wlan0"
IPADDR[4]="" # fill in if you don't use DHCP
NETMASK[4]="" # you have to fill this in as well if you don't want to use DHCP
USE_DHCP[4]="yes" # or no, if you filled in the above fields ;-)
DHCP_HOSTNAME[4]="" # usually this can be left empty
WLAN_WPA[4]="wpa_supplicant"

/etc/rc.d/rc.wireless
- does it have the x-bits? (so it can be executed)
- just checked, should not have to be edited

/etc/wpa_supplicant.conf: you may need some editing here. Here's what I have:
Code:
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
eapol_version=1
ap_scan=1
fast_reauth=1

network={
  scan_ssid=0
  ssid="<your ssid (wireless network name)>"
  proto=WPA RSN
  key_mgmt=WPA-PSK
  pairwise=CCMP TKIP
  group=CCMP TKIP WEP104 WEP40
  psk="<your pre-shared key (password)"
  priority=10
}

# plaintext connection
network={
  key_mgmt=NONE
  priority=0
}
Also check if wpa_supplicant is running:
Code:
/usr/sbin/wpa_supplicant -B -c/etc/wpa_supplicant.conf -Dwext -iwlan0
This should get you wireless wired.
 
Old 12-22-2010, 11:13 AM   #14
adtf01
LQ Newbie
 
Registered: Oct 2010
Location: Gweru, Zimbabwe
Posts: 29

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Ramurd View Post
getting the feeling wpa_supplicant is not running for some reason.

/etc/rc.d/rc.wireless
- does it have the x-bits? (so it can be executed)
- just checked, should not have to be edited
What do you mean by x-bits? (sorry I am totally new to linux)
 
Old 12-22-2010, 11:22 AM   #15
adtf01
LQ Newbie
 
Registered: Oct 2010
Location: Gweru, Zimbabwe
Posts: 29

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Ramurd View Post
getting the feeling wpa_supplicant is not running for some reason.
Also check if wpa_supplicant is running:
Code:
/usr/sbin/wpa_supplicant -B -c/etc/wpa_supplicant.conf -Dwext -iwlan0
This should get you wireless wired.
Did the editing of rc.inet1.conf and wpa_supplicant.conf as suggested
Restarted the machine and got the error
Failed to connect to wpa_supplicatnt - wpa_ctrlopen No such file or directory

Tried to see if wpa_supplicant is running as above but got the error
bash /user/sbin/wpa_supplicant: no such file or directory

Please note that when installed I did not create a /user partition.

I created 4 / /swap /home /var
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
USB Dongle - Network recognised but won't connect! MattJUK Linux - Wireless Networking 7 11-24-2008 03:11 PM
Linksys Wireless card won't connect to wireless network battle_scarred Linux - Newbie 3 04-03-2008 04:27 PM
Wire network is ok but unable to connect to wireless and wireless card is not detect vitalstrike82 SUSE / openSUSE 4 11-01-2007 06:56 AM
Card recognised but how do i connect? crw128 Linux - Wireless Networking 1 01-17-2007 01:03 AM
Trying to get USB linksys wireless g 802.11g network card to connect in linux mandriv Raze31 Linux - Wireless Networking 10 08-13-2005 09:39 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration