-   Slackware (
-   -   USB tethering with slackware 14 (

g4ry 01-08-2013 11:40 AM

USB tethering with slackware 14
Hi, I used to tether Android to slackware 13.37 through USB, which it created usb0 and then I just used dhcpcd usb0. But now I'm trying it on slack 14 and slackware is picking my phone up has a storage device.
Should I be loading a module before plugging in the cable?


ponce 01-08-2013 11:55 AM

check if this thread helps

g4ry 01-08-2013 12:50 PM

Thanks for the reply ponce, yeah I tried what was in the link your posted. Well before I had another phone (Samsung Galaxy y) which worked. But my new phone is Alcatel onetouch 903. I've tried live distros like Archbang and Sabayon but no difference, my phone claims that linux is supported. Until now I've been using wifi but sometimes it just handy to plug into usb. I'll have to do some more googling...

dr.s 01-08-2013 06:37 PM


Originally Posted by ponce (Post 4865525)

Ok that was unbelievably easy, I just connected my Android phone to my laptop (previously used the phone's wifi), turned wicd off, turned phone tethering on, typed

dhcpcd usb0
and a new connection was up and running in less than 2 seconds, beats wifi hands down.

Ponce deserves a medal for this post :D

frushiyama 01-09-2013 08:18 AM

Android version
Which version of android do you use? I had same problems with 2.3.3 versions of android, seems to be a problem with that versions.

All times are GMT -5. The time now is 08:32 AM.