LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 02-14-2018, 09:45 PM   #1
ruy
LQ Newbie
 
Registered: Feb 2018
Posts: 21

Rep: Reputation: Disabled
USB stick and external disk nor automount


Hello, first of all excuse my english.
I'm using Slackware 14.2, is the first time and I think that its awesome. In the past I had installed Fedora and after Arch.
Is a fresh install, my problem is that the system not mount automatically the USB stick and the external disk.
I have the xfce desktop, with the options for automount devices (the first and the second checked). I uncheck this options and reboot, and nothing.
Then install pmount (with slpkg from SBO), this work until I turn off the notebook, when I turn on the problem's back.
I was looking for a solution here but I can't find anything, I have no idea if exist some demon that I need to activate (I have acces at plugdev group as user). Also install the xfce-mount-plugin (that not read the external device).
The problem is the same when I login as root.
When I use the command lsusb with an USB stick connected, the result is:

Bus 002 Device 008: ID 0951:1666 Kingston Technology DataTraveler G4
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 002: ID 0458:003a KYE Systems Corp. (Mouse Systems) NetScroll+ Mini Traveler / Genius NetScroll 120
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 0bda:0158 Realtek Semiconductor Corp. USB 2.0 multicard reader
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

The system read the pendrive, but not mount it automatically (as I wish).
Thanks and I hope I was clear.

Ruy
 
Old 02-15-2018, 04:14 PM   #2
mmasic
LQ Newbie
 
Registered: Sep 2007
Location: Belgrade
Distribution: Debian
Posts: 7

Rep: Reputation: 2
udisks2

"The udisks daemon serves as an interface to system block devices,
implemented via D-Bus. It handles operations such as querying, mounting,
unmounting, formatting, or detaching storage devices such as hard disks
or USB thumb drives."
 
Old 02-15-2018, 09:16 PM   #3
ruy
LQ Newbie
 
Registered: Feb 2018
Posts: 21

Original Poster
Rep: Reputation: Disabled
Hello mmasic, I try with the daemon but it doesn't work. Really I have no idea what happen.
The devices are read (I can check this with the command ls -l /dev/sda*, whit the pendrive connected), but not are automount.
The xfce-mount-plugin neither recognise the USB.
The last option is reinstall the SO.

Thanks.
 
Old 02-17-2018, 03:02 PM   #4
dave8671
Member
 
Registered: Mar 2016
Posts: 55

Rep: Reputation: Disabled
How new are you to Linux? If you are really new I suggest using Linux mint which auto mounts any device. I do not think Slackware is a distribution for new users. That said this may help.

https://www.axllent.org/docs/view/au...g-usb-storage/

If you do not understand this above link than try Linux Mint 18.3 or Ubuntu 16.04.3
 
Old 02-17-2018, 03:39 PM   #5
Skaendo
Member
 
Registered: Dec 2014
Location: West Texas, USA
Distribution: Slackware64-14.2
Posts: 747

Rep: Reputation: Disabled
@ruy,

Have you looked through this page and tried some of the things there?:
https://docs.xfce.org/xfce/thunar/using-removable-media

Under "Managing Removable Drives and Media", it looks like you want the first 3 boxes checked, and possibly the last box "Auto-open files on new drives and media" as well.

Or it could possibly be a dconf setting that needs to be adjusted. I do not have XFCE installed so I hope these hints will help.

Last edited by Skaendo; 02-17-2018 at 03:42 PM.
 
Old 02-17-2018, 06:36 PM   #6
keefaz
LQ Guru
 
Registered: Mar 2004
Distribution: Slackware
Posts: 6,230

Rep: Reputation: 712Reputation: 712Reputation: 712Reputation: 712Reputation: 712Reputation: 712Reputation: 712
Is it a sdcard reader? If yes, you may need to install exfat
https://slackbuilds.org/repository/1...em/fuse-exfat/
 
Old 02-17-2018, 08:27 PM   #7
gibal
LQ Newbie
 
Registered: Oct 2015
Location: Blackpool, UK
Distribution: Slackware
Posts: 6

Rep: Reputation: 1
Have you tried adding it to /etc/fstab?
 
Old 02-18-2018, 10:13 AM   #8
Gordie
Member
 
Registered: Aug 2007
Posts: 409

Rep: Reputation: 134Reputation: 134
Quote:
Originally Posted by gibal View Post
Have you tried adding it to /etc/fstab?
My fstab

Code:
/dev/sda4        /                ext3        defaults         1   1
/dev/sda1        /boot            ext3        defaults         1   2
/dev/sda2        /var             ext3        defaults         1   2
/dev/sda3        /home            ext3        defaults         1   2
#/dev/cdrom      /mnt/cdrom       auto        noauto,owner,ro,comment=x-gvfs-show 0   0
#/dev/fd0         /mnt/floppy      auto        noauto,owner     0   0
devpts           /dev/pts         devpts      gid=5,mode=620   0   0
proc             /proc            proc        defaults         0   0
tmpfs            /dev/shm         tmpfs       defaults         0   0
Mine automounts without fail
 
Old 02-18-2018, 05:22 PM   #9
ruy
LQ Newbie
 
Registered: Feb 2018
Posts: 21

Original Poster
Rep: Reputation: Disabled
Hello

@dave8671:
I'm start using Linux around 3 years ago (as I post, fist was Fedora and after Arch). I'm not an expert obviusly, but I think that have some experience (with Fedora I had installed Gnome, but with Arch I have XFCE).
I never had problem with the automount device.
Really I'm not interesting in Ubuntu or Mint, but thank you.


@Skaendo:
I try with this options.
The first time, when I install Slackware works fine. But I have some issues with the compilation of QT5 and then I install all the system again (even make the new partition table and format).
In the new instalation, when I configure all the system (this time using slpkg) and I update all and install new (with slackpkg) the usb port not mount automatically (with the options selected).
Now I'm mounting manually the USB and the external disk (I try with the 2 first boxes checked, rebbot and nothing happen; then I check the 3 boxes, reboot and nothing). But the smartphone is recognized and I can see it as a directory in the Side Panel.
Thanks.


@keefaz:
No, is just a USB port.
Thanks.



@gibal:
A copy of my fstab without anything connected (I mean USB or external disk, just a optical mouse and a base cooler for notebook):

/dev/sda1 swap swap defaults 0 0
/dev/sda2 / ext4 defaults 1 1
/dev/sda3 /usr/local ext4 defaults 1 2
/dev/sda5 /tmp ext4 defaults 1 2
/dev/sda6 /home ext4 defaults 1 2
/dev/sdc1 /fat-c vfat fmask=111,dmask=000 1 0
#/dev/cdrom /mnt/cdrom auto noauto,owner,ro,comment=x-gvfs-sh$
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0
tmpfs /dev/shm tmpfs defaults 0 0


Thanks.
 
Old 02-18-2018, 10:18 PM   #10
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 5,294

Rep: Reputation: 3043Reputation: 3043Reputation: 3043Reputation: 3043Reputation: 3043Reputation: 3043Reputation: 3043Reputation: 3043Reputation: 3043Reputation: 3043Reputation: 3043
What groups are assigned to your user? Slackware does not automatically add the needed groups to be able to automount and it needs to either be done using the adduser command or manually using the usermod command. It should look similar to the following if you use the groups recommended in the adduser script.

Code:
jbhansen@craven-moorhead:~$ groups
users lp floppy audio video cdrom plugdev power netdev scanner
 
3 members found this post helpful.
Old 02-19-2018, 08:50 AM   #11
ruy
LQ Newbie
 
Registered: Feb 2018
Posts: 21

Original Poster
Rep: Reputation: Disabled
Hello @bassmadrigal, this are the groups that have my user:

users lp wheel audio video cdrom plugdev power netdev scanner

I'm not add the floppy group because the noteebok have not a floppy disk reader.

Thank you.
 
Old 02-19-2018, 11:45 AM   #12
keefaz
LQ Guru
 
Registered: Mar 2004
Distribution: Slackware
Posts: 6,230

Rep: Reputation: 712Reputation: 712Reputation: 712Reputation: 712Reputation: 712Reputation: 712Reputation: 712
You have gvfs package installed? (ls /var/log/packages/gvfs*)
 
Old 02-19-2018, 12:23 PM   #13
ruy
LQ Newbie
 
Registered: Feb 2018
Posts: 21

Original Poster
Rep: Reputation: Disabled
@keefaz:
Yes it's installed:

/var/log/packages/gvfs-1.26.3-i586-1

Thanks.
 
Old 02-19-2018, 01:50 PM   #14
keefaz
LQ Guru
 
Registered: Mar 2004
Distribution: Slackware
Posts: 6,230

Rep: Reputation: 712Reputation: 712Reputation: 712Reputation: 712Reputation: 712Reputation: 712Reputation: 712
Do you have udisk and udisk2 installed? (ls /var/log/packages/udisk*)

You could try running ' dbus-monitor ' command on a terminal window, then insert usb key and see what happens.
Normally you should see something like "org.gtk.vfs.UDisks2VolumeMonitor" and usb key label, device name etc
 
Old 02-19-2018, 02:29 PM   #15
ruy
LQ Newbie
 
Registered: Feb 2018
Posts: 21

Original Poster
Rep: Reputation: Disabled
@keefaz:

Yes, I have installed both. With the command, the result is:

/var/log/packages/udisks-1.0.5-i586-3 /var/log/packages/udisks2-2.1.5-i586-2


I run the dbus-monitor and after connect a USB stick, and is running and giving some codes like: "signal time = ... destination =: 1.137 (give one with this value and one with: (null destination) each time) serial = ... path = ...
And still running.
I dont't find anything about org.gtk.vfs..., but yes said org.freedesktop.DBus.
Check yourself:

string "org.freedesktop.Notifications"
signal time=1519071767.840604 sender=org.freedesktop.DBus -> destination=(null destination) serial=133 path=/org/freedesktop/DBus; interface=org.freedesktop.DBus; member=NameOwnerChanged
string "org.freedesktop.Notifications"
string ":1.137"
string ""
signal time=1519071767.840625 sender=org.freedesktop.DBus -> destination=:1.137 serial=24 path=/org/freedesktop/DBus; interface=org.freedesktop.DBus; member=NameLost
string ":1.137"
signal time=1519071767.840640 sender=org.freedesktop.DBus -> destination=(null destination) serial=288 path=/org/freedesktop/DBus; interface=org.freedesktop.DBus; member=NameOwnerChanged
string ":1.137"
string ":1.137"
string ""

And still running.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Thunar does not automount USB stick in Windowmaker on Slackware64-current allend Slackware 4 04-18-2016 08:29 AM
32bit -current+XFCE+usb stick=no automount the_penguinator Slackware 18 12-20-2015 11:53 PM
HAL automount permissions differs between USB HD and USB memory stick Olaus Slackware 5 06-28-2010 06:34 PM
FC3 - usb stick automount after kernel compiling mightyMile Linux - Hardware 0 01-19-2006 02:07 PM
usb stick automount mfrangos79 Linux - Hardware 9 09-19-2005 09:55 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 12:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration