LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   USB mouse thru a USB modem & linux support (https://www.linuxquestions.org/questions/slackware-14/usb-mouse-thru-a-usb-modem-and-linux-support-76120/)

zeppelin 07-26-2003 12:34 PM

USB mouse thru a USB modem & linux support
 
hello everyone. I had Genius NetMouse Pro (ps/2). I switched tao Microsoft Wheel Optical Mouse. Everything works the same, except that I want to PLUG in in USB (rather than ps/2) anymore. (I also have the MS Natural Keyboard PRO [which has sth like a usb hub] and it works great if i plug there my mouse! -in windows of course..)
I don't have place in my motherboard for another USB, so I want to to plug it in my keyboard's USB.
My question is: how will I say to Slackware, to look for the mouse in the USB "hub" of my Keyboard?
thanks..

ps. Someone who will read this post, might think that I am Microsoft fan or sth.. But the products I bought from Microsoft is HARDWARE. And I strongly believe that Microsoft's Hardware Products (mice & keyboards & gamepads) suit me perfect. So this is all about hardware and I hope I don't give help to Microsoft expand the software monopoly..
that was my ps. Thank you for reading, hope you reply.. :D

stevenhasty 07-26-2003 02:00 PM

I have a usb hub with a usb mouse plugged in, and when I installed slack I turned on usb probing. If you have that turned on, it should recognize the hub and it either loads modules automatically or uses drivers in the kernel. This is all I had to do (usb mice and keyboard are pretty well supported nowadays). I think you might have to uncomment some lines in /etc/rc.d/rc.modules but I'm not sure. And you have to change your X config to use the usb mouse, too.

stevenhasty 07-26-2003 03:28 PM

in /etc/X11/XF86Config :

if your Section "ServerLayout" says this:

InputDevice "Mouse0" "CorePointer"

use that mouse name in the Section "InputDevice"

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Device" "/dev/mouse"
Option "Name" "AutoDetected"
Option "Protocol" "IMPS/2"
Option "Vendor" "AutoDetected"
Option "ZAxisMapping" "4 5"
EndSection

depending on how many buttons your mouse has that ZAxisMapping may or may not work for your scroll wheel. you may want to look up which numbers to use.

zeppelin 07-27-2003 05:44 PM

the problem is that the kernel (while booting) doesn't see my mouse, and doesn't let me to type (I have to unplug the mouse from the usb port in the keyboard!)
any ideas?

zeppelin 07-28-2003 05:59 PM

anyone..? :(

Tinkster 07-28-2003 06:05 PM

what does your lsmod say?

Cheers,
Tink

zeppelin 07-29-2003 05:46 AM

a) keyboard freezes when I use the mouse from USB motherboard or hub's port, even though it says it founds the HUB and also the 3 button (?) intelli mouse and all that stuff, it also says about a device not being claimed by any driver.. [these recognition happens only when the mouse is on usb port in motherboard ONLY, cause while on the hub's port, just freezes..]
As I said, I used to have a PS/2 and now It only works fine (?) when i have it plugged in PS/2 but this is temporary for me.. (ok there is also a USB modem working fine, after a mknod I maid)

even now, with the new Mouse in the PS/2, dmesg says about USB:
Quote:

uhci.c: USB UHCI at I/O 0xd400, IRQ 5
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 2 ports detected
PCI: Found IRQ 5 for device 00:07.3
PCI: Sharing IRQ 5 with 00:07.2
uhci.c: USB UHCI at I/O 0xd800, IRQ 5
usb.c: new USB bus registered, assigned bus number 2
hub.c: USB hub found
hub.c: 2 ports detected
parport0: PC-style at 0x378 (0x778) [PCSPP,TRISTATE]
parport_pc: Via 686A parallel port: io=0x378
hub.c: new USB device 00:07.2-1, assigned address 2
usb-uhci.c: $Revision: 1.275 $ time 15:38:38 Mar 11 2003
usb-uhci.c: High bandwidth mode enabled
usb-uhci.c: v1.275:USB Universal Host Controller Interface driver
usb.c: USB device 2 (vend/prod 0x45a/0xb4a) is not claimed by any active driver.
usb.c: registered new driver acm
ttyACM0: USB ACM device

b) lsmod
Quote:

Module Size Used by Tainted: P
ppp_deflate 3256 0 (autoclean)
zlib_deflate 18200 0 (autoclean) [ppp_deflate]
bsd_comp 4312 0 (autoclean)
ppp_async 7520 1 (autoclean)
ppp_generic 15452 3 (autoclean) [ppp_deflate bsd_comp ppp_async]
slhc 5040 1 (autoclean) [ppp_generic]
appletalk 21508 1 (autoclean)
ipx 17316 1 (autoclean)
agpgart 35776 3 (autoclean)
nvidia 1539840 10 (autoclean)
acm 5856 2
parport_pc 14724 0
parport 23264 0 [parport_pc]
uhci 24560 0 (unused)
usbcore 58144 1 [acm uhci]
emu10k1 61288 1
ac97_codec 9512 0 [emu10k1]
soundcore 3332 4 [emu10k1]
emu10k1-gp 1352 0 (unused)
gameport 1452 0 [emu10k1-gp]
ide-scsi 8048 0
apm 9608 1
nls_iso8859-7 3612 4 (autoclean)
nls_cp737 3836 4 (autoclean)
I sometimes see (when i plug my mouse in USB and freezes, if you plug it out, then keyboard works ok) and then I type lsmod, and I see KEYDEV and MOUSEDEV or sth like that..

GOSH! why WINDOZ find it automatically?:tisk:

zeppelin 07-29-2003 03:43 PM

Suddenly the kernel did some MAGIC!
a) in one boot, kernel saw the mouse as INTELLI MOUSE 3BUTTON

b) afterwards I got disappointed..
WHAT DID I DO TO HAVE IT WORKING RIGHT NOW I AM NOT SO SURE..
BUT, I disabled automatic gpm launch while booting.. (this was needed once)
The settings in GPM and XF86CONFIG file were the SAME (and are the same, that is working flawlessly)
After DISABLING the GPM, I had my pc working..
I then tried to enable GPM (automatically, rather than typing manually the stuff- when I did that manually worked fine [the same settings!] and guess what, now it works AUTOMATICALLY and all go well)

I didn't change anything, and all works as I had changed sth.. :|
don't know if anyone believes me, yet I now have other MOUSEDEV, KEYBDEV, INPUT (important!) and HID (or the heck is that!)

Don't know if the problem was that SLACKWARE wanted once to boot without gpm (but that fixed my problem) Go figure..

[the whole thing reminded me a bit of WINDOWS.. hehe]
Now I am happy and working (hope the USB-magic keeps working!)

if anyone has a explaination about the GPM making problem to the kernel I can listen to him.. (you see I don't believe in MAGIC)


All times are GMT -5. The time now is 10:08 AM.