-   Slackware (
-   -   USB Mobile Broadband Install. (

madder 11-22-2012 10:28 AM

USB Mobile Broadband Install.
I've just bought a new USB mobile broadband dongle, which on the device has an install script and a few other files with it too.


I don't know whether to run the install script, when I boot up Slackware the device isn't seen but when reboot from Windows to Slackware it sees my modem as eth*. I can't see any extra modules loaded, anyone have an idea what could be the problem.
Here is the install script.

My older mobile broadband modem I used wvdial to connect to my ISP, but with these new modems I just have to use dhcpcd.

manwichmakesameal 11-22-2012 11:12 AM

Just out of curiosity, have you tried to use NetworkManager with it? I have a Sprint USB dongle and it works like a champ through NM. You basically plug it in, pick your provider and go.

madder 11-22-2012 11:21 AM

Yeah manwichmakesameal, i've tried it with NetworkManager on 14, my older modem works fine with it. Just seems strange how it works when I reboot from Windows and was wondering why install what's on the device for linux if works after reboot from Windows...probably more curiosity than anything.

haeri 11-25-2012 02:18 AM

Do you give KPPP a try? My modem failed to connect with NetworkManager but it work with KPPP.

madder 11-25-2012 10:19 AM

Well I ran the install script and it now shows my USB mobile broadband modem as eth0 when I rebooted. So far I've only seen an extra file added /etc/udev/rules.d/10-Huawei-FlashCard.rules

I haven't tried NetworkManager or KPPP because you only have to run dhcpcd eth0 and I get, and it's all working fine.

xj25vm 11-27-2012 01:54 PM

Several hints which might help:


I've just bought a new USB mobile broadband dongle, which on the device has an install script and a few other files with it too.
If you include the make and model in your post, some people might have more specific suggestions or might have already managed to get the same device working.

Most broadband modems I've seen have two working modes: mass storage mode, and serial modem mode. They tend to switch between the two. Last time I looked, the package usb-mode-switch (the exact spelling seems to vary) handles this. If I remember correctly, it installs a bunch of udev rules, which recognise various usb 3G modems and handle them, forcing them to switch to the modem/serial mode when needed. I can't remember thought if it is included in Slackware by default or it needs to be installed. Checking their home page, it seems development is ongoing with recent versions. You need a recent version, as you need a recent version of their devices database which will recognise your modem.

In order to get anywhere (with ppp or wvdial or any other similar software), your modem has to be seen first as /dev/ttyUSBx or /dev/ttyACMx (if we are talking about a USB dongle). If, after waiting 1-2 minutes for it to initialise, those devices are not showing up, it probably means it is not switching from mass storage mode to modem mode. You can try watching dmesg after plugging the modem in, as many times relevant messages show up there in terms of what is detected.

After you solve the above problem, then you can proceed to configure kppp, pppd, wvdial or any other package of your preference to send the right strings to the modem for initialization and dialing.

Hope the above helps some

madder 11-27-2012 05:27 PM

@xj25vm, sorry I didn't mark this as solved, this seems work a couple of newer modems I've tried. Once I ran the script it works fine, just use dhcpcd eth* and it's up and running.

All times are GMT -5. The time now is 12:00 PM.