-   Slackware (
-   -   USB keyboard won't respond on luks login (

Lethys 05-09-2011 04:34 AM

USB keyboard won't respond on luks login
I just installed slackware 13.37 64 using luks and lvm by following this. However, when its time to enter the password, my usb keyboard won't work. I included the uhci-hcd, and usbhid modules when running mkinitrd, as the link suggested.

titopoquito 05-09-2011 06:03 AM

I experienced the same problem on older installations and found I had to include one of ehci_hcd or ohci-hcd and hid_microsoft (obviously I own a Microsoft keyboard) or else I could not use the keyboard. I can not say which one of the both I needed for I am not at the right computer now, but I guess it would not hurt to include both of them. My order of these modules at the computer where I am right now:

EDIT: Get rid of the smilies in modules list

Lethys 05-09-2011 04:13 PM

Thanks. I included all those modules, and it seems one of them did the trick.

gargamel 05-09-2011 05:17 PM

I am not a mod, but would like to suggest, that you mark this thread as SOLVED, if your problem is --- well, solved. :)


All times are GMT -5. The time now is 01:50 PM.