-   Slackware (
-   -   USB keyboard not recognized at boot (

alexjohnson 10-10-2011 05:18 PM

USB keyboard not recognized at boot
I have Slackware64 13.37 installed with RAID1, LVM2 and LUKS.

When I reboot the machine I get asked to enter the LUKS password but when I try to use a USB keyboard it doesn't respond, I have to connect a PS/2 keyboard to get it to work.

After I enter the password and get to the console login the USB keyboard works and it keeps working until I reboot the machine.

It seems as if the USB keyboard module isn't loaded when I get asked for the LUKS password, I searched and haven't found any solution for it.

Does anyone know how to solve this?


dive 10-10-2011 05:22 PM

Do you have an option in the BIOS for usb keyboards? I know mine has but afair it is on by default. Worth checking though.

alexjohnson 10-10-2011 05:23 PM

Yes, I have USB keyboard support enabled in the BIOS. It was one of the first things I checked.

Thanks though.

beder 10-10-2011 05:25 PM

Never faced this problem myself (I don't even use LUKS), but found a thread here that indicates you have to include other modules on your initrd:

There's also a few others if that one doesn't help (although it looks like it's your exact same issue, so it will probably help you)

dive 10-10-2011 05:27 PM

Yeah sounds like you need to rebuild initrd

alexjohnson 10-10-2011 05:29 PM

OK, I'll try that.


Ilgar 10-12-2011 02:13 PM

You should include usbhid in your initrd (all its dependencies will automatically be added by mkinitrd).

alexjohnson 10-13-2011 08:32 PM

I ran mkinitrd with the extra modules and it worked.

The command I ran was:

mkinitrd -c -k -m ext4:usbhid:usb:ehci_hcd:ohci-hcd:uhci-hcd:hid -f ext4 -r /dev/vg/root -C /dev/md1 -L -R
And then lilo to apply the configuration.

beder 10-14-2011 08:09 PM

That's great news :-)

Perhaps you could set the topic as "Solved" so that future searchers know they'll find an answer for this issue here

Kind Rgds, Felipe Weber.

All times are GMT -5. The time now is 11:55 PM.