-   Slackware (
-   -   USB keyboard and LUKS (

slackwareuser5000 06-26-2012 12:28 PM

USB keyboard and LUKS
Hello everyone,

I have recently installed 32-bit Slackware on a normal desktop with the "Combining LUKS and LVM" configuration for 256-bit AES encryption.

I have a USB keyboard, which I can use perfectly fine in the BIOS setup as well as when booting from the Slackware DVD.

However, after having installed, created an initrd and attempting to boot, I am unable to use the keyboard, hence I cannot enter the password when prompted to do so.

I rebooted using the DVD again, mounted the encrypted file system and examined the load_kernel_modules file. There was no mention of any module related to the keyboard being loaded.
Hence I added "hid", "usbhid" and "uhci-hcd", for reference the only other modules (not related to the keyboard) are "jbd2", "mbcache" and "ext4".

I tried first with modprobe, then when that didn't work I changed it to insmod using the full path of each module. This didn't work either.

Then I tried to disable BIOS support for the USB keyboard to see if the BIOS was somehow doing something bad. This didn't change anything.

The keyboard does not work. It works in lilo but it stops working somewhere around when the kernel boots, perhaps when the system stops using the keyboard support provided by the BIOS. I'm not sure.

I need help with this. I have spent so many hours trying to get this working. I've found others posting similar problems and having them solved by modifying their initrd.
Is it incorrect to add modules to load_kernel_modules? Do I need to do anything else? I have obviously executed mkinitrd and lilo after doing this. What else could be wrong?

Thanks in advance.

bormant 06-26-2012 12:37 PM

All times are GMT -5. The time now is 06:04 PM.