-   Slackware (
-   -   USB install for current broken ? (

Bertical 08-15-2013 05:17 AM

USB install for current broken ?
Rsynced the latest current this morning and created a full install using The installation drops out about 5 seconds after selecting packages with the message that installation is complete but nothing has been done. The slakckware tree seems to be present on the USB drive ( ~ 2.2G ) and I've tried a full install and using tagfiles.

colorpurple21859 08-15-2013 05:24 AM

Are you using 64 bit or 32 bit? You didn't happen to rsync to the wrong one? ie 32 bit instead of 64 bit or vice a versa.

Mark Pettit 08-15-2013 09:16 AM

I've recently installed via USB from the current just a few days previous to the very latest update and it went fine.

mrclisdue 08-15-2013 09:47 AM

Where are your sources? I've found the 5 second install occurs when the installer *finds* the source tree but for some reason doesn't dig deeper, more often-than-not when installing from another partition, but sometimes also with an nfs mount, and perhaps even ftp (not too sure tho').

So, perhaps, try an install from a different mirror....


volkerdi 08-16-2013 07:18 PM

It is indeed broken due to a change in the behavior of "dialog --checklist".

Didier Spaier 08-17-2013 01:32 AM

If that can help narrow things a bit, besides maketag*, following scripts make use of that option:

But pkgtool works for involved functions (choose packages to remove and choose installation scripts to run again, in the latter case even if all scripts are selected).

EDIT I just see that last batch of updates should have fixed that, so thanks for the fix and sorry for the noise.

zerouno 08-19-2013 08:48 AM

"dialog --checklist" on the script is present not only on the installer but even on the package pkgtools-14.0-noarch-2

Didier Spaier 08-19-2013 11:33 AM


Originally Posted by zerouno (Post 5011876)
"dialog --checklist" on the script is present not only on the installer but even on the package pkgtools-14.0-noarch-2

Yeah, but that is solved now AFAIK, adding option ' --output-separator "#"' to the main dialog of SeTPKG and setpkg. Not all" dialog --checklist" needed a fix. Or do I miss something?

PS To be accurate is not present in the installer. It is called from the installer after packages' installation and can be called as well in an installed system (usually by pkgtool, also shipped in pkgtools package).

guanx 09-11-2013 04:35 PM

I'm having exactly the same issue using DVD install with the "Mon Sep 9 03:34:59 UTC 2013" snapshot of slackware-current.

Has the bugfix been reverted?

All times are GMT -5. The time now is 04:09 AM.