-   Slackware (
-   -   USB file transfer from HP slate 7 (android) to stock slackware 14 install (

capnstabbin 09-07-2013 11:36 PM

USB file transfer from HP slate 7 (android) to stock slackware 14 install
so... i've installed slackware 14 on my laptop for the 3rd time (just screwing around), but usually i have my wireless drivers on a disk to install. but not this time. all i have to macgyver this together is: my hp slate 7 with android 4.1.1 and my broadcom driver source/slackbuild files on it, a USB connection and my laptop with full package install of slackware14 (no wifi, hence the problem, also: one slackware x64 dvd). the android can transfer files through MTP and PTP, but i dont have a way to get any of the applications for thisthat ive seen online onto my laptop. are there any that come stock? i am able to connect and transfer picture files using PTP, but i am unable see any .tar.gz files i would try to put there (/storage/sdcard0/DCIM/Camera/) so i also tried "$ cat ~/driversource.tar.gz >> /storage/sdcard0/DCIM/Camera/IMG_2013xxxx_xxxxxx.jpg" on my tablet to see if i could then try to at least "piggyback" the data through to my computer, but no luck. is there a way to connect MTP or PTP from android to slackware without a bunch of downloads? like longhand? seems like something i should know anyways...

volkerdi 09-07-2013 11:44 PM

You could try using bluetooth instead.

Edit: nevermind. I'm guessing since you don't have wifi that you don't have bluetooth either.

capnstabbin 09-08-2013 12:29 AM

no i dont think so. i ran '/etc/rc.d/rc.bluetooth' after setting it to executable with no error but 'hciconfig -a' returns no output. also 'dmesg | grep bluetooth' returns nothing. the HP product number of my laptop is 'fe701ua#abc', aka: dv9904ca, which doesnt list bluetooth. thx tho. i have a wifi card in my laptop, the purpose of this is to get the driver source and slackbuild onto the pc without burning them to a disk (would need another computer w/burner)

AlleyTrotter 09-08-2013 09:36 AM

Take a look at the udev rules in '/lib/udev/rules.d/69-libmtp.rules'. Using them as a model make a udev rule describing your device and place it in a file named something like '/etc/udev/rules.d/91-myslate.rules' and you should be able to connect using mtp.
I did this once about three years ago and don't remember all the details. I believe I got the manufactures and device codes using lsusb.
Wish I could remember more
In my /etc/fstab I found a commented line which I believe was related to the old episode with mom-in-laws Arnova

# /dev/sde      /media/ARNOVA  vfat    noauto,rw,nosuid,nodev,uhelper=hal,users,utf8,shortname=mixed,flush    0  0
on second thought maybe not, but worth investigating[/EDIT]

capnstabbin 09-08-2013 10:00 PM

this information is appreciated, i will look into it.

capnstabbin 10-07-2013 12:27 AM

i did solve this problem using a bluetooth dongle i went and bought. although the immediate solution would have been the "mtp-tools" group (installed with slackware 14.) specifically "mtp-getfile" and "mtp-sendfile". there is a bug tho: "mtp-files" and "mtp-folders" (for getting a list of files/folders from the MTP device) won't always report all the files present, even after rescanning the sdcard with a separate app. the only way i found around this was to move the file(s) between locations on the android's internal SD, until they just "show up" in the output of mtp-files/mtp-folder, and then you can establish a file ID to pass to mtp-getfile. SWED.

Bourbon 10-15-2013 02:15 PM

Hi All,

Ask permission to come in this thread because I have the same problem with my
Slackware 14.0 KDE 32 bit installed over a computer desktop and Samsung Galaxy
Note 2; no problem to transfer using bluetooth or Airdroid but due my miserable
and expensive Internet connection I should like to work offline transferring
files by usb connection.
Seems that is possible installing Android SDK and a file manager recently
developped to do that (sorry, forgot the name), I skip this opportunity because
the Android SDK package is very large (around 500 MB).
Another attempt of mine involved the installation of Kies (Samsung) under Wine
(don't shoot me, please), simply not working.
The most serious and correct way is the installation of Slackware packages
involving "MTP", for what I know we have two different opportunities but both
of them failing (the device does not mounting or the process die).
I describe the steps done by myself with both packages.

Package nr. 1 = kio-mtp
After installation have been creating a file concerning "udev".
Path & Name file = /etc/udev/rules.d/51-android.rules
Content of the file:
# Samsung
SUBSYSTEM=="usb", SYSFS{04e8:6860}=="04e8", MODE="0777"
After that:
chmod a+r /etc/udev/rules.d/51-android.rules
(also restart the system)
lsusb data:
Bus 001 Device 008: ID 04e8:6860 Samsung Electronics Co., Ltd GT-I9100 Phone
[Galaxy S II], GT-P7500 [Galaxy Tab 10.1]
Final result = the proces die
My opinion = the device is not mounted
(KDE window shows the device but clicking on the right's icon can't mount)

Package nr.2 = mtpfs
After installation have been creating the folder /mtp under /media and a new
string in /etc/fstab
mtpfs /media/mtp fuse defaults,users,noauto 0 0
(the user is already in the group "audio")
After plugging the device giving the command:
$ mount /media/mtp
Final result = can't mount the device

Thank you for your kind attention

Best Regards

All times are GMT -5. The time now is 07:40 PM.