-   Slackware (
-   -   USB 2.0 Jump Drive (

mrgoodtrips 09-22-2005 06:42 PM

USB 2.0 Jump Drive

I have a Memorex USB 2.0 jump drive that I want to be able to mount in Slackware. I have the drive formatted using FAT, and it is visible in Windows and I can mount it without issue on a machine where I run RedHat Enterprise. When I try to mount it on my slackware box, however, I get an error saying "mount: No medium found." I am able to mount other USB drives on the box, which I believe are USB 1.0 or 1.1.

I have tried googling around for a good solution, and I have also tried recompiling the kernel for USB 2.0 support, inserting an "ehci" module, and various other work-arounds, but to no avail. Is it possible that I need to download a more up to date driver and recompile? Has anyone seen this before with slackware?

Any help would be greatly appreciated, and I'll be happy to post file dumps or error message text if that would help a kind soul troubleshoot my problem - just tell me what you want to see.

Thanks in advance.

dracolich 09-22-2005 07:22 PM

First try fdisk -l to see if it's detected as a device.

What is the exact command you are using to mount it? It should be something like this:

mount -t vfat /dev/sda1 /mnt/mountpoint

If yours is not sda1 use yours.

rhb327 09-22-2005 07:48 PM

I would recommend a look at:

1) lsusb
2) and cat /proc/bus/usb/devices

...just see if the device is being recognized at a low level. Also, if you use any custom rules, have a look at /etc/udev/rules.d/udev.rules to ensure there's nothing odd...I don't really think your isse is in the rules though. Just fyi, I have a dual partitioned jump drive working this way with some custom rules on a 2.6.13 kernel.


jaws_tas 09-22-2005 08:21 PM

Similar problem
I had a similar problem with fedora 4 not mounting the drives on my USB 2.0 Zaurus. It was identified by the usb subsystem but not correctly handled by the usb-storage module. So I could see it in dmesg, but I got the same error "no medium found".

I found a kernel upgrade to 2.6.12-1 fixed the problem. Maybe this will work for you too.

mrgoodtrips 09-23-2005 10:47 AM

Hi guys - thanks for the responses.

@jaws_tas: Unfortunately, upgrading the kernel is not an option. The entire OS is a production level setup for target machines in the field, and everything is under tight version control. We're also making use of a RTAI kernel which needs the base we currently have. That sounds like a good suggestion though.

@rhb327: I do not have the executable "lsusb" residing anywhere in the filesystem. A "locate lsusb" came up with nothing. I also do not have a usb directory in "/proc/bus". The closest thing that I seem to have is a /proc/scsi directory where USB jump drives appear when I connect them. A dump of /proc/scsi/usb-storage-0/0 is:


  Host scsi1: usb-storage
      Vendor: Memorex
      Product: TD 2C
Serial Number: 09B08150A363897B
    Protocol: Transparent SCSI
    Transport: Bulk
        GUID: 08ec000809b08150a363897b
    Attached: No

This indicates to me that it does recognize the device.

@dracolich: You are exactly right regarding the command that I've been trying to use ("mount -t vfat /dev/sda1 /mnt/usb" to be exact.) The contents of fdisk -l are:


Disk /dev/hda: 255 heads, 63 sectors, 4998 cylinders
Units = cylinders of 16065 * 512 bytes

  Device Boot    Start      End    Blocks  Id  System
/dev/hda1  *        1      4967  39890403+  83  Linux
/dev/hda2          4967      4998    256000  82  Linux swap

This seems odd, considering that both dmesg and the proc files indicate that the OS recognizes the drive. When I try fdisk -l /dev/sda1 I get nothing at all....

Edit: I tried fdisk again with my USB 1.0, which I know to work and there was an entry in there for /dev/sda1. Clearly, the drive is not being recognized in the partition table. Does anyone know what the next logical step I should take is?

Again, thanks all for the help - if I can get this up and running, I will be quite a happy man.

wpyh 09-23-2005 08:30 PM

I don't understand "the drive is not being recognised in the partition table". But I suggest you run fdisk -l /dev/sda, then see what happens.

mrgoodtrips 09-27-2005 10:43 AM

fdisk -l /dev/sda

returns nothing.

liquidtenmilion 09-27-2005 05:50 PM

maybe it is being detected as a different device?

maybe "dmesg" can reveal something.

EDIT: Of course after you plug in the usb stick.

mrgoodtrips 09-28-2005 10:12 AM

Once I plug in the jump drive, the contents (last 25 lines) or dmesg are as follows:


BCRSI module version BCRSI_1.0_20050710 tasks started
Intel(R) PRO/1000 Network Driver - version 5.5.4
Copyright (c) 1999-2004 Intel Corporation.
e1000: eth0: e1000_probe: Intel(R) PRO/1000 Network Connection
e1000: eth0: e1000_watchdog: NIC Link is Up 100 Mbps Half Duplex
keyboard: Timeout - AT keyboard not present?(f4)
keyboard: Timeout - AT keyboard not present?(f4)
hub.c: new USB device 00:1d.1-1, assigned address 2
hub.c: USB hub found
hub.c: 4 ports detected
hub.c: new USB device 00:1d.1-1.3, assigned address 3
input0: USB HID v1.10 Keyboard [Logitech Logitech USB Keyboard] on usb2:3.0
input1: USB HID v1.10 Pointer [Logitech Logitech USB Keyboard] on usb2:3.1
hub.c: new USB device 00:1d.1-1.4, assigned address 4
input2: USB HID v1.10 Mouse [Logitech USB-PS/2 Optical Mouse] on usb2:4.0
hub.c: new USB device 00:1d.2-2, assigned address 2
scsi1 : SCSI emulation for USB Mass Storage devices
WARNING: USB Mass Storage data integrity not assured
USB Mass Storage device found at 2
hub.c: already running port 2 disabled by hub (EMI?), re-enabling...
usb.c: USB disconnect on device 00:1d.2-2 address 2
hub.c: Cannot enable port 2 of hub 1, disabling port.
hub.c: Maybe the USB cable is bad?

The bolded section is what, I believe, is relevant to me plugging in the jump drive. The rest appears to be me loading a network module, and the other USB/hub stuff is the result of me having the PC set up on a KVM switch that operates on USB.

All times are GMT -5. The time now is 09:29 AM.