-   Slackware (
-   -   Upgraded To KDE 4.1...and lost some sound? (

27thSunshine 01-03-2009 02:35 AM

Upgraded To KDE 4.1...and lost some sound?
Okay, to me this doesn't make too much sense, but maybe it does to everyone else:

I had all my sound working - music, movies in vlc, youtube. Things were good. After I upgraded KDE from 3.5 to 4.1, I lost 2/3rds of this functionality - I now have a picture in VLC but no sound, and youtube...well, if I have an audio player open, youtube will play video with no audio. If I Don't have an audio player open, youtube will play 2 seconds of audioless video and then stop playing and refuse to go any further. Always 2 seconds, every video. MP3s work just fine in Amarok/XMMS.

Actually, now that I think of it/look into it...all of my internet has lost sound. Anything on line that plays sound, doesn't anymore. Its as if FF has a mute button.

Does this sound familiar, or fixable at all?
I'm sorry, but I'm a bit new at this and don't exactly know where to start looking [with commands and such]..thank you much ^^;;

chakkerz 01-03-2009 06:28 AM

well, one thing to try would be to `mv ~/.mozilla ~/mozilla-backup` which removes your firefox configuration, which would confirm (or deny) that it is firefox that's the cause. This will also nuke plugins you've got installed, but you can always copy those back. If you want to undo this, just `rm -rf ~/.mozilla && mv ~/mozilla-backup ~/.mozilla`. Also this doesn't account for VLC.

More likely is the other thing i would investigate, which would be the sound settings. KDE 3.5 (and others as well user aRts for sound, which has been replaced in KDE 4.x [apparently for gstreamer???]). Check for the control panel (i think they renamed it in KDE 4.x but i believe it was kontrolpanel)

Lastly, i'd check the alsa-mixer (console) settings (kmixer might do the same thing, i forget) and see if your video or any other output is muted... though i don't see how alsa (or firefox) would have been affected by a KDE update, though kmixer's settings being updated could have gone to a different default config so that one also seems plausible.

chakkerz 01-03-2009 06:33 AM

i assume you've read:

(or wherever you got it from) and took particular note of the kde3-compat thing (check your /var/log/packages to see if you've got it installed ... ). lists the files in question

There are also two scripts in that directory (ftp, not /var/log/packages) for up and downgrading...

Eternal_Newbie 01-03-2009 09:00 AM

I just uninstalled KDE and installed KDE 4.1.3 on my main Slackware 12.2 install. I followed the instructions in the readme to the letter (also renamed my ~/.kde directory). I have no sound at all after starting KDE 4, even after exiting and running XFCE there is no sound.

I have 2 sound cards, the built-in Intel sound and an Audigy 2 , the second being the ALSA default. At first I assumed that KDE4 was forcibly routing all sound to the Intel chip, ignoring my ALSA settings, but apparently not. According to alsamixer and xfce-mixer, the levels on both cards appear ok, and there is no sound whichever card the speakers are plugged into (analog out). Any ideas?

Strangely, when I previously ran slackware-current with KDE4 under VirtualBox with the additions, the sound in KDE4 worked fine in the VM. That is the sound from KDE4 in the VM was audible on the host.

EDIT: I suspect the sound is getting lost somewhere in phonon or gstreamer. There appears to be no way to tell KDE 4 not to use its sound subsystem

EDIT2: no sound output whatsoever, tried audacious, xine, xmms, vlc, amarok and flash in Opera and Firefox.

27thSunshine 01-03-2009 07:09 PM

Thanks for the responses...

chakkerz, I did indeed read it and followed every step on it, successfully installing all kde3-compat packages [as well as, y'know, the rest of 'em].

And now I feel like a moron! I guess I should've tried alsaconf, but I didn't. Now that I have, VLC works!! As for firefox, still no, but I'll try moving the conf file...I'll edit it in in a second.

EDIT: Guh, there's no way of testing without [re]installing FlashPlayer. Hoooooooold on.

EDIT: Well! I didn't reinstall Flash, but I put the old conf back and went over to Facebook..have the SuperPokePets thingie, which'll make a noise...and that noise worked! So I think the actual problem is with FlashPlayer...not FireFox.

Eternal_Newbie 01-04-2009 01:38 PM

Fortunately my sound problems turned out be basically a PEBKAC error.

KDE 4 had routed all sound via a channel on my Audigy 2 which kmix appears to hide and mute by default (seeing as I am using a clean .kde directory). This should have been the first thing I checked. KDE4's kmix also appears to use different names for the channels from KDE 3 kmix (and alsamixer, xfce-mixer and aumix for that matter).

Unfortunately I have no idea what is causing your sound problems.

All times are GMT -5. The time now is 12:47 PM.