-   Slackware (
-   -   Upgraded 2.6.0test9 NIC not working (

matt3333 10-29-2003 11:01 AM

Upgraded 2.6.0test9 NIC not working
Ok i just upgraded to kernel 2.6.0test9 and it went well but then i rebooted and it wouldnt let me back into 2.6.20 and now im stuck in 2.6.0test9 and my NIC doesnt work i believe i have a tulip card. when i was in 2.4.20 i did cat /proc/something cant member and it showed all my modules that were loaded and tulip was in there.
When i boot 2.6.0test9 i get cant locate module tulip and i had rebuild the kernel twice!!!!!! and still nothing i dunno what i can do now im stuck!!!!!


bbeers 10-29-2003 11:30 AM

When you built 2.6.0test9, did you also make modules?
If yes, try modprobe tulip.
What does lsmod return?

What directories do you have in /lib/modules?

Getting back into 2.4.20 is a function of your lilo.conf.
What does it look like?

matt3333 10-29-2003 11:47 AM

Ok im not at home right now because my NIC isent working hehe
yes i did build it with modules. When i try modprobe tulip i get this big error say cant locate module. Ill check lsmod when i get home what should i be looking for and if its not in there how would i get it in there??

for lilo.con it looks like:

image = /boot/vmlinuz
root = /dev/hda1
label = linux
image = /boot/vmlinuz.old
root = /dev/hda1
label = slack.old

thats what it looks liek it worked the first time then i tried to boot into it again and it just loaded kernel 2.6.0test9.


matt3333 10-29-2003 02:20 PM

Kernel 2.6.0 Test
Is mode nothing happened modules can't be found. It seems like its not loaded into the Kernel. I'm going to rebuild Kernel 2.6.0 Test

matt3333 10-29-2003 02:48 PM

Sorry about that last message my girlfirend wrote it for me since I was unable to get to a computer.... and well she screwed the message up lol Its supposed to say LS mod is not working and modules can't be found. They're not loading into the kernel. Although, I did make modules and make modules_intsall . I don't know what wrong so I'm just going to rebuild it.


bbeers 10-29-2003 03:41 PM

I'm guessing you did a make install, which is okay,
but after the second time you do that you may lose
you first kernel. I prefer to move the new kernel(s)
to /boot myself and edit lilo.conf myself, then I can
have any number of kernels to choose from when
lilo starts up (I think up to 16 anyway, never had that
many yet). You may be able to find the original
2.4.20 kernel in your /boot directory and add another
stanza to lilo.conf for booting to it, but it is for sure on
the cd in /slackware/kernels/bare.i/bzImage.

But anyway, back to the NIC issue. Do you have a
tulip driver in the /lib/modules/2.6.0test9/ directory
tree? "find /lib/modules -name tulip.o* -print"

Did you copy the .config from your 2.4.20 source
directory? Or did you make {old,menu,x}config in the
2.6.x source directory from scratch? In which case
you'll need to be sure and specify which network
modules you want to be built byt going through all
the choices and saying "Y" for in kernel, or "M" for
separate modules which you load with modprobe.

Is this making sense?

As an example of what "lsmod" is supposed to return,
here's mine:
bash-2.05b# lsmod
Module Size Used by Not tainted
uhci 24560 0 (unused)
usbcore 58144 1 [uhci]
i810_rng 2624 0 (unused)
i810_audio 21160 0
ac97_codec 9512 0 [i810_audio]
soundcore 3332 2 [i810_audio]
eepro100 19316 0 (unused)
mii 2240 0 [eepro100]
orinoco_cs 4456 1
orinoco 30232 0 [orinoco_cs]
hermes 5796 0 [orinoco_cs orinoco]
ds 6568 2 [orinoco_cs]
yenta_socket 9632 2
pcmcia_core 38112 0 [orinoco_cs ds yenta_socket]
ide-scsi 8048 0
apm 9608 2

So you see, I have a eepro100 NIC and an orinoco wireless pcmcia NIC.

Another handy command is "lspci" which can tell you what PCI
cards your system sees. This will tell us whether you really have a tulip
NIC or just what ethernet controller you do have.

matt3333 10-29-2003 05:57 PM

Thanks for the replies! I know what lsmode is supposed to look like, but this is what I get,

QM_modules: Function not implimented

I went into /lib/modules/2.6.0test9/kernel/drivers/net/tulip and in this directory there is one file and it is tulip.ko and shouldn't it be tulip.o ? In /lib/modules there are three different kernels 2.6.0test9 , 2.4.20 , 2.4.22 . In /boot there is vmlinuz and vmlinuz.old So I edited lilo.conf and added the new image.old and made the label slack.old . What do you mean by everytime I reconpile I have to have another entry?

Thanks again for your replies!


matt3333 10-29-2003 08:48 PM

ya ok well anyways my gf doesnt really know what she is talking about i was telling her over the phone and she was typing it so lol hehe anyways i got back into kernel .2.4.22 by going into /boot/ and changing vmlinuz-ide-2.4.22 to vmlinuz.old and it worked perfectly!!!!! so here i am!!! anyways when i typed lspci the last one is my NIC and it is linksys fast ethernet driver (NC100) i tried looking for that in Networking under make menuconfi and i couldnt find it!!!!! hmmm where is my .config for kernel 2.4.22 ill just copy it to 2.6.0-test9 hopefully that works hmm. Oh i guess u can see that i took ur advice and didnt do make install and it worked out thanx!!!!!!!! anyways getting back my my NIC.

When i look in /lib/modules/2.6.0-test9/kernel/drivers/net/tulip its tulip.ko shouldnt it be tulip.o???? i thought it was kinda werid it being .ko and all??? When i boot kernel 2.6.0-test9 i get dhcpStart: loctl SIOCGIFHWADDR: Device not found then it trys to connect to dhcpcd server or something and it just quits saying cant be found then it goes on with modprobe cant locate modules tulip.ko and dummy ip module. Also it says cant locate ide-scsi module thats the big it!!!! anyways plz help me!!!!!!!!!!! i really really wanna get this kernel working!!! Thanx so far!!


bbeers 10-30-2003 11:03 AM

Well, I guess 2.6.x is different from 2.4.x wrt kernel modules. ;-P
After booting into 2.6, what does "depmod -a" return?

Your config for 2.4.22 is "/usr/src/linux-2.4.22/.config". You can copy
it to /usr/src/linux-2.6.0test9/.config, then run "make oldconfig". It
will only ask you about new config items, which may be a whole lot.

But I still don't know which driver you are loading for your NIC when
in 2.4.22. lspci tells you the hardware, lsmod tells you the driver.

I wouldn't call anything in /boot anything.old; that means almost nothing.
After I make bzImage, I "cp arch/i386/boot/bzImage /boot/bzImage-2.x.x-001"
or some other descriptive name. Then add a new stanza to lilo.conf:
image = /boot/bzImage-2.4.22-015
root = /dev/hda1
label = 2.4.22-015
then run lilo. This never removes any old kernels from your boot options.



matt3333 10-30-2003 11:54 AM

In /usr/src/ all i have is linux-2.6.0-test9.tar and rpm no 2.4.22 or 2.4.20 i checked in /lib/modules/2.4.20 and /lib/modules/2.4.22 but nope nothing???????? maybe i didnt install kernel source at installation??? Anyways im going to reinstalll kernel 2.4.22 and hopefully i can figure whats wrong with the installation of 2.6.0-test9 Ill post back later today Thanx for ur replys!!!


matt3333 11-01-2003 01:36 AM

Ok i believe i found out whats wrong i believe i have to install module-init-tools i believe ill try that and try rebuilding my kernel ONE more time and if this doesnt work thats it i give up!!!!!! hehe anyways thanx for ur help and patients bbeers!!!!


musrum 11-01-2003 01:32 PM

You have got it, matt3333! If you see:

QM_modules: Function not implimented

That means just that, you need to install module_init_tools. I also _strongly_ recomend reading 'Changes' in the Documentation directory of the linux source tree, and getting everything else up to date, if they are not.

All times are GMT -5. The time now is 08:05 PM.