-   Slackware (
-   -   Upgrade to 14, issues with Ralink rt3090 (

mariostg 09-30-2012 10:02 AM

Upgrade to 14, issues with Ralink rt3090
I decided to get my feet wet and attempted to upgrade from 13.37 to 14. It rebooted fine :).

When I installed 13.37, I had some issues but I managed to fix. I blacklisted rt2800{sta, pci, lib} and rt2860sta. Then I symlinked rt3090.bin to rt2860.bin and it was working.

Now, modprobe rt3090 or rt2860 returns FATAL module not found.

I could probably try complete install from 14 and see what happens but I would really like to fix this problem, say for a learning point of view.

Any hint?

willysr 09-30-2012 10:20 AM

probably you forgot to recompile the drivers with the current kernel you are using?

djemos 09-30-2012 11:08 AM

On slackware 14.0, and recent kernels, the rt3090 is supported from rt2800pci. So you have to remove the lines blacklist rt2800{sta, pci, lib} and rt2860sta from /etc/modprobe.d/blacklist.conf
And also remove the symlinked rt3090.bin to rt2860.bin

Then as root run
modprobe rt2800pci
And you are OK.

burbabro 05-02-2013 11:13 PM

I've been running slackware 13.1 on an Asus eee pc 1015pem. I also found that the RT3090 wireless card wasn't working. Like mariostg, I solved it by adding "blacklist rt2800pci" to /etc/modprobe.d/blacklist.conf.

Now I've installed slackware 14.0 on the eee pc. Again, the wireless card isn't working.

In spite of what djemos says, rt2800pci still isn't working.

Blacklisting rt2800pci still prevents that driver from being loaded, but rt2860sta is no longer included in the modules (3.2.29-smp) so it doesn't load. I tried copying the old rt2860sta.ko into the kernel modules directory and then loading it with "modprobe rt2860sta." That didn't work.

So rt2800pci isn't working, and what did work has been removed from slackware 14. Very disappointing.

Erik_FL 05-03-2013 12:02 AM

Have you checked to see if the driver has been renamed? I noticed that there are some "rt2x00" modules though I don't know if they are what you need for that card.

cynwulf 05-03-2013 05:33 AM

Do not blacklist rt2800pci or try to copy the module for the staging driver.

From Linux 3.x onwards rt2800pci supports the RT3090. Disabling and removing staging drivers and merging their functionality into other drivers is pretty standard practice.

Post the output:

# modprobe -r rt2800pci ; modprobe rt2800pci && dmesg | tail

All times are GMT -5. The time now is 01:07 PM.