-   Slackware (
-   -   Upgrade of shared-mime-info (-current): all icons missing? (

niels.horn 10-18-2009 07:21 AM

Upgrade of shared-mime-info (-current): all icons missing?
Just upgraded the latest packages from -current and all my icons went missing.

I tried the normal 'update-mime-database' but it had no effect.
Finally I returned the 0.60 package from 13.0-stable and that gave me all my icons back.

Any idea?

I am using Xfce as a DE by the way...

sahko 10-18-2009 07:47 AM

niels.horn 10-18-2009 07:56 AM

Yes, I searched the forum before posting and tried the update-mime-database (although it is in the script in the package) but that did not solve anything, like I said in my original post.

sahko 10-18-2009 08:08 AM

Did you logout and relogin?

niels.horn 10-18-2009 08:21 AM


Originally Posted by sahko (Post 3723728)
Did you logout and relogin?

Yes, tried that as well... :)
Actually, I also logged out & in again after falling back to 0.60. Only then the icons came back.

I went back to 0.60 as I have some work to do, but I am updating a second machine now to do some tests there.

sahko 10-18-2009 08:41 AM

Alien BOB made a blog entry about this:
FWIW using the two mentioned commands and reloging in worked for me.

grissiom 10-18-2009 08:49 AM

Thanks sahko and alienBOB! It works like a charm! ;)

P.S. When I found problem using slackware I come to LQ for help and it always works! ;D

niels.horn 10-18-2009 09:02 AM

OK, I tried it on another -current (32-bits) box and the two lines:


# update-mime-database /usr/share/mime
(as root)



$ update-mime-database $HOME/.local/share/mime
(as normal user)

Brought my icons back :)

Just wonder why it did not work on this box (64-bits).
I'll try again later when I have some more time, but I'll consider the subject closed as this seems to be a very local problem on this particular box :(

All times are GMT -5. The time now is 11:36 AM.