-   Slackware (
-   -   Upgrade 13.1 to 13.37 problems (

mesuutt 02-05-2012 06:13 AM

Upgrade 13.1 to 13.37 problems
2 Attachment(s)
I upgraded kernel firstly step by step with read UPGRADE.txt.
I did not get any error while upgrade.
After upgrade, I encountered two problem.
1. Keyboard and mouse not working when I start X.I am using xfce as display manager.
2. I cant reach to internet.I cant see my network card in ifconfig command output.
How can I solve these problems?

Thank you in advance

Cedrik 02-05-2012 06:46 AM

1. try copy /usr/share/X11/xorg.conf.d/90-keyboard-layout.conf in /etc/X11/xorg.conf.d directory
then change options like you want (XkbLayout, XkbVariant...)

create 50-mouse.conf file in /etc/X11/xorg.conf.d, with content

Section "InputDevice"
    Identifier    "Mouse0"
    Driver        "mouse"
    Option        "Protocol" "auto"
    Option        "Device" "/dev/psaux"
    Option        "Emulate3Buttons" "no"
    Option        "ZAxisMapping" "4 5"

(change options like you want)

2. What is your network card model ?

mesuutt 02-05-2012 07:37 AM

Firstly thanks Cedrik
I make that you say about X11, but did not change anything.

My network card model is " Realtek RTL8111/8168B PCI express Gigabit ethernet controller (rev 03)"

willysr 02-05-2012 08:56 AM

realtek is well supported, so it shouldn't be a problem
try looking at .new files and merge it

find /etc -name "*.new"

mesuutt 02-05-2012 12:08 PM

I already chanced config files with .new files. I am using 64 bit system.These problems does not relevant with 64 bit,does it?
I can install slackware from the rough instead of upgrade but I want to learn slackware :)

colorpurple21859 02-05-2012 12:58 PM

try rerunning netconfig and mouseconfig as root in a console.

Woodsman 02-05-2012 01:07 PM


2. I cant reach to internet.I cant see my network card in ifconfig command output.
Try deleting /etc/udev/rules.d/70-persistent-net.rules and rebooting.

dwblas 02-05-2012 01:22 PM

Newer kernels and the older generic (not huge) kernels require initrd. If the previous kernel worked fine and this one does not, it is likely that initrd will solve the problem Read the README.initrd file in the /boot directory. You might as well get used to using/creating it as it will be the norm in future kernels. There are several posts here on LinuxQuestions and elsewhere about initrd. Also, when you read the README.initrd file note that you have to add initrd to lilo.config and re-run lilo per the example.

mesuutt 02-06-2012 01:23 PM

Thanks you all for reply
I tried netconfig,mouseconfig and remove /etc/udev/rules.d/70-persistent-net.rules but did not change anything

I detect that when run `lsmod` command, I have seen only 5 modules(intel_agp,intel_gtt,agpgard,i2c_i801, i2c_core).Did am I upgrade missing?

colorpurple21859 02-06-2012 05:39 PM

Did you just upgrade the kernel or did you upgrade everything? The last post in this thread tells how to upgrade to a newer version of slackware. I know it mentions current, but it will work for other versions also.
Sometimes bad upgrades occur and have to do a reinstall of packages

mesuutt 02-07-2012 03:17 AM

Did I upgrade only kernel? I saw that I should use slackpkg for upgrade, but I did not use slackpkg because I think I learn better with manually upgrade with upgradepkg tool.Am I thing mistake? I did not understand that below commands upgrade only kernel?


upgradepkg /root/slackware64/a/pkgtools-*.tgz
upgradepkg /root/slackware64/a/tar-*.tgz
upgradepkg /root/slackware64/a/xz-*.tgz
upgradepkg /root/slackware64/a/findutils-*.txz
upgradepkg /root/slackware64/a/glibc-solibs-*.t?z
upgradepkg --install-new /root/slackware64/*/*.t?z

Where did I do wrong/inadequate on upgrade ?
Forgive me for my ignorant.

Cedrik 02-07-2012 03:24 AM

Please post output with ls -l /boot

mesuutt 02-07-2012 03:31 AM


Originally Posted by Cedrik (Post 4595768)
Please post output with ls -l /boot

I am at work now.Upgrade problem on my home desktop pc. But I am installing slackware 13.1 in virtualbox for try upgrade again . I can give in a little while :)

colorpurple21859 02-07-2012 04:54 AM

when you upgraded the kernel did you also upgrade the kernel-modules and kernel-firmware too? Also need both of those to go with the kernel for a newer kernel to work.

mesuutt 02-07-2012 05:59 AM

Hmm.I did not know I upgraded only kernel. Now I am researching about kernel-modules upgrade and kernel-firmware upgrade.
Can you suggest some links about kernel-modules upgrade and kernel-firmware upgrade?
Thanks you all for helping.

All times are GMT -5. The time now is 12:04 AM.