-   Slackware (
-   -   Updating to KDE 4.7.3 in Slackware 13.37 (

R3V0LV3R 11-05-2011 12:58 PM

Updating to KDE 4.7.3 in Slackware 13.37
Hello everyone.

Hopefully the answer to this question isn't painfully obvious, but it feels like it should be.

I just installed slackware about a week ago. I'm trying to use alienbob's instructions for updating to KDE 4.7.3, but after using the rsync command to download all the repositories, nothing seems to happen. The next step is to cd to 4.7.3, but that doesn't exist anywhere in my directories.

So.... what's the obvious step I'm missing? I suspect there's something I'm supposed to update in my repositories/mirrors beforehand, but not sure.


beder 11-05-2011 03:02 PM

Well, what was the exact rsync command you issued? Did it take long enough to complete as to indicate it really worked and stuff was downloaded?

Try going into the directory you issued the command from and do "find . -name *.t?z" and see if it brings any results
If you don't remember the directory you issue the command from, try doing "find / -name 4.7.3 2> /dev/null" and see if it finds the directory for you

On a side note, for some reason I tend to prefer using wget to download this kind of stuff...
In this case, you would do

wget -r --no-parent
or, if you have a 64bits system,
wget -r --no-parent

Remember that the content will be downloaded inside the directory you issued the command from. Also, wget will download into a folder a hierarchy such as in your current dir

R3V0LV3R 11-05-2011 03:48 PM

The command I'm using is

rsync -av rsync://


Below are the steps you need to take to install or upgrade to KDE 4.7.3.

Make sure you are not running KDE or even X! If you are running an X session,
log out first, and if you are in runlevel 4 (graphical login) you first have to
go back to runlevel 3 (console) by typing "init 3".

To make it easy for you, here is an easy one-line command that downloads the
whole 4.7.R3directory with all the sources, and 32bit and 64bit packages:

# rsync -av rsync:// .

Assuming you downloaded the complete directory tree "4.7.3" with everything
below, you change your current directory to where you found this README
(which is the directory called '4.7.3'). If you used the above "rsync" command
then that would mean a simple:

# cd 4.7.3
And cd 4.7.3 isn't working because that directory isn't created. As you guessed, the command completes way too quickly to have downloaded the content, but there are no errors or anything.

Before I try 'wget', do I really need to exit X in order to just download the data? That makes sense for updates but I didn't think it was necessary when downloading.

T3slider 11-05-2011 03:56 PM

You're missing the . (period) at the end of that rsync command, which tells it to sync it to the current directory.

R3V0LV3R 11-05-2011 04:00 PM


Originally Posted by T3slider (Post 4516775)
You're missing the . (period) at the end of that rsync command, which tells it to sync it to the current directory.

Yeah I had actually tried that too.... same result.

Right now, I'm downloading successfully using wget in place of rsync. I'm still in KDE so hopefully this isn't going to blow anything up. If it does, I guess a reinstall is in my near future.

beder 11-05-2011 04:08 PM

You can download from kde without worries, just exit X right before installing (the upgradepkg commands)

I would make sure to have another window manager working before doing the install in case you have to debug something (although not likely you'll need, i'm currently using kde 4.7.3 under slack 13.37 without problems)
Try issuing startxfce from the command line just to be safe that you have a backup plan (off course, kde must not be running at the same time)

R3V0LV3R 11-05-2011 06:40 PM

Outstanding, beder.

Using 'wget' works like a charm. Posting from the upgraded system right now. Thanks for the help.

Alien Bob 11-06-2011 05:56 AM


Originally Posted by R3V0LV3R (Post 4516772)
The command I'm using is rsync -av rsync://

If you did add that dot at the end, the only thing I can think of is that you also added that hash character at the beginning of the line, i.e. you have run the command as:


# rsync -av rsync:// .
Having the "#" at the beginning essentially makes the rest of the line a comment... it will not be executed.


All times are GMT -5. The time now is 06:19 AM.