-   Slackware (
-   -   Updating Intel Drivers (

Deagger 05-07-2013 11:54 PM

Updating Intel Drivers
I have Slackware 14.0 32-bit.

I tried playing a game called Costume Quest, which I got from the Humble Bundle. I did not use steam nor do I have steam.

I got the error:
"Your GL driver does not support EXT_texture_compression_s3tc, and this title requires it."
along with a black screen.

After googling for around an hour and asking the slackware IRC, I've come to the conclusion that the only way to fix this is updating the drivers, which was what I was trying to avoid.

Now that I know I must do so, I have no idea how so I need help.
Here is my lsmod and lspci.
According to someone on the IRC, from this info, they say I have chipset Intel Mobile 4

According to KInfocenter I have the driver Mesa DRI Mobile Intel GM45 Express Chipset x68/MMX/SSE2.
OpenHL/ES version: 2.1 Mesa 8.0.4

After googling for new GM45 Express drivers, I have come across this:

My question:
Are these the drivers that I need, and if so which ones (if not all of them)? How do I install them?

If these are not the drivers I need, which ones do I need?

If any more info is needed to help me, just ask. Thanks.

T3slider 05-08-2013 12:12 AM

I don't have an Intel chipset so I may be way off the mark here. According to this page, you should be able to enable s3tc using driconf (which has a SlackBuild available at

ReaperX7 05-08-2013 12:24 AM

Yeah, DRIConf will enable S3TC Texture Compression on Intel graphics chipsets.

cynwulf 05-08-2013 04:45 AM

As far as I'm aware you will need to build the s3tc lib - mesa should then just enable it

Deagger 05-08-2013 06:05 PM


Originally Posted by caravel (Post 4947123)
As far as I'm aware you will need to build the s3tc lib - mesa should then just enable it

This worked. Thank you.

H_TeXMeX_H 05-09-2013 01:57 AM

So you don't need to rebuild mesa after installing libtxc ?

cynwulf 05-09-2013 03:24 AM

No, mesa just picks up the s3tc lib if it's installed. It's just a case of building it from slackbuilds and then doing e.g.

$ glxinfo | grep -i s3tc
This should produce some output.

H_TeXMeX_H 05-09-2013 04:58 AM

Ok, I see it works.

Deagger 05-09-2013 06:43 PM

The textures now work, but in both Costume Quest and in Stacking, the game automatically exits after saving/loading.

Here's the error I get:

root@darkstar:~# costumequest
Segmentation fault

I'm running it as root so I don't think that is the problem. I've looked this error up but I can't find a solution. I'm also not sure whether I should make a separate thread for this or just keep this title.

When I run it in strase these are the last 800ish lines:

cynwulf 05-12-2013 07:21 AM

Looks like a bug in the program - regardless you should not be running it as root.

All times are GMT -5. The time now is 12:44 PM.