-   Slackware (
-   -   Updated to kernel 3.0.4 but now source package can not find kernel headers. (

ReaperX7 10-02-2011 08:06 PM

Updated to kernel 3.0.4 but now source package can not find kernel headers.
This started yesterday after updating my kernel to version 3.0.4. This part of Linux is where I usually have issues heavily when I do custom kernels.

After updating my kernel and redoing my symlinks, to the source and all now when I compile a package that looks for the kernel headers it stated they can not be found.

I've tried working around this editing the files that generate errors to manually probe to the direct path of the kernel headers, example:

Where as a package use to have:

I've hasd to edit it to include the full path:

Due to this issue package that are SlackBuilds can not compile unless I do a manual audit of the package to relink the headers as the compiler generate errors one file at a time. I've even had to do this to several kernel headers as well.

Is there anything I can do to restore the kernel headers to a functional state so I don't have to perform a manual audit and edit of all the files as errors are generated?


Fixed the issue.

rfernandez 10-03-2011 02:48 AM

When you compile the kernel yourself you'll just have to worry with the resulting image (bzImage), the .config and files, only. You'll _NOT_ touch any headers nor firmware (although this last one will _mostly_ give you no problem if you install them). The reason you should not touch any headers is that they must be the ones which glibc was compiled with (the kernel-headers package distributed by Slackware). No, there's no problem running a kernel 3.0.4 with the headers from A good explanation about this is at Alien Bob's wiki about compiling your own kernel -

ReaperX7 10-03-2011 07:48 PM

I think I found part of the problem and I don't know why but glibc had an anomaly with it's kernel headers. I fixed up glibc by recompiling it from source and it restored the headers.

I ran a few builds and everything works perfectly now.

The firmware got installed with the modules and kernel.

All times are GMT -5. The time now is 12:32 AM.