-   Slackware (
-   -   updated slack now xfce refuses to load correctly (

simonb1975uk 10-08-2007 04:16 AM

updated slack now xfce refuses to load correctly
Good morning all.

I don't know if this is a coincidence but since I ran slackpkg to upgrade my slack box packages xfce now refuses to load up correctly. The rodent on the screen flashes on and off for a few seconds with plenty of disk activity then the rodent stops flashing, the disk activity stops and all I'm left with is the rodent on my screen and my mouse cursor sitting there displaying the watch icon. I have looked at the file to see if there are any errors in there but I can't see anything in there which would be pertinent to the problem. Is there any xfce specific logs anywhere I can look at?

Thanks in advance,

allend 10-08-2007 07:58 AM

What did you update from?
If you are going from Slackware 11.0 to Slackware 12.0, then there are a number of new packages to be installed and a number of old packages to be removed. See CHANGES AND HINTS.TXT.

simonb1975uk 10-08-2007 08:03 AM

As my sig says I'm already running Slack 12 I am simply updating my packages using
'slackpkg update' then running 'slackpkg upgrade-all'

allend 10-08-2007 08:17 AM

Did you also execute "slackpkg install-new"?

simonb1975uk 10-08-2007 09:51 AM

Just tried that and it thinks about it for a few seconds then comes up: 'No packages match the pattern for install'

allend 10-08-2007 10:09 AM

It sounds as though all the prerequisites should be fulfilled. ( You can always try "slackpkg clean-system" to remove any extraneous packages.)
Does this failure to load only affect xfce? Are any problems apparent with other window managers (KDE, FluxBox, WindowMaker etc)?

BTW- That's a nice box you have there.

simonb1975uk 10-08-2007 10:14 AM

I only tend to use KDE and xfce and KDE seems to be fine. I've just tried downgrading the KDE packages and XFCE is still failing so it's not them, oops!!

simonb1975uk 10-08-2007 10:17 AM

Thanks :-D

allend 10-08-2007 10:32 AM

Does the problem occur when you try to start xfce after logging in as root?

I do not use xfce that much, so I am not aware of any specific logfile.

If the problem only occurs with xfce, then perhaps you should try reinstalling the xfce package.

simonb1975uk 10-08-2007 04:36 PM

I managed to fix it by backing up, deleting and recreating my home directory as I found it worked when I logged in as root. Thanks for all your help allend.

allend 10-08-2007 08:14 PM

Glad that you made it all work!

All times are GMT -5. The time now is 09:52 AM.