LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 12-06-2015, 09:26 PM   #1
TSquaredF
Member
 
Registered: Dec 2005
Location: "The South Coast of Texas"
Distribution: Slackware64-current
Posts: 512
Blog Entries: 1

Rep: Reputation: Disabled
Unwanted Network Manager icon in system tray


I have two desktop computers on my lan, both of which run Current, all up to date. Both of them use very simple networking, just DHCP to my router, which is set to give them the same network address all the time. There are no wireless connections involved. One of these two computers has a Network Manager icon in the system tray. There is a red box, with a white X in it, in the lower right corner of the icon. When the mouse is hovered over this icon, the tooltip says "Networking disabled". This icon appears in both KDE & XFCE. rc.networkmanager is not executable. This is not a big deal, just a nit, but I want to get rid of that icon. Can anyone help?
Regards,
Bill
 
Old 12-06-2015, 09:31 PM   #2
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, and whatever VMs I happen to be playing with
Posts: 13,715
Blog Entries: 22

Rep: Reputation: 3615Reputation: 3615Reputation: 3615Reputation: 3615Reputation: 3615Reputation: 3615Reputation: 3615Reputation: 3615Reputation: 3615Reputation: 3615Reputation: 3615
Never mind. Asked a question that was already answered.
 
Old 12-06-2015, 10:23 PM   #3
Spinlock
Member
 
Registered: Jan 2006
Location: Missouri
Distribution: Slackware -current, Slackware64 -current, Slackware 12.2
Posts: 150

Rep: Reputation: 24
If you uninstall nm-applet, it should go away.
 
Old 12-07-2015, 12:44 AM   #4
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 5,129

Rep: Reputation: 2910Reputation: 2910Reputation: 2910Reputation: 2910Reputation: 2910Reputation: 2910Reputation: 2910Reputation: 2910Reputation: 2910Reputation: 2910Reputation: 2910
Quote:
Originally Posted by Spinlock View Post
If you uninstall nm-applet, it should go away.
There's still gotta be a way to prevent it from showing without resorting to completely removing it. I have the same icon on both of my hard-wired (neither even has wireless capabilities) Slackware systems (one is running a heavily customized 14.1 and the other is an up-to-date -current install). From reading online, most just say to kill the nm-applet program, but it isn't running, so there is nothing to kill. I've dug through the KDE settings and can't seem to find anything that is loading this icon.

I'd like it gone, but I don't want to have to remove programs just to do it. I want to find where it is being launched and prevent that from happening.
 
Old 12-07-2015, 02:28 AM   #5
phenixia2003
Member
 
Registered: May 2006
Location: France
Distribution: Slackware
Posts: 803

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
Hello,

Quote:
Originally Posted by bassmadrigal View Post
There's still gotta be a way to prevent it from showing without resorting to completely removing it. I have the same icon on both of my hard-wired (neither even has wireless capabilities) Slackware systems (one is running a heavily customized 14.1 and the other is an up-to-date -current install). From reading online, most just say to kill the nm-applet program, but it isn't running, so there is nothing to kill. I've dug through the KDE settings and can't seem to find anything that is loading this icon.

I'd like it gone, but I don't want to have to remove programs just to do it. I want to find where it is being launched and prevent that from happening.
In KDE, right-click on the system-tray area (don't click on the icons in the system-tray, but beside one of them).

You should see a context menu with an option called System tray settings.

Select this option, and in the section Display, disable the Extra Items called Network Management.

--
SeB
 
4 members found this post helpful.
Old 12-07-2015, 06:18 AM   #6
chris.willing
Member
 
Registered: Jun 2014
Location: Brisbane, Australia
Distribution: Slackware,LFS
Posts: 466

Rep: Reputation: Disabled
For XFCE, since OP asked about that too, right click on the panel bar and from the popup menu that appears, select the Panel item which opens a submenu from which you should select Panel Preferences. That will bring up a new window with 3 tabs; select the tab named Items in which you'll see an item named Notification Area (external). Select that item and then click on the '-' button on the right hand side.

chris
 
2 members found this post helpful.
Old 12-08-2015, 12:03 PM   #7
TSquaredF
Member
 
Registered: Dec 2005
Location: "The South Coast of Texas"
Distribution: Slackware64-current
Posts: 512
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
@chris: Thanks. That solved it for me. The difference between my two computers was that one had a Notification area, the other did not. Now neither does.
Thanks to all for the replies.
Regards,
Bill
 
Old 12-08-2015, 03:16 PM   #8
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 5,129

Rep: Reputation: 2910Reputation: 2910Reputation: 2910Reputation: 2910Reputation: 2910Reputation: 2910Reputation: 2910Reputation: 2910Reputation: 2910Reputation: 2910Reputation: 2910
Quote:
Originally Posted by phenixia2003 View Post
Hello,



In KDE, right-click on the system-tray area (don't click on the icons in the system-tray, but beside one of them).

You should see a context menu with an option called System tray settings.

Select this option, and in the section Display, disable the Extra Items called Network Management.

--
SeB
Beautiful! Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] network-manager-applet not showing in system tray (KDE) piratesmack Slackware 14 06-15-2010 06:36 AM
WICD tray icon says not connected, WICD manager says conneted to wired network?!?! intheshadows Linux - Newbie 1 12-24-2009 12:15 PM
network manager system tray applet heltgroen Linux - Newbie 5 06-29-2009 06:27 AM
Add an Icon to The System Tray hhamid General 3 09-13-2005 05:11 AM
AMSN icon in system tray, help BlenderGuy Linux - Newbie 6 03-04-2004 10:01 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration