Latest LQ Deal: Linux Power User Bundle
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 01-09-2010, 10:46 AM   #1
LQ Newbie
Registered: Oct 2006
Posts: 17

Rep: Reputation: 1
Unwanted apps starting when logging into KDE

KDE 3.5.4
Slack 11

A few weeks ago, my system locked up and I had to do a hard reboot (hold down power button). When I powered back on, the programs (KDE System Guard, Konsole window, MythFrontEnd) that were running at the time of the lockup appeared again. I exited System Guard and the Konsole window and then restarted normally. However, they keep appearing in the same spot when I log in to KDE. I looked through some logs in /var/log, but I don't see anything I haven't seen before.

I deleted the /home/myuser/.kde/cache-hostname folder and its contents while in single-user mode, but that had no impact.

Help please.


Last edited by pimy; 01-09-2010 at 10:22 PM. Reason: Problem solved using instructions provided by Woodsman.
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 01-09-2010, 11:32 AM   #2
Senior Member
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,153
Blog Entries: 3

Rep: Reputation: 339Reputation: 339Reputation: 339Reputation: 339
check your /tmp file most likely the program running cache was never deleted when the system went down. so when you restart it reads the /tmp file for this . delete what ever you want in tmp EXCEPT! any hidden files.
this should fix the problem if not. in your /home/your_user/ ./kde folder check the auto start. but I am pretty shure it is your tmp. also in kde 3 you may have to when logging out check the save as is now. because when you forced a power down kde kept the running settings.
It looks to the /tmp cache to see what was running last.

last resort caveman style as root delete that users ./kde folder and then log in as the user. it will reconfigure the kdedesktop .or just rename the .kde folder to .kde.old
Old 01-09-2010, 12:17 PM   #3
Senior Member
Registered: Jul 2006
Location: Kolkata, India
Distribution: Debian 64-bit GNU/Linux, Kubuntu64, Fedora QA, Slackware,
Posts: 2,766

Rep: Reputation: Disabled
auto start is in settings --> advanced (kde-4.xx)
Old 01-09-2010, 02:04 PM   #4
Senior Member
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 544Reputation: 544Reputation: 544Reputation: 544Reputation: 544Reputation: 544
Sounds as though you have saving sessions enabled. Open KControl, then proceed to KDE Components, then to Session Manager. In the In Login section select the Start with an empty session button. Save the settings and then restart KDE.
2 members found this post helpful.
Old 01-09-2010, 10:20 PM   #5
LQ Newbie
Registered: Oct 2006
Posts: 17

Original Poster
Rep: Reputation: 1
Thank you all for the feedback. Woodsman, your instructions worked. All is well again.
1 members found this post helpful.
Old 04-01-2012, 12:50 AM   #6
Registered: Oct 2009
Posts: 32

Rep: Reputation: 0
It's the little things in Linux

Also helped me find this on 4.4.5 KDE, in the system settings gui, session manager. Giving you a point on that Woodsman.

Thanks all. Be real, be sober.

Last edited by WSmart; 04-01-2012 at 12:52 AM. Reason: Spelling, Wooder.



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Removing unwanted KDE packages ekinakoglu Linux - Desktop 1 07-04-2008 03:22 PM
removing unwanted apps epona Linux - Newbie 1 01-23-2005 03:08 PM
auto-starting apps in kde foustware Fedora 1 11-16-2004 09:12 PM
Starting apps after starting xfce?? gtgoku Slackware 2 08-21-2004 01:49 PM
Unwanted programs start-up with KDE...? THX1138 Linux - Software 2 02-14-2004 06:56 PM > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 02:43 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration