LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 08-04-2017, 09:13 PM   #1
limpingstone
Member
 
Registered: Mar 2017
Location: Mountain Time Area
Distribution: Slackware64 14.2
Posts: 52

Rep: Reputation: Disabled
Unresponsive Mouse for seconds


Greetings, Slackers!

I have been using Slackware for months, but it wasn't until recently that my mouse started to become unresponsive for seconds when not touching it for a while. I wonder if it is a performance problem or some settings error.

Everything else is fine with the mouse, it is just the lag that concerns me at the moment.
 
Old 08-04-2017, 09:29 PM   #2
upnort
Member
 
Registered: Oct 2014
Distribution: Slackware, CentOS, Ubuntu MATE
Posts: 385

Rep: Reputation: Disabled
USB autosuspend?
 
Old 08-05-2017, 09:57 AM   #3
limpingstone
Member
 
Registered: Mar 2017
Location: Mountain Time Area
Distribution: Slackware64 14.2
Posts: 52

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by upnort View Post
USB autosuspend?
How do I change the settings for autosuspend?
 
Old 08-05-2017, 11:17 AM   #4
upnort
Member
 
Registered: Oct 2014
Distribution: Slackware, CentOS, Ubuntu MATE
Posts: 385

Rep: Reputation: Disabled
Quote:
How do I change the settings for autosuspend?
Running powertop probably is the easiest way to see whether autosuspend is enabled. Launch powertop and tab to the Tunables menu. If USB autosuspend for your mouse is enabled that display will show 'Good'. If autosuspend for the mouse is disabled then the display will show 'Bad'.

To view the actual run-time parameter to modify, run powertop with the --html=filename option to generate an html report. Open the report in a web browser.

On one of my systems the report looks like this:

Code:
Autosuspend for USB device 2.4G Wireless Mouse
echo 'auto' > '/sys/bus/usb/devices/3-1/power/control';
In other words, if I want autosuspend for my mouse, I would run the following:

Code:
echo auto > /sys/bus/usb/devices/3-1/power/control
I do not want autosuspend. On the same system I look at the contents of the file:

Code:
cat /sys/bus/usb/devices/3-1/power/control
On my system the result is 'on'.

If autosuspend was enabled on my system then I would run the following:

Code:
echo on > /sys/bus/usb/devices/3-1/power/control
Be sure to use the respective file path for your system, which might not be '3-1'.

Last edited by upnort; 08-05-2017 at 11:19 AM.
 
3 members found this post helpful.
Old 08-10-2017, 12:07 PM   #5
limpingstone
Member
 
Registered: Mar 2017
Location: Mountain Time Area
Distribution: Slackware64 14.2
Posts: 52

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by upnort View Post
Be sure to use the respective file path for your system, which might not be '3-1'.
Does the command permanently change the configuration?
And when I changed the setting with
Code:
echo auto > /sys/bus/usb/devices/3-1/power/control
it turned off my mouse completely.

Last edited by limpingstone; 08-10-2017 at 12:32 PM.
 
Old 08-10-2017, 12:31 PM   #6
upnort
Member
 
Registered: Oct 2014
Distribution: Slackware, CentOS, Ubuntu MATE
Posts: 385

Rep: Reputation: Disabled
Quote:
Does the command permanently change the configuration?
From the command line, no, won't survive a reboot. In rc.local, yes.
 
1 members found this post helpful.
Old 08-10-2017, 12:34 PM   #7
pan64
LQ Guru
 
Registered: Mar 2012
Location: Hungary
Distribution: debian/ubuntu/suse ...
Posts: 9,790

Rep: Reputation: 2888Reputation: 2888Reputation: 2888Reputation: 2888Reputation: 2888Reputation: 2888Reputation: 2888Reputation: 2888Reputation: 2888Reputation: 2888Reputation: 2888
I would try an(other) USB2 port - and probably USB3 too.
 
1 members found this post helpful.
Old 09-04-2017, 03:37 PM   #8
limpingstone
Member
 
Registered: Mar 2017
Location: Mountain Time Area
Distribution: Slackware64 14.2
Posts: 52

Original Poster
Rep: Reputation: Disabled
I ran the command powertop and the computer just got stuck.

Code:
Loaded 0 prior measurements
Cannot load from file /var/cache/powertop/saved_parameters.powertop
File will be loaded after taking minimum number of measurement(s) with battery only 
RAPL device for cpu 0
RAPL Using PowerCap Sysfs : Domain Mask f
RAPL device for cpu 0
RAPL Using PowerCap Sysfs : Domain Mask f
I cannot even use Ctrl+C to cancel it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mouse unresponsive tehkaao Linux - Hardware 5 07-05-2007 07:29 PM
microsoft wireless usb mouse unresponsive Argent Slackware 4 10-28-2006 08:30 AM
Unresponsive scroll mouse corbis_demon Slackware 6 04-01-2006 02:58 PM
mouse is choppy, unresponsive kupek85 Linux - Hardware 3 10-20-2005 04:02 PM
Mouse Unresponsive after Change Settings lel800 Linux - Newbie 5 02-16-2004 11:22 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 02:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration