-   Slackware (
-   -   Unresponsive interface in slackware (

kainhighwind19 06-22-2013 11:03 PM

Unresponsive interface in slackware
I recently installed Slackware without a hitch, and to my dismay, even after successfully installing the proper Nvidia drivers, everything seems unresponsive and glitchy.

For example, I am unable to change focus from window to window by clicking (90% of the things I try to click don't register) where the keyboard shortcuts work just fine. I've tried 4 different mouses to receive the same results each time.

I thought at first it was just KDE, but I encountered the same errors occurred in wmaker, xfce, and fluxbox. Sometimes programs become unresponsive to any input at all.

I've tried Googling around for a solution, but nobody seems to be having similar problems. Maybe I need to reinstall? IDK, this is my second linux distro I have ever installed (the first being ubuntu). Any help, guidance, advice, or general direction would be much appreciated.

STDOUBT 06-22-2013 11:31 PM

Go ahead and tell us as much as you can about your hardware.
Also, did this happen before you installed the Nvidia driver?
Did you blacklist the Nouveau driver?

Didier Spaier 06-23-2013 04:58 AM

Two other things you could look at to investigate further:

(1) Type 'top' in a terminal to see if some processes are using a huge percentage of your CPU, which could slow down other processes. If yes, try to kill them and see what happens.

(2) As root type "tail -f /var/log/messages". Maybe some process is writing a lot of messages per second, which could be another cause of slowing down.

You could look at other logs in /var/log too.

PS Welcome to LQ and to the Slackware forum.

WhiteWolf1776 06-23-2013 02:35 PM

It helps if you can give some idea of what system you are using, what version of slackware, and what nvidia card / driver you are using along with how you installed it...

oh, and just a shot in the dark... did you install the xf86-video-nouveau-blacklist-noarch-1 ?

Richard Cranium 06-23-2013 02:43 PM

It would be nice if you were to post the contents of /var/log/Xorg.0.log

All times are GMT -5. The time now is 04:33 AM.