-   Slackware (
-   -   unrecognized bash commands and missing directories after 2.6 kernel recompile (

R_Shackleford 12-23-2005 10:46 AM

unrecognized bash commands and missing directories after 2.6 kernel recompile
:scratch: I originally installed Slackware 10.2 on a freshly formatted hard drive, dedicated to GNU/Linux (No M$ on this hard drive.) I used the sata.i kernel during the install and chose the test26 kernel. I later recompiled the kernel (using the guide in the sticky post by DaOne). All was well. Then one day last week I ran swaret to update/upgrade. I over-looked the fact that the kernel-2.4.32 was to be installed. A few days later, I rebooted the machine and instead of my normal "fortune" at login, I was greeted with "bash command not found (or unrecognized, I don't remember the exact syntax). I was able to execute some commands, but only after a su to root. I could not edit text or run lilo. I was able to use a PHLAK liveCD to change the symlinks in /boot, so that I was able to boot the computer with the 2.4 kernel. I re-installed the test26 kernel and was able to reboot into my previous configuration. However, I wanted to use my optimized kernel. I thought perhaps the problem was something in the old config, so I downloaded the latest 2.6 kernel from, and started with a fresh config. I again followed the guide posted by DaOne and all went well (no warning messages) and I rebooted. Again I run into the unrecognized bash commands problem. Has anyone experienced similar issues? I tried removing all previous versions of the 2.6 kernel,, config, and vmlinuz files, as well as /lib/modules/2.6.x/, and used pkgtool to install the slackware packaged kernel and modules from /testing, and I am still having these problems on a recompile. The stock kernel works fine. I am at my wit's end trying to resolve this. I've been poring through dmesg and /var/log/syslog to no avail. Nothing jumps out at me a being a blatant, obvious error. Could this be something as simple as a bad symlink in rc.d or something similar? (Of note: in the original recompile of my 2.6.13 kernel, I did use the APPEND_LOCAL_VERSION option. Fearing this may have been the source of my troubles, I did not choose this option on subsequent attempts.) Someone, anyone, please save me from myself!!!:confused:

sweetnsourbkr 12-23-2005 10:59 AM

Did you enable SCSI support and SATA support? Not sure if you need both, but just in case. Also, make sure you compile all filesystems in the kernel, not as modules.

R_Shackleford 12-23-2005 02:47 PM

I did compile those options into the kernel, not as modules, but this is irrelevant at this point, as the linux hard drive in this box is IDE. I have 1 SATA drive in the machine, but is NTFS.

All times are GMT -5. The time now is 05:40 AM.