LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-29-2010, 03:48 PM   #1
Sylvester Ink
Member
 
Registered: Jun 2010
Distribution: Slackware
Posts: 99

Rep: Reputation: 35
Uninstalling Fglrx


Recently I installed the proprietary ATI video driver, fglrx, on my Slackware 13.1 setup, but I have since decided that I prefer the default open-source drivers. (I can boot to Windows for gaming and would rather have a smooth system for development on the Linux side.)

I had originally installed the fglrx drivers by downloading the file directly from the AMD website and using that file to generate Slackware-specific packages to install with installpkg. After some tweaking they seemed to work quite well with 3d applications, so I know they were set up properly. When it came time to remove the drivers, I used removepkg to uninstall both the fglrx driver and module, then copied back my old xorg.conf file. Unfortunately this did not restore my setup as I had (perhaps naively) expected it to.

From there I assumed that I had uninstalled the fglrx drivers properly, so I decided that I would reinstall the drivers via the ATI installer rather than using the ATI installer to generate packages, then uninstall it using the ati-uninstall.sh script. However, after installing the driver this way, I am unable to find the script, so I'm assuming that I didn't do a clean install. (Also, whereas the package install had worked well with 3d applications, this install did not work.)

Before I go on and mess things up further, I decided I'd ask here and perhaps get a clearer idea of what I should be doing. My end goal is to remove all remnants of the fglrx driver and restore the open-source drivers as default. (Also, any comments on what I may have done wrong when uninstalling the first time, using the Slackware system, will definitely be welcome as I'm still new to the Slackware method of doing things.)

Thanks for your time!
 
Old 06-29-2010, 04:44 PM   #2
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,367

Rep: Reputation: 840Reputation: 840Reputation: 840Reputation: 840Reputation: 840Reputation: 840Reputation: 840
The ATI proprietary drivers overwrite some files from stock Slackware packages. You will have to reinstall those packages after removing fglrx to get back to a conventional install. I am not sure which files it replaces in total -- at least mesa will have to be reinstalled.
 
Old 06-30-2010, 06:49 AM   #3
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 399Reputation: 399Reputation: 399Reputation: 399
The uninstaller for fglrx should be in /usr/share/ati/ . If it's not, then the installation didn't go properly and I would recommend creating the packages, installing them, and then removing them. That should clean up fglrx.

Mesa and the Xserver packages will need to be reinstalled afterward (well, perhaps "need" is a bit strong, but do it anyway).

Adam
 
Old 06-30-2010, 12:56 PM   #4
Sylvester Ink
Member
 
Registered: Jun 2010
Distribution: Slackware
Posts: 99

Original Poster
Rep: Reputation: 35
The uninstaller is missing, but I do still have the packages I created the first time, so I'll give that route a try. As for the Mesa and Xserver packages, I'm assuming they're both on the Slackware CD as individual packages. Thanks for the advice, I'll let you know how it turns out!
 
Old 07-06-2010, 10:14 PM   #5
Sylvester Ink
Member
 
Registered: Jun 2010
Distribution: Slackware
Posts: 99

Original Poster
Rep: Reputation: 35
Okay, looks like that method worked. For those that may have the issue in the future, the problem was solved by installing the fglrx packages (driver and module) over the messed up install, then removing those two packages for a clean uninstall. Then I reinstalled the xorg-server and mesa packages and restored my old xorg.conf file.

Everything is running smoothly again, though I was sure that before the ordeal, Mesa had been able to do direct rendering, and now it is unable to do so. I'm sure I'll be able to fix that up with a bit more tweaking.

Thanks for the help!
 
Old 10-10-2010, 03:39 PM   #6
nass
Member
 
Registered: Apr 2006
Location: Athens, Greece
Distribution: slackware, debian, ubuntu
Posts: 653

Rep: Reputation: 39
Quote:
Everything is running smoothly again, though I was sure that before the ordeal, Mesa had been able to do direct rendering, and now it is unable to do so. I'm sure I'll be able to fix that up with a bit more tweaking.
did you manage to find a solution in the end?
 
Old 10-10-2010, 04:38 PM   #7
Sylvester Ink
Member
 
Registered: Jun 2010
Distribution: Slackware
Posts: 99

Original Poster
Rep: Reputation: 35
Quote:
Originally Posted by nass View Post
did you manage to find a solution in the end?
Yeah, it was just a missing file that the installation of fglrx had deleted. I just reinstalled all the Xorg stuff to be safe and now it seems to work just fine.
 
Old 10-10-2010, 06:03 PM   #8
BrZ
Member
 
Registered: Apr 2009
Distribution: Slackware
Posts: 542

Rep: Reputation: 120Reputation: 120
http://www.x.org/wiki/radeonBuildHowTo

Quote:
Removing AMD/ATI catalyst/fglrx driver (closed source)

You have to first remove fglrx because it overwrites our userspace files and conflicts with our kernel modules. Maybe some day drivers can coexists but not yet :/

First remove all fglrx packages and check that fglrx.ko is not left in /lib/modules/uname -r. If it is there you can just rm it and do depmod -a.

Next step is to reinstall mesa and libdrm. Which should be handled easily by your package manager or make install.

Last but not least is removing fglrx configurations from xorg.conf. With xserver 1.6 or higher you can just rename xorg.conf and trust the auto detect to do the right things.

Now you can reboot to clean system when open driver can function correctly.
 
Old 10-10-2010, 06:03 PM   #9
nass
Member
 
Registered: Apr 2006
Location: Athens, Greece
Distribution: slackware, debian, ubuntu
Posts: 653

Rep: Reputation: 39
hmmm ok I am running 'fine' now.
That is: radeon driver, with KMS enabled , but agpmode set to off.

I have created /etc/modprobe.d/radeon.conf to contain:

Quote:
options radeon agpmode=-1
options radeon modeset=1
also glxinfo tells me that direct rendering is enabled.

First a Question. I read somewhere that xorg.conf is NOT used anymore? I should jsut remove it? or the rest of the sections (f.e. mouse) is still used?

Then my problem. googleearth works, but the image of the rotating earth is like a slideshow. The pc is not new (appprox since 2k4), but I wonder if the radeon driver is pushed to its limits or there is room for improvement.

glxgears gives me a frame rate of 237 fps. the gpu is a ati mobility radeon x300 (based on the chip RV370).

Any ideas?
thank you for your help
 
Old 10-10-2010, 06:07 PM   #10
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 399Reputation: 399Reputation: 399Reputation: 399
What is the output of 'glxinfo | grep -i render'.

Adam
 
Old 10-10-2010, 06:09 PM   #11
nass
Member
 
Registered: Apr 2006
Location: Athens, Greece
Distribution: slackware, debian, ubuntu
Posts: 653

Rep: Reputation: 39
It is:

Quote:
direct rendering: Yes
OpenGL renderer string: Software Rasterizer
GL_NV_conditional_render, GL_NV_depth_clamp, GL_NV_fragment_program,
 
Old 10-10-2010, 06:18 PM   #12
BrZ
Member
 
Registered: Apr 2009
Distribution: Slackware
Posts: 542

Rep: Reputation: 120Reputation: 120
you'll need to search a bit as xorg is removing Hal support. you can keep your xorg.conf and some tweaks are still working, but mouse/synaptics and keyboard settings are being ignored. LQ have some nice threads about it.

kms give low framerates, but the system (2D) feels very responsible. here it is disabled on radeon.conf, but i made a little script to start on demand:
Quote:
#!/bin/bash
rmmod radeon
modprobe radeon modeset=1
 
Old 10-10-2010, 06:19 PM   #13
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 399Reputation: 399Reputation: 399Reputation: 399
So you aren't using 3D acceleration. You are using the software rasterizer.

Attach your /var/log/Xorg.0.log file to a post here.

Adam
 
Old 10-10-2010, 06:26 PM   #14
nass
Member
 
Registered: Apr 2006
Location: Athens, Greece
Distribution: slackware, debian, ubuntu
Posts: 653

Rep: Reputation: 39
what should I search about?

well if kms slows things down i'll probably disable it..it's nice to see half the boot process on the mative resolution but its not THAT important.

I guess I could use the exact opposite from the script you offered me

However, the important thing is , how do I get OpenGL to NOt use the software rasterizer????
 
Old 10-10-2010, 06:28 PM   #15
BrZ
Member
 
Registered: Apr 2009
Distribution: Slackware
Posts: 542

Rep: Reputation: 120Reputation: 120
no friend, it is usable and, for me, the 3D performance is almost the same, just the framerates show lower =]

edit: please, attach you log as adamk75 asked.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
I got fglrx driver to install, but what do I do with fglrx module? mack_the_knife Slackware 7 07-12-2009 03:48 AM
ATI driver, fglrx - FATAL: Error inserting fglrx hubabuba Slackware 4 04-18-2009 01:27 PM
No direct rendering after uninstalling fglrx BedriddenTech Linux - Software 0 10-02-2004 03:35 PM
Fglrx console=>X changing problem and fglrx resume zbychdm Linux - Hardware 2 09-21-2004 12:58 PM
ATI 9500, fglrx-glc22-4.1.0, fglrx-glc22-4.2.0, fglrx-glc22-4.3.0 ctrl_alt_delx Linux - Hardware 1 09-30-2003 05:48 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 09:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration