-   Slackware (
-   -   UnDVD and slackware-current 01/01/10 (

antitu 01-09-2010 04:16 PM

UnDVD and slackware-current 01/01/10
Just an FYI if anyone runs into something similar...

Slackware 13.0, updated to slackware-current on 01/01/10. 32bit version. I excluded Mplayer from the original install, and the update, as I build Mplayer myself to gain additional codec support.

I use UnDVD to make AVI files of DVDs so I don't have to lug around a bunch of discs. UnDVD was working as expected with Slackware 13.0. After doing the update to slack-current, UnDVD output heavily compressed AVI files. Before the update a 2 hour movie would be around 1 gig or so, using x264. After updating to slack-current the same video was compressed into 150MB file that looked just awful. I verified this new compression with DVDs that I had already compressed before the update. Same result - heavily compressed videos.

UnDVD is a Perl script that uses Mplayer/mencoder to do its work, BTW.

I tried to figure out which package might have overwritten something but wasn't able to figure it out. I think something in the slackware-current is altering MPlayer/mencoder settings. Just not sure which packages and/or settings.

Finally, I rebuilt MPlayer/mencoder and UnDVD's AVI compression was back to normal.

Probably not worth a lot of research but I like to share solutions that I come up with whenever possible.

All times are GMT -5. The time now is 10:43 PM.