LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 12-13-2012, 02:23 AM   #16
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,979

Original Poster
Rep: Reputation: Disabled

Quote:
Originally Posted by GazL View Post
Don't know whether you got anywhere with this Markus,...
I'm using "terminal" now, it works.
Quote:
... but I just thought you'd be interested to know that when I just tried the latest nouveau and libdrm version from git on my system, my underscores disappeared too, so you're not alone in this. I swapped back to using the nvidia blob.
I have ATI adapters in my computers and use the radeon module. I had installed the fglrx module recently, but it changed nothing.

Markus
 
Old 11-14-2018, 10:28 AM   #17
swatnio
LQ Newbie
 
Registered: Jan 2009
Distribution: slackware
Posts: 23

Rep: Reputation: 1
necrobumping

I had the same issue, same faceName (I also use xmonad!)
My solution:
removed ~/.config/fontconfig/fonts.conf


I can still use xterm and the same font as before

I am 100% sure I didn't write that file. And I have no idea how it got there, nor if it was there before and some software modified it.

Last edited by swatnio; 11-14-2018 at 11:36 AM. Reason: more info
 
Old 11-14-2018, 01:03 PM   #18
phenixia2003
Member
 
Registered: May 2006
Location: France
Distribution: Slackware
Posts: 839

Rep: Reputation: 709Reputation: 709Reputation: 709Reputation: 709Reputation: 709Reputation: 709Reputation: 709
Hello,

Quote:
Originally Posted by swatnio View Post
necrobumping

I had the same issue, same faceName (I also use xmonad!)
My solution:
removed ~/.config/fontconfig/fonts.conf


I can still use xterm and the same font as before

I am 100% sure I didn't write that file. And I have no idea how it got there, nor if it was there before and some software modified it.
If you use it, this can be KDE.

Moreover, KDE overwrites ~/.config/fontconfig/fonts.conf each time the font settings panel is opened and even if you don't make change to fonts configuration, which can lead to font rendering issue.

Example:
Code:
$ cd .config/fontconfig
$ cp fonts.conf fonts.conf.bak

$ md5sum fonts.conf*
61224ee07ca088ac471c7018b1726657  fonts.conf
61224ee07ca088ac471c7018b1726657  fonts.conf.bak
Go in System Settings > Application Appearance, select fonts. At this point, the file fonts.conf has (already) been overwritten by KDE :

Code:
$ md5sum fonts.conf*
d4bdf067729830765b64ea11f27ce709  fonts.conf
61224ee07ca088ac471c7018b1726657  fonts.conf.bak

There are two ways to prevent this, (1) never open the font setting panel, and, (2) protect this file, by running :

Code:
$ chattr +i ~/.config/fontconfig/fonts.conf
--
SeB
 
3 members found this post helpful.
Old 11-14-2018, 02:08 PM   #19
swatnio
LQ Newbie
 
Registered: Jan 2009
Distribution: slackware
Posts: 23

Rep: Reputation: 1
As I use xmonad (it's a WM), I am sure I didn't went to Application Appearance.

BUT, it could be I opened some KDE software and it changed something.. maybe? I run dolphin yesterday, it's not something I usually do but I did it yesterday, and this '_' issue happened between yesterday and today.

Thanks for the highlights! I'll pay attention to fonts.conf and if it still bothers me, I will +i it
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
xterm: cannot match normal font "Monospace" on xterm 282, X11R7.7 ebol4 Linux - Software 2 10-07-2012 09:59 PM
How to set the font-size for "xterm" terminal-emulator (running "bash" shell) ajaygarg Linux - Desktop 1 03-09-2012 01:38 PM
Fedora 15 Grub2 Graphical Menu "Invisible" yet there Remore Linux - Newbie 2 08-21-2011 10:36 AM
a "filename~" type file invisible in nautilus cad Linux - General 5 01-03-2007 05:11 AM
LXer: Linuxworld Boston mulls "invisible Linux" pavilion LXer Syndicated Linux News 0 12-12-2005 11:01 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration