LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-04-2003, 09:13 AM   #1
salparadise
Senior Member
 
Registered: Nov 2002
Location: Birmingham UK
Distribution: Various
Posts: 1,736

Rep: Reputation: 146Reputation: 146
unchangeable screen resolution


greetings

i changed to slackware about 4 hours ago
so i'm kind of new to this

I can't seem to get the screen to run higher than 1024x768
i've edited the XF86Conf file about 12 times trying to find a resolution that will work

this seems to be tied somehow to the NVIDIA drivers that i've installed


any ideas??
 
Old 05-04-2003, 03:46 PM   #2
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 46
If you are running in framebuffer mode then I do not think the res can be changed while running X. At least to my knowledge. Then change needs to be made in the /etc/lilo.conf file "vga=" line, lilo written and then rebooted.

If you are running in another mode, then in the screens section it contains the resolutions listed for each color depth. The first listed on the line is the default viewport resolution, and the largest listed defines the desktop area. My default colordepth setting is at 24, so the subsection for 24 bit color will apply and my screens are defined as below for 1280x1024. This is on 17" monitor.

Code:
    Subsection "Display"
        Depth       24
        Modes       "1280x1024" "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
You switch between the different offerings listed by using [ctrl][alt][+] or [-]. The last key must be on the numeric keypad.

If you have higher values listed and they are not working or X refuses to start then look at the monitor definition section. The values provided may not allow for the higher resolutions and will need to be modified if your monitor actually supports it.

My monitor, 17" CTX, is defined as below. I do not know if these values are really respective of my monitor. But they allow the 1280x1024 to work very stable.
Code:
Section "Monitor"
	Identifier   "Monitor1"
	HorizSync    30.0 - 72.0
	VertRefresh  50.0 - 130.0
EndSection
 
Old 05-04-2003, 04:13 PM   #3
gtsanders
LQ Newbie
 
Registered: May 2003
Posts: 11

Rep: Reputation: 0
If you have your Nvidia kernel driver loaded, then run a /usr/X11/bin/XFree86 -configure. This will automatically generate a /root/XF86Config file (if you are running as root...which you should be). mv that to /etc/X11/XF86Config-4. The auto configuration probes your card for optimum settings. Be sure to edit this new config file and load the NvAGP driver as well. Nvidia's linux drivers were ported from Windows...so my experiences have been better using the Nvidia drivers themselves. You also can change the resolution by setting a DefalutDepth just below the "Display" settings in XF86Config.
 
Old 05-04-2003, 10:45 PM   #4
vexer
Member
 
Registered: Jan 2003
Location: Sudbury Ontario, Canada
Distribution: Slackware
Posts: 388

Rep: Reputation: 30
Make sure that if you are going into X windows, add the new resolution changes at the front of the line, otherwise, you'll be stuck doing ctrl+alt+ + all the time.
 
Old 05-05-2003, 03:17 AM   #5
salparadise
Senior Member
 
Registered: Nov 2002
Location: Birmingham UK
Distribution: Various
Posts: 1,736

Original Poster
Rep: Reputation: 146Reputation: 146
hmmm

still not getting anywhere

here is relevant sections of XF86Config

vendorname "[My Monitor]"
modelname "[My Monitor]"
ModeLine "1024x768/60Hz" 65 1024 1032 1176 1344 768 771 777 806 -HSync -VSync
EndSection


Section "Device"
Identifier "VESA Framebuffer"
Driver "nv"
#VideoRam 4096
# Insert Clocks lines here if appropriate
vendorname "NVidia"
boardname "GeForce2 MX DDR"
EndSection

Section "Screen"
Identifier "Screen 1"
Device "VESA Framebuffer"
Monitor "My Monitor"


# DefaultDepth 8
# DefaultDepth 16
DefaultDepth 24
# DefaultDepth 32

# "1024x768" is also a conservative usable default resolution. If you
# have a better monitor, feel free to try resolutions such as
# "1152x864", "1280x1024", "1600x1200", and "1800x1400" (or whatever your
# card/monitor can produce)

Subsection "Display"
Depth 8
Modes "1024x768/60Hz" "800x600" "640x480"
Virtual 0 0
EndSubsection
Subsection "Display"
Depth 16
Modes "1024x768/60Hz" "800x600" "640x480"
Virtual 0 0
EndSubsection
Subsection "Display"
Depth 24
Modes "1400x1050" "1280x960" "1024x768"
Virtual 0 0
EndSubsection
Subsection "Display"
Depth 32
Modes "1024x768/60Hz" "800x600" "640x480"
Virtual 0 0
EndSubsection

the 24bit section is different because I added the extra settings

still won't run in anything higher than 1024x768

under mandrake 9 i had 1400x1050 before Nvidia drivers

and 1280x1024 after nvidia was installed

(the X Display feature seems to report inaccurately)
 
Old 05-05-2003, 04:02 AM   #6
salparadise
Senior Member
 
Registered: Nov 2002
Location: Birmingham UK
Distribution: Various
Posts: 1,736

Original Poster
Rep: Reputation: 146Reputation: 146
developments...

I deleted the lower resolutions from the Config file,
logged out and back in
and seem to be running at a higher resolution than before

XDisplay still says it's 1024x768

I had given up and gone back to Mandrake but then I thought that that was silly so came back to slackware
i downloaded the NVIDIA stuff afresh and the kernel package seemed different this time
don't know if that's related

anyway
problem solved

next problem

how to get the wheel mouse to let me use the wheel
 
Old 05-05-2003, 05:50 AM   #7
gtsanders
LQ Newbie
 
Registered: May 2003
Posts: 11

Rep: Reputation: 0
Be sure to to an 'lsmod' to see if 'nvidia' is loaded. If not...the kernel module isn't even running. If not...do a 'modprobe nvidia' and if you have it installed...it should load.

More suggestions below.

Also...you may want to start over with a fresh XF86Config file.

Do '/usr/X11/bin/XFree86 -configure'...then move it to /etc/X11/XF86config-4. Remove any other XF86config or move to a '.old'

hmmm

still not getting anywhere

here is relevant sections of XF86Config

vendorname "[My Monitor]"
modelname "[My Monitor]"
ModeLine "1024x768/60Hz" 65 1024 1032 1176 1344 768 771 777 806 -HSync -VSync
EndSection


Section "Device"
Identifier "VESA Framebuffer"
Driver "nv"

--change to Driver "nvidia"

#VideoRam 4096
# Insert Clocks lines here if appropriate
vendorname "NVidia"
boardname "GeForce2 MX DDR"
EndSection

Section "Screen"
Identifier "Screen 1"
Device "VESA Framebuffer"
Monitor "My Monitor"


# DefaultDepth 8
# DefaultDepth 16
DefaultDepth 24
# DefaultDepth 32

# "1024x768" is also a conservative usable default resolution. If you
# have a better monitor, feel free to try resolutions such as
# "1152x864", "1280x1024", "1600x1200", and "1800x1400" (or whatever your
# card/monitor can produce)

Subsection "Display"
Depth 8
Modes "1024x768/60Hz" "800x600" "640x480"
Virtual 0 0
EndSubsection
Subsection "Display"
Depth 16
Modes "1024x768/60Hz" "800x600" "640x480"
Virtual 0 0
EndSubsection
Subsection "Display"
Depth 24
Modes "1400x1050" "1280x960" "1024x768"
Virtual 0 0
EndSubsection
Subsection "Display"
Depth 32
Modes "1024x768/60Hz" "800x600" "640x480"
Virtual 0 0
EndSubsection

the 24bit section is different because I added the extra settings

still won't run in anything higher than 1024x768

under mandrake 9 i had 1400x1050 before Nvidia drivers

and 1280x1024 after nvidia was installed

(the X Display feature seems to report inaccurately)
 
Old 07-07-2003, 05:24 PM   #8
rivang
Member
 
Registered: May 2002
Location: Elkview, WV
Distribution: Slackware 10
Posts: 139

Rep: Reputation: 15
New Slackware Install

Ok I have a newly installed Slackware box here... I am about to run telinit 4 to test the x config but before I do that, I want to make sure that when I start a KDE session the first time that the resolution is going to be 1024x768.

I read somewhere that default resolution is 640x480 when a kde session is started. If the resolution is 640x480 the screen is to small to see the option buttons when KDE Personalization Wizard runs the first time you start a KDE session.

How can you force the starting resolution to be 1024x768 before you start X?

Thanks...
 
Old 07-07-2003, 06:26 PM   #9
SocialParasite
Member
 
Registered: Feb 2003
Distribution: Slackware 10
Posts: 38

Rep: Reputation: 15
Edit the line in your XF86Config file that talks about bit depth and reslutions. Erase all resolutions before "1024x768" and it will then automagically start X at that resolution. It will always default start to the first resolution listed for that bit depth (in my case it was 1280x1024 or something insane like that).

This is the section I'm talking about:

Subsection "Display"
Depth 8
Modes "1024x768/60Hz" "800x600" "640x480"
Virtual 0 0
EndSubsection
Subsection "Display"
Depth 16
Modes "1024x768/60Hz" "800x600" "640x480"
Virtual 0 0
EndSubsection
Subsection "Display"
Depth 24
Modes "1400x1050" "1280x960" "1024x768"
Virtual 0 0
EndSubsection
Subsection "Display"
Depth 32
Modes "1024x768/60Hz" "800x600" "640x480"
Virtual 0 0
EndSubsection
 
Old 07-08-2003, 12:15 PM   #10
rivang
Member
 
Registered: May 2002
Location: Elkview, WV
Distribution: Slackware 10
Posts: 139

Rep: Reputation: 15
My Default Depth is 24 and for the subsection where depth is 24 the settings are:

Subsection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
End Subsection

I just ran telinit 4 and once X11 started, I got the GDM in "640x480".

Do I need to drop to a depth of 16 for it to give me 1024x768 resolution when I start X11?

The depth 16 settings are the same.

If I went on into KDE right now I wouldn't be able to see the buttons on the KDE Personalization panel.

Any other suggestions?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
I messed with the screen resolution and now Redhat will boot into a black screen! Mr. Hill Linux - Newbie 29 05-04-2009 12:52 PM
default screen resolution smaller than max. resolution ?? Thoddy Linux - General 2 11-10-2005 02:33 AM
Screen Size Unchangeable bpellet314 Linux - Hardware 1 12-21-2004 04:46 PM
Unable to configure screen resolution for 15.2" LCD screen in Fedore Core 1 schu Linux - Newbie 3 01-02-2004 06:39 PM
screen freezes after making changes to the screen resolution with Xconfigurator sharathkv Linux - Newbie 1 08-01-2003 06:56 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 11:41 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration