-   Slackware (
-   -   Unbootable after 3.2.29 to 3.2.45 kernel update (

JxPond 11-07-2013 01:27 AM

Unbootable after 3.2.29 to 3.2.45 kernel update
Whats the easiest way to go about repairing this issue (i upgradepkg instead of installed)? It says im missing modules. I imagine booting the dvd and chroot would fix this but im confused on how to setup chroot thks

willysr 11-07-2013 02:02 AM

Boot with your dvd, mount your root partition, chroot to that partition, and ran lilo

Raveriux 11-07-2013 03:52 AM

have you upgraded kernel-modules package?

kikinovak 11-07-2013 04:03 AM

With the 3.2.29 kernel, did you use the huge or the generic kernel with an initrd?

JxPond 11-07-2013 10:07 AM

I had previously been on the Generic 3.2.29 kernel

I saw that there were a lot of security advisories that I had missed so
Here's what I did (not knowing there was a kernel update in there as well, which should have been installed separately):

slackpkg update
slackpkg install-new
slackpkg upgrade-all

I tried to rerun lilo prior to the reboot and it said something was missing.
so I hand edited lilo.conf from 3.2.29 to 3.2.45, because that's what's vmlinuz is in the /boot now.

I tried mkinitrd with -k 3.2.45 / I think I may have deleted mkinitrd.gz and messed up the mkinitrd-tree.

Any Ideas?

jtsn 11-07-2013 10:47 AM

Reinstall all 3.2.29 packages using the Slackware install media, run lilo from there to enable booting of the huge kernel. Reboot into your system. Edit /etc/slackpkg/blacklist to blacklist all kernel packages. Install all packages from the patches/packages/linux-3.2.45 directory, update your lilo.conf and run lilo again.

JxPond 11-07-2013 04:33 PM

Thank you, jtsn:

This indeed got me back into my system, but it was acting sluggish in X and was running out of memory and hitting the hard drive swap constantly.

I've decided to reformat and reinstall from the Slackware 14 DVD and then reapply the kernel updates separate from the reset of the security updates.

All times are GMT -5. The time now is 09:58 AM.