LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-11-2018, 02:06 AM   #1
navigium
Member
 
Registered: Aug 2014
Location: Switzerland
Distribution: Slackware, FreeBSD
Posts: 111

Rep: Reputation: 56
Unblocking wifi using rfkill at boot time


Hey all

I'm using /etc/rc.d/rc.inet1 with an wpa_supplicant.conf file to setup my wireless connection. This has always worked on my older laptops. Now I bought a Lenovo Yoga where I had to install current for the hardware to be supported.

Upon boot, the wpa_supplicant is unable to connect because the wifi interface is soft blocked at boot time. After booting I am able to manually connect by using rfkill to unblock the device and then restart rc.inet1.

Now I was wondering how to automate this. Where would I put the rfkill unblocking command. Does this belong in rc.inet1? I tried rc.local but this is run too late.

I'm also unsure whether current or the used hardware is the reason that it doesn't work.

Thanks

-b
 
Old 07-11-2018, 04:09 AM   #2
coralfang
Member
 
Registered: Nov 2010
Location: Bristol, UK
Distribution: Slackware, FreeBSD
Posts: 718
Blog Entries: 3

Rep: Reputation: 224Reputation: 224Reputation: 224
Have you tried to restart the network after the rfkill command, from within rc.local?

eg;
Code:
rfkill [...   ] && /etc/rc.d/rc.inet1 restart
I'd imagine that should work.
 
Old 07-11-2018, 04:30 AM   #3
navigium
Member
 
Registered: Aug 2014
Location: Switzerland
Distribution: Slackware, FreeBSD
Posts: 111

Original Poster
Rep: Reputation: 56
Quote:
Originally Posted by coralfang View Post
Have you tried to restart the network after the rfkill command, from within rc.local?

eg;
Code:
rfkill [...   ] && /etc/rc.d/rc.inet1 restart
I'd imagine that should work.
I haven't tried this. Sounds like a plan that would work. The downside is that it doesn't solve the problem I failed to mention: the first connection attempt locks up the boot process for about a minute, which I'm also trying to avoid.
 
Old 07-11-2018, 04:48 AM   #4
Loomx
Member
 
Registered: Sep 2012
Distribution: Slackware
Posts: 69

Rep: Reputation: Disabled
I had the same issue on one particular laptop.

To avoid the boot delay I added the `rfkill ...' command into /etc/rc.d/rc.M just before it calls /etc/rc.d/rc.inet1 (around line 97)
 
1 members found this post helpful.
Old 07-11-2018, 04:59 AM   #5
navigium
Member
 
Registered: Aug 2014
Location: Switzerland
Distribution: Slackware, FreeBSD
Posts: 111

Original Poster
Rep: Reputation: 56
Quote:
Originally Posted by Loomx View Post
I had the same issue on one particular laptop.

To avoid the boot delay I added the `rfkill ...' command into /etc/rc.d/rc.M just before it calls /etc/rc.d/rc.inet1 (around line 97)
Perfect, that is the place I was looking for. Added it and it works flawlessly.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
no wifi on pc and can't get rfkill list to display output in command line rave199 Linux - Hardware 2 08-21-2015 12:37 AM
inspecting on rfkill at boot with Broadcom WIFI dariodee Slackware 5 07-21-2014 03:49 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 10:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration