-   Slackware (
-   -   unable to write on CIFS after upgrade KDE 4.10 (

Barx 02-25-2013 02:42 AM

unable to write on CIFS after upgrade KDE 4.10
Hi all

I try to copy and paste the following in a new thread because my original post now is buried in the original thread ..

I have updated my -current to kde 4.10

all works good, except one thing: I cannot write/save on a samba share with kde-sc programs (tried with kate, kwrite, kdevelop, calligra)
I always get the error (translated from italian) "Unable to write the document. Check permission and/or free disk space)

no problem using other editors (vi, vim, emacs, libreoffice) and no problem moving/renaming files from dolphin

So it's not system wide but only related to programs included in the KDE-SC

Running kwrite or kate or kdevelop from the command line I always get this error trying to save on the samba share:

QFile::remove: Empty or null file name
No problems saving on local folders with kate, kwrite, kdevelop, calligra, only on the samba share

No problems with previous KDE 4.8

thank you for any help

Alessandro Barisone


I have a problem only trying to work on a samba share mounted via fstab, with this line

//      /mnt/www      cifs  user=barx,password=xxxxxxxxx,nobrl 0 0
removing the nobrl parameter nothing changed

I tried unmounting the share, then I tried to open the share via Dolphin -> Network -> Samba Shares

By this way I can write files from kdevelop/kwrite/kate

So the problem seems to be related to the smb mount via fstab

Another test: opening kdevelop as root I can write to the samba share (mounted via fstab)

thank you all

Alessandro Barisone

All times are GMT -5. The time now is 04:58 AM.