-   Slackware (
-   -   Unable to update or upgrade slackpk (

NightSky 05-19-2013 03:01 PM

Unable to update or upgrade slackpk
Slackpkg won't update, while trying to upgrade from Slackware64-13.37 current. I get the following:

#slackpkg update
wget:error while loading shared open shared object file:no such file or directory.
grep: /tmp/slackpk.wm5xdm/changelog.txt: No such file or directory.
Having trouble downloading from Check mirrors and try again.

Checked Blacklist nothing is uncommented for upgrade. Changed mirror to Oregon State for slackware64 current without success. Any suggestions beside downloading or buying the new version. I'd rather buy it than download in which case i have to wait to get the $. Thanks

TommyC7 05-19-2013 03:17 PM

My first guess is that you're missing the gnutls package which ships the shared object (perhaps it wasn't installed when you first installed Slackware?).

If you do have it installed then I would make sure that your gnutls package is for the correct architecture.

Another possibility is that wget wasn't upgraded in the past and so it still links to an old libgnutls.

tuxbg 05-19-2013 03:36 PM

I have the same problem when upgrade from 14 to current.To be able to update to current i download gnutls and openssl-solibs and first upgrade them.

mrclisdue 05-19-2013 03:53 PM

One of the remedies to these types of upgrade issues is to edit /etc/slackpkg/slackpkg.conf and change the default:

DOWNLOAD_ALL=off to on.

This was brought up within the past few weeks in another thread but I'm too lazy atm to look it up.

Upgrading in this manner prevents stuff like:


Another possibility is that wget wasn't upgraded in the past and so it still links to an old libgnutls.
from occurring.


TobiSGD 05-19-2013 03:57 PM

mrclisdue is right, usually this kind of behavior occurs when a dependency for wget (in this case libgnutls) is updated to a newer version, but wget is still the older version. Something that does not happen when slackpkg is configured to download all packages first, as pointed out above.

By the way, there is no such thing as Slackware64-13.37 current, you run either 13.37 or -current, but not both.

NightSky 05-19-2013 04:07 PM

Slackpkg worked till last update
Slackpkg worked I'm guessing up to the last update. A quick slocate shows gnutls was upgraded 2012-12-18 to gnutls-3.0.23-x86_64-1.

wget-1.13-x86_64-1 was upgraded 2011-10-11

Don't remember using either. Will it mess anything else up if I generate a new key? Forgot how to do it.

Another question I just use network tools and XFCE plus wireless PCIEX1 - can I create a template to just upgrade what I use? If so do you know of a link on how create and use such a template? Thanks for responding so quick.

TobiSGD 05-19-2013 04:11 PM

wget and therefore libgnutls are used by slackpkg to download the packages that have been upgraded. In your case fixing the system is as simple as manually downloading the upgraded packages and installing them using upgradepkg. I would not recommend to do partial upgrades of the system, unless you know exactly what you are doing.

NightSky 05-19-2013 05:44 PM

Regards and thank all of you for the quick helpful responses. I will first change the slackpkg.conf if that doesn't work I will upgrade utilities manually. I did a similar search before posting but did not find the thread mentioned by mrclisdu. I'm going to wait for my new wireless PCIEX1 before trying upgrading so I don't have to manually change it in udev ;)

NightSky 05-26-2013 03:37 AM

Changed slackpkg.conf to "Download_All= on".
ftp slackware64-current got: wget & gnutls.
upgradepkg wget
gnutls didn't need to be upgraded

Still got slackpkg update error:

# slackpkg update

wget: error while loading shared libraries: cannot open shared object file: No such file or directory
Updating the package lists...
wget: error while loading shared libraries: cannot open shared object file: No such file or directory
grep: /tmp/slackpkg.Ybgh5a/ChangeLog.txt: No such file or directory

Error downloading from
Please, check your mirror and try again.

Tried to upgrade openssl but i got compression and corruption errors. Not so simple after all. Thanks

willysr 05-26-2013 03:40 AM

try downloading them manually, not using slackpkg

NightSky 05-26-2013 04:23 PM

WillySr, thanks that is what I did downloaded them using ftp. Its weird usinig slackpkg for current updates left me with pkgtool ver. 14. Some updated & some not. Where do the shared libraries reside? I have an empty /usr/local/share/ folder?

willysr 05-26-2013 07:04 PM

The problem you encountered was because slackpkg download the packages one by one and unfortunately, wget is upgraded and linked to newer gnutls library which isn't updated yet, so by using DOWNLOAD_ALL=ON, it will download all packGes first before upgrading them one by one
It's now set to ON on current

All times are GMT -5. The time now is 02:54 AM.