-   Slackware (
-   -   Unable to patch kernel with Reiser4 mm patch (

SlackwareInAZ 04-23-2005 07:45 PM

Unable to patch kernel with Reiser4 mm patch
New to this forum, so greetings!

Am a moderately experience linux user since 1998, settling on Slackware several years ago.

I must be missing some minor step in patching my kernel for Reiser4. Here's what I did:

Have the source code for in /usr/src/linux-

downloaded the latest mm patch from, used bunzip2 to uncompress it to 2.6.12-rc2-mm3 and copied to to the /usr/src/linux- directory.

when I try to apply: patch -p1 </usr/src/linux- I quickly get errors such as reverse patch detected, etc.

What am I doing wrong?

I've tried to put the patch in /usr/src, and while in the /linux- directory, used patch -p1 /usr/src/2.6.12-rc2-mm3 or patch -p0, etc with the same errors.

I assume this is the correct Reiser4mm patch for the stable kernel code, so I would appreciate any help.

Thanks :(

egag 04-23-2005 07:53 PM

from some howto :

Now, on to applying the patches. Normally all you need to do is simply issue the following command:

patch -p0 < patch-file-name-here

This should be done from the /usr/src directory.

put the patch in the dir above the sourcefile ( prob. /usr/src ) and use the command there.


SlackwareInAZ 04-23-2005 08:48 PM


Thanks for the quick reply. Tried your suggestion. Placed 2.6.12-rc2-mm3 patch in /usr/src.

Applied patch while in /usr/src using your directions -- patch -p0 <2.6.12-rc2-mm3 and received the following error:

can't find file to patch at input line 3
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
|--- linux-2.6.12-rc2/arch/alpha/defconfig 2005-03-02 01:09:17.000000000 -0800
|+++ 25/arch/alpha/defconfig 2005-04-10 23:48:27.000000000 -0700
File to patch:

Any further suggestions are most appreciated.


amos 04-23-2005 10:55 PM

Isn't patch 2.6.12-rc2-mm3 meant for use with kernel 2.6.12-rc2.

You need to either get the patch for kernel 2.6.11 which would be 2.6.11-mm4 from here or download the full kernel source for 2.6.12-rc2, and run your patch against that.


cathectic 04-24-2005 05:10 AM

You're using the wrong patch! For Reiser4, get the patch for a vanilla kernel from Namesys themselves:

Use the latest 2.6.11 patch against your kernel sources (reiser4-for-2.6.11-3.patch.gz)

SlackwareInAZ 04-24-2005 11:20 AM

Amos & Cathectic,

I know this shouldn't be so difficult, as several years ago, without much effort, was able to patch an older 2.6.x kernel with the mm patch, but using the 2.6.11-mm4 suggested didn't work either.

Method used: 2.6.11-mm4 patch is in /usr/src. While in /usr/src/linux- directory I applied patch -p1 </usr/src/2.6.11-mm4.

Are you saying that I need to patch a 2.6.11 kernel with the Reiser4 mm patch, then upgrade that to, or does the 2.6.11-mm4 patch work for all 2.6.11.x kernels?

Thanks everyone

SlackwareInAZ 04-24-2005 12:49 PM


Downloaded source code for and successfully patched it with 2.6.11-mm4 Reiser 4 patch.

Then tried to patch that code with the patch- kernel patch to update everything to the newer kernel, but received the familiar errors. Do I have to patch it with kernel patch to update it to .2, then to .3. etc, or shouldn't the .7 patch include everything previous, ie. like Windows service packs?


gbonvehi 04-24-2005 12:58 PM

Patches are incremental unless specified so patch- will upgrade
Service Packs usually replace already compiled binary files while this patches updates source code (by adding, removing, replacing lines, so you have to do it once at the time because a line added by a patch may got replaced by another).

SlackwareInAZ 04-25-2005 09:47 PM

Finally got my kernel patched for Reiser 4 support.

Your suggestion to use the latest 2.6.11 mm patch (the one labeled reiser4-for-2.6.11-3.patch.gz) was the one that worked.

Appreciate everyone's help.

Booted to a Gentoo Reiser4 LiveCD, wiped and reformatted the 22Gb partition to Reiser 4, then copied the backed up data, chrooted and set lilo, rebooted and I was set.

Don't see too much difference between Reiser4 and Reiser3.6 in day to day copying and usage, but I had to try the latest and greatest. Maybe one day I'll give JFS or XFS a try.

Take care,

davidsrsb 04-26-2005 06:33 AM

Any idea when reiser 4 is going to be included in the stock 2.6 kernel? V4 has been around quite a while now.

At some stage I guess that Slack 11 will appear with 2.6.x kernel and PK always seems to use unpatched kernels. I always use Reiser 3.6 on my PCs now.

All times are GMT -5. The time now is 01:30 AM.