-   Slackware (
-   -   unable to make initrd (

puru 01-01-2014 09:44 AM

unable to make initrd
I recently upgraded to slackware-14.1. When I run i get the following error.


ls: cannot access /sys/module/*_hcd/drivers/*: No such file or directory
Although an initrd is generated when i run the suggested command, the system fails to boot with the generic kernel. Could anyone help me with it?

Didier Spaier 01-01-2014 10:28 AM

Looks strange. Please post the command suggested by, as well as output of following command, typed as root:

lspci -k|grep hcd

puru 01-01-2014 11:12 AM

Thanks for the quick reply. Following is the command suggested by


mkinitrd -c -k 3.10.17-smp -f ext4 -r /dev/sda7 -m usbhid:hid_generic:mbcache:jbd2:ext4 -u -o /boot/initrd.gz
The lspci -k|grep hcd does not return anything.

Didier Spaier 01-01-2014 11:23 AM

So either that's not a PCI based system, or you have no USB hardware support. Is that right?

This can also happen if you built a custom kernel and didn't include proper drivers, but I guess that's not the case?

puru 01-02-2014 10:48 AM

Frankly i dont know how to determine whether the system is pci based. But when i run the lspci command in vector linux on this system it shows "Kernel driver in use: ehci_hcd" message.

I have not tried to build a custom kernel.

As for the usb, i can access usb storage from the system. Only one problem with the usb is that i'm unable to make a boot disk using usb.

Do you need any other information that will be helpful to diagnose the problem at hand?


Didier Spaier 01-02-2014 11:39 AM

I don't understand why the lspci -k command don't give the same output on Vector and Slackware.

Could you please, under Slackware, issue following command:

zcat /proc/config.gz > configSlackware.txt
Also, under Vector, issue following command:

zcat /proc/config.gz > configVector.txt
then attach both files configSlackware.txt and configVector.txt to your next post.

Also, please give output of following commands under Slackware:

ls -l /lib/modules
uname -a

puru 01-03-2014 12:32 PM

2 Attachment(s)
The output of ls -l /lib/modules is as follows:

total 8
drwxr-xr-x 3 root root 4096 Dec 28 20:26 3.10.17
drwxr-xr-x 3 root root 4096 Dec 28 20:26 3.10.17-smp

The output of uname -a is as follows:


Linux darkstar 3.10.17-smp #2 SMP Wed Oct 23 17:13:14 CDT 2013 i686 Intel(R) Core(TM) i5-2450M CPU @ 2.50GHz GenuineIntel GNU/Linux
Also attached the outputs of zcat /proc/config.gz in both Slackware and Vector Linux.

Didier Spaier 01-03-2014 01:09 PM

Sorry, no clue. I just saw that the 'huge" kernel of Slackware 14.1 has the ehci_hcd driver configured as a module, that is not the case in Slackware 14.0 in which this driver is built in the kernel.

But I don't know if that can cause a problem when building the initrd. Still, I hardly understand why "lspci -k" doesn't list this driver. Would you be kind enough to plug in some USB device under Slackware, then type

lsmod > lsmod.txt
and attach that file to your next post?

In any case, I'd suggest you stay with the huge kernel till someone finds a more helpful answer, this usually doesn't hurt (unless in some special cases like conflicting drivers loaded, for instance).

Just one more question: does your USB devices work properly when using the huge Slackware kernel ?

aikempshall 01-03-2014 02:39 PM

I would also suggest running this command as root -


dmesg | grep ehci

puru 01-04-2014 12:44 PM

1 Attachment(s)
Please find attached the output of the lsmod after usb is attached.

I can read from and write to the usb. Lately i was unable to make a bootstick though. Also, the video of the game speed-dreams 2 is not displayed properly.

Didier Spaier 01-04-2014 01:03 PM

So, modules ehci_pci and ehci_hcd are loaded. I don't know why no module shows in lspci -k output.

lems 01-18-2014 02:19 AM


I get

ls: cannot access /sys/module/*_hcd/drivers/*: No such file or directory
when running on a 3.12.7 kernel on Slackware -current, built using testing/source/config-testing-3.12/config-generic-smp-3.12-smp. I only made sure that CONFIG_X86_PAE, CONFIG_PREEMPT, CONFIG_SCHED_AUTOGROUP and Processor type are enabled/correct (I also disabled CONFIG_DEBUG_KERNEL, as I use the nvidia driver). Otherwise I didn't change anything.

When running the same command on a 3.10.17 kernel (huge or generic), I don't get this message. The 3.12.8-generic-smp kernel boots, though. I am able to use USB devices etc. Is this something I should worry about? Or can I ignore this?


Didier Spaier 01-18-2014 03:11 AM

It *could* be that paths have changed in tree /sys.

Try this:

find /sys -name "*pci:?hci_hcd*"
and please post the output (both kernels).

Petri Kaukasoina 01-18-2014 04:23 AM

How about

ls /sys/module/ehci_pci/drivers/*
Maybe this would work:


mkinitrd -c -k 3.10.17-smp -f ext4 -r /dev/sda7 -m usb-storage:ehci-hcd:ehci-pci:usbhid:hid_generic:mbcache:jbd2:ext4 -u -o /boot/initrd.gz

lems 01-18-2014 08:33 AM


Originally Posted by Didier Spaier (Post 5100164)
It *could* be that paths have changed in tree /sys.

Try this:

find /sys -name "*pci:?hci_hcd*"
and please post the output (both kernels).


thanks for the quick reply.

find /sys -name "*pci:?hci_hcd*" on 3.10.17-smp (huge):

On 3.12.8-generic-smp, I get no ouput.


ls /sys/module/ehci_pci/drivers/* gives this on 3.12.8:


All times are GMT -5. The time now is 09:34 PM.