LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 08-11-2019, 03:16 PM   #1
dracolich
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 1,218

Rep: Reputation: 51
Unable to locate printer error with cups+avahi in Slackware64


Two weeks ago I installed Slackware64 on a new ssd. Previously I had been using 32-bit Slackware. This past November I got a wireless Canon MG3620 printer. In 32-bit Slackware I added avahi and nss-mdns from SlackBuilds, then recompiled/reinstalled cups with avahi and mdns enabled. After that the printer was working great.

Today I attempted printing for the first time since the install. I have already installed avahi,mdns and recompiled cups as I had done previously. The printer is discovered correctly with a dnssd address. However, when attempting to print anything (even a test page) the cups web interface always gives the error "Unable to locate printer "919B80000000.local"."

I have been searching Google and various forums all day for ideas. I have copied the working cupsd.conf and nsswitch.conf from the old disk, checked /etc/hosts and everything in /etc/cups, and ran avahi-resolve with the printer's ip and name to verify that it resolves both ways. I have deleted and re-added the printer in cups many times, and recompiled cups again.

Just now added it again using ipp with the ip address and it does work this way. Any ideas why the dnssd is failing?
 
Old 08-11-2019, 09:37 PM   #2
dracolich
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 1,218

Original Poster
Rep: Reputation: 51
Never mind, I solved this one. I had to add the printer's ip address and the 919B80000000.local name in /etc/hosts. Odd because I didn't have to have that before...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] CUPS printer discovery without avahi or samba Poprocks Slackware 4 02-25-2019 03:01 PM
[SOLVED] Fedora 20 cups/avahi/firewall problem boazk Fedora 3 11-07-2014 06:52 PM
CUPS/AVAHI - what did I miss? Pedulla Linux - Server 1 02-22-2013 01:29 AM
[SOLVED] E: Unable to locate package nova-comm E: Unable to locate package python-psycopq2 mint12 Linux - Virtualization and Cloud 2 01-05-2012 12:07 PM
Can't get avahi to install (trying to get Netatalk and Avahi running) MarcusWebb1966 Gentoo 4 07-28-2011 03:55 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration