-   Slackware (
-   -   Unable to install packages from fat32 for -current build (

MWilson 09-03-2005 03:32 AM

Unable to install packages from fat32 for -current build
Greetings all :)

I am trying to install the unstable -current build of slackware. I downloaded the entire slackware-current tree from minus two directories; "pasture" and "source". I saved them to a fat32 partition on one of my harddrives. I made the bare bootdisk and two install rootdisk floppies using rawwritexp contained inside and loaded them.

I can get all the way thru the entire install process up until the point it actually tries to unpack packages to the linux partition. I've tried two ways; if I try "Install from harddrive partition" it tells me it has an issue mounting my fat32 partition. I switch to another console and mount it manually just fine, so I try "Install from pre-mounted directory". When I do that it is able to read it and brings up the general package selection options. I select the ones I want and then select "full blown install".

It then tells me it is doing a full blown install without prompting, a fraction of a second later it tells me installation complete and to exit setup. Nothing was obviously extracted or written to my linux partition.

That is where I am stuck, I do not understand why it cannot locate the .tgz packages that are obviously there. I can switch back to the other console and do a ls and everything in the "slackware" subdirectory is there; folders a-y, two CHECKSUMS files, FILE_LIST, MANIFEST.bz2, and two .TXT files.

If anyone has any ideas or suggestions, it would be very greatly appreciated. Thanks. :)

- Mark

Randall Slack 09-03-2005 06:44 AM

Its a long shot!
but this had me stuck for a while when istalling packages from a directory;

Do you happen to leave some space in the name of the directory?
i had my packages for KDE in /FAT/KDE 3.4/ while it should have been /FAT/KDE3.4/

MWilson 09-03-2005 07:14 AM

I know the problem you are talking about, it seems the installer doesn't like having spaces in a path even if you use "\ " when typing it out. There arn't any spaces in the path, I manually mounted "/dev/hda4" (my fat32 partition) to /slackwaresource while installing so the the full path comes out to "/slackwaresource/slackware-current". I have no problem accessing the packages manually in another console, the installer just seems to think it unpacked and installed all the packages without actually doing anything.

Randall Slack 09-03-2005 07:21 AM

have you tried:

instead of

i will burn the install cd, don't have it here, and try to do it myself, will give you my findings in a while

Randall Slack 09-03-2005 07:39 AM


don't have the same setup as you, but i guess when using the normal disk 1 you can do the same.

after seting up swap and your root directory, it asks if tou want to set up your fat32 partition, we want to so we name it /fat32

i guess after mounting fat32 in your second console the path should be


if this doesn't work i'm out of ideas for the moment!

MWilson 09-03-2005 08:13 AM

I just tried it with slackware 10.1 as opposed to "current" and got the same problem. I even tried a different fat32 partition on another drive.

That's an interesting idea, if the ending "/" has any effect. I don't recall if I was using a slash at the end or so I will try that a little later and see. Yes, I was setting up my windows partitions prior to package selection, I was doing "/mnt/win_c" thru "/mnt/win_h" for my fat32 partitions and "/mnt/win_xp" for my NTFS partition. I tried to install first off of "/dev/hdd7" (win_g), when that didn't work I moved the install files to "/dev/hda4" (win_c). The install files were in the folder "slackware-current" in the root of the partitions and when I was manually mounting the partitions I was mounting them to "/slackwaresource", so the install files were in "/slackwaresource/slackware-current" when mounted.

The installer does see the folders "a" thru "y" and gives the choice of what packages to install, so it must be seeing the install directoy. It's just not extracting and installing anything. Doing a ls in the console, all the filenames look good, none of them look truncated.

If all fails, I am going to try copying the install files to another system on my network later and doing a network install, hopefully that will circumvent the problem.

Randall Slack 09-03-2005 08:28 AM

don't know what reasons you have to install from harddrive,

if you have a working 10.1 installed you could use slapt-get or something like swaret to upgrade to current.
if you have a cd rom drive you could also try to download and burn one of the current iso's
one place you can get them is

jong357 09-03-2005 04:51 PM

I've seen alot of permission problems with mounted FAT32 partitions. That could very well be your problem. Just a guess anyway. man mount and see what you can come up with. Generally, it's problematic 'working' from a FAT32 partition. I realize your not trying to install to a FAT32 but it could still give you problems none-the-less... They're nice for storing files but not much good for anything else IMO...

MWilson 09-04-2005 12:25 AM

Okay, I had an idea I tried but it did not work. I did the setup up to the point that it asks for source media. I switched to another console and mounted my fat32 drive. I then copied the install tree to my freshly setup ext3 file system (the one I'm installing to). Selected "install from pre-mounted directory" and pointed it to the install directory on my ext3 file system. The same thing happened however, the installer said it was done without extracting anything.

I'm copying the install directory now to another system on my network and am gunna try a network install.

If this fails I will see about burning "current" to CDs, I'll have to separate the KDE packages and the "testing" directory so the install can fit on CDs. It looks like I will have to modify and create new CHECKSUMS, FILE_LIST, and MANIFEST.bz2 files so the installer will know the extra packages are on a second disk.

If THAT doesn't work then I'll install 10.1 and try slapt-get or swaret. =)

PDock 09-04-2005 06:16 AM

For sometime now the install-packages script in each directory has failed to work for me.
Following is based on pkgtools-10.1.0-i486-4 and has been a problem for me for a while.

Documentation for dialog --checklist says --seperate-output option is not given, the strings will
be quoted to make it simple for scripts...
Well I guess the default has changed because there are no quotes "" seperating the names/fields
in .../setup/tmp/SeTpkgs.
sh -x ./maketag shows the fgrep statement is trying to find "$PACKAGE" in the SeTpkgs file which
results in everything being set to "SKP" in the SeTnewtag file.

If the line in each maketag file is changed to:
if fgrep $PACKAGE $TMP/SeTpkgs 1> /dev/null 2> /dev/null ; then
results in proper creation of the SeTnewtag file.

The above message was recently sent to Mr. V and could also be the cause of your problems also as you state

It then tells me it is doing a full blown install without prompting, a fraction of a second later it tells me installation complete and to exit setup. Nothing was obviously extracted or written to my linux partition.
Still could be a fat32 issue but if your network install efforts result in same problem then try editing the maketag file as shown above.

MWilson 09-04-2005 11:05 PM

Well I have current installed now. I ended up doing it the easy way by burning 10.1 to CD and installing that. Then I mounted my "slackware-current" tree that's on my fat32 partition, and following Patrick's directions in UPGRADE.TXT, upgraded by doing a "upgradepkg --install-new" for all the packages in "slackware-current".

I'm still curious to know though if anyone recently had any success with a hard drive install with any of the recent versions.

All times are GMT -5. The time now is 08:41 PM.