-   Slackware (
-   -   Unable to get wireless networking working (

arubin 11-05-2006 04:25 AM

Unable to get wireless networking working
I had slackware 10.2 on one of our Pcs and had wireless networking using ndiswrapper and drivers off the windows cd.

I have now done a fresh installation of slackware 11 and installed the 2.6 kernel. I cannot get wireless networking going despite using the same procedures as previously.

I am using ndiswrapper-1.28.tar.gz

The chipset is Broadcom BCM4306

I have tried drivers off the wiki list and off the windows cd ..BCMWL5.INF

Whatever I do I do not seem to get wlan0 so iwconfig gives

root@RubinGirls:/home/alan/packages/ndiswrapper-1.28# iwconfig
lo no wireless extensions.

eth0 IEEE 802.11b/g ESSID:off/any Nickname:"RubinGirls"
Mode:Managed Access Point: Invalid Bit Rate=1 Mb/s
RTS thr:off Fragment thr:off
Encryption key:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0 no wireless extensions.
There is an error on dmesg


bcm43xx: PHY connected
bcm43xx: Error: Microcode "bcm43xx_microcode5.fw" not available or load failed.
spurious 8259A interrupt: IRQ7.
modprobe ndiswrapper seems to work Ok but there is no ndiswrapper: diver ''driver1'' added message.

I do not know if the following is relevant

When I run make to compile ndiswrapper I get this message


*** WARNING: This kernel seems to use 4K stack size option (CONFIG_4KSTACKS); many Windows drivers will not work with this option enabled. Disable CONFIG_4KSTACKS option, recompile and install kernel
I cannot find CONFIG_4KSTACKS in /usr/src/linux/.config

Alien Bob 11-05-2006 05:03 AM


bcm43xx: Error: Microcode "bcm43xx_microcode5.fw" not available or load failed.
This indicates that the driver can not find it's firmware. Aren't you supposed to extract the bcm43xx firmware out of the Windows driver using the "fwcutter" tool? There are some threads in this forum that deal with fwcutter iirc, look for them.


I cannot find CONFIG_4KSTACKS in /usr/src/linux/.config
Don't worry about this one - the software tries to check your kernel configuration but fails to do this correctly on (at least) the Slackware kernels.


arubin 11-05-2006 05:36 AM

I have it working

It seems that there is a module bcm33xx which interferes with ndiswrapper

modprobe -r bcm33xx got things working
I have now blacklisted bcm33xx

Bruce Hill 11-05-2006 05:41 AM

That is the module in the kernel.

Did you not try it before ndiswrapper?

arubin 11-05-2006 08:58 AM

I wasn't aware that I should

Doesn't this

bcm43xx: PHY connected
bcm43xx: Error: Microcode "bcm43xx_microcode5.fw" not available or load failed.
spurious 8259A interrupt: IRQ7.

which occurs several times in dmesg suggest a problem with the kernel module?

Bruce Hill 11-05-2006 09:12 AM

First, Alien Bob knows infinitely more about Slackware and
wireless than do I. That being said, it seems to me that if
there is a module in the Linux kernel, one would try to use
that first. If it doesn't work, then use the Windows driver.

Just my opinion, which is worth exactly what you paid for it. :D

rje_NC 11-05-2006 09:12 AM

The native bcm43xx driver uses firmware that needs to be extracted using the fwcutter program. Since the driver is compiled as a module in the slack supplied kernels, you are getting the message since the hardware is present and the driver attempts to load.

If you have any need to recompile the kernel, I would remove the bcm43xx driver and suggest that you enable the kernel debugging option to enable the 8k stack size that ndiswrapper wants.

I have a broadcom wireless card in my Compaq laptop and have had no luck at all with the native driver. Ndiswrapper works great for me.

arubin 11-05-2006 09:36 AM

Well it is working now with the driver of the Windows cd and ndiswrapper. I don't get this kernel compile option. I you enable kernel debugging there is an option to 'Use 4kb for kernel stacks instead of 8kb". So why should I enable kernel debugging so as to give the option of ignoring this option?

Judging from some of the comments I have seen ndiswrapper works better than bc33xx but I'll have a look at fwcutter

Hangdog42 11-05-2006 12:31 PM

Just to clarify a couple of points....

The bcm43xx kernel module is only part of the driver. As has been pointed out, you need to run fwcutter against a Windows driver to generate the firmware files. What many people don't seem to get is that no distro ships the firmware files (since technically they are proprietary), so you have a slightly ugly situation in which your card can be detected but is non functional.

As for the 4K stacks problem, as Eric noted, Slackware stock kernels don't suffer from this, and unless you've enabled it in a custom kernel, odds are you won't suffer it with a custom kernel either. If ndiswrapper can't find a statement about 4K stacks, it tosses out that error as a warning, just in case. My opinion is that they should do so only if they've found 4K stacks enabled, but the ndiswrapper team seems to have taken a broader view. As far as I can tell, the only distro that seems to use 4K stacks routinely is Fedora.

All times are GMT -5. The time now is 09:53 PM.