LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 10-17-2009, 11:43 AM   #1
Alexvader
Member
 
Registered: Oct 2009
Location: Japan
Distribution: Arch, Debian, Slackware
Posts: 994

Rep: Reputation: 94
Angry "Unable to determine your tty name"


Hi Forum

I have installed Slackware 13 x64 in my laptop, configured it allright, set up the wireless, etc.

When I was upgrading the installed packages via the repository, suddenly the battery ran out of charge,,,

After connecting it again to power, I tried to login, but this strange msg pops after the init sequence:

login :

Trying to log as root, ( did not create user accounts yet... )

"Unable to determine your tty name"

Trying to sitch to other ttys, ctrl+alt+Fn yelds the same result... :-(


Must I reinstall Slackware again...?

This never happened with any other Distribution that I used, RHEL/Fedora/CentOS/Scientific Linux, Debian/Ubuntu/CaeLinux, Suse, Mandriva, ArchLinux, FreeBSD....

Slackware is purportedly "The best of The Best" in terms of reliability, K.I.S.S. principle, security... only comparable to RHEL or FreeBSD...

Was this just a mere "beginner's bad luck" ( although being a beginner in Slackware, I am no beginner in Unix/Linux ), or is this a real issue with Slackware operating system ?

Can I recover my sytem without having to reinstall from scratch...?

What can I do NOT to let this happen again ...?

Reaaly... this has NEVER happened to me before... and I've been using computers for a while now... :-(

Best Regards

Alex
 
Old 10-17-2009, 12:22 PM   #2
slackass
Member
 
Registered: Apr 2006
Location: SE Texas
Distribution: Slack64-14.2
Posts: 908

Rep: Reputation: 89
I don't know if this will fix it but you might try booting from the dvd and run:
slackpkg update
slackpkg clean-system
slackpkg upgrade-all
slackpkg new-config

also:
Wouldn't hurt to check to make sure you have the correct repo selected.

Last edited by slackass; 10-17-2009 at 12:25 PM.
 
Old 10-17-2009, 12:47 PM   #3
Alexvader
Member
 
Registered: Oct 2009
Location: Japan
Distribution: Arch, Debian, Slackware
Posts: 994

Original Poster
Rep: Reputation: 94
Hi Slackass

Thx for yr help, I will try this as soon as I get back home, now just for one more question, I enabled a repo from those listed in the file in the Slackware 13 section ( just uncommented it ) I believe this is the right way to do it... am I right here...?

Or are some repos "healthier" than others....?

In Debian, or CentOS all the repos listed are equally valid for that specific distribution, one only has to enable or disable them... I did not add anything to the repo file...

I only uncommented one of the entries in the 13 section... is this OK...?

Thanks in advance

Alex
 
Old 10-17-2009, 01:09 PM   #4
slackass
Member
 
Registered: Apr 2006
Location: SE Texas
Distribution: Slack64-14.2
Posts: 908

Rep: Reputation: 89
You need the one for:
Slackware64 13.
If your running "Slackware64 13" and you selected "Slackware 13" it will hose your system.
 
Old 10-17-2009, 02:00 PM   #5
Alexvader
Member
 
Registered: Oct 2009
Location: Japan
Distribution: Arch, Debian, Slackware
Posts: 994

Original Poster
Rep: Reputation: 94
Hi again

Are there any Slackware64 13 repos in the repo Fileor must I manually add them....?

Alex
 
Old 10-17-2009, 02:21 PM   #6
slackass
Member
 
Registered: Apr 2006
Location: SE Texas
Distribution: Slack64-14.2
Posts: 908

Rep: Reputation: 89
There in:
/etc/slackpkg/mirrors
 
Old 10-17-2009, 02:37 PM   #7
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.2
Posts: 7,809
Blog Entries: 58

Rep: Reputation: Disabled
Just uncomment (delete the # and a space from in front of) the nearest mirror to you.
 
Old 10-17-2009, 04:36 PM   #8
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Debian
Posts: 8,577
Blog Entries: 31

Rep: Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195
Quote:
Originally Posted by brianL View Post
Just uncomment (delete the # and a space from in front of) the nearest mirror to you.
All things being equal that would make perfect sense. Situated in India, experience says effective Internet distance differs wildly from geographic distance; connections with Europe and even USA (on the opposite side of the planet) are usually faster than "next door" Asian sites. I speak generally, rather than Slackware-specifically.
 
Old 10-17-2009, 07:37 PM   #9
slackass
Member
 
Registered: Apr 2006
Location: SE Texas
Distribution: Slack64-14.2
Posts: 908

Rep: Reputation: 89
Alexvader

If you did use the wrong mirror to up date with then it might be quicker to re-install rather than trying to fix it.
If you used the correct mirror there would have only been 3 or 4 updates on it. You mentioned that your battery went dead during the updates so I'm assuming there were a lot of them, like maybe most of the system as would be the case if you were using the wrong mirror.
If you decide to re-install run:
slackpkg update
slackpkg upgrade-all
before installing your graphics driver because there is a “mesa” upgrade in there that can possibly further complicate things for you.
 
Old 10-18-2009, 11:10 AM   #10
Alexvader
Member
 
Registered: Oct 2009
Location: Japan
Distribution: Arch, Debian, Slackware
Posts: 994

Original Poster
Rep: Reputation: 94
Hi @Catkin, @Slackass, @BrianL

I solved this issue by reinstalling from scratch, peformed an update, and so far so good...

Let-s hope this doesn-t happen again... if I had some work already in my pc, using ext4 and encrypted partitions, would have been a real pain in the ass to get my stuff back from the hdd... :-|

Once again, Thanks ppl :-)

BRGDS

Alex
 
Old 02-15-2010, 12:29 PM   #11
zigmunds
LQ Newbie
 
Registered: Feb 2010
Distribution: Slackware, RedHat, Ubuntu
Posts: 1

Rep: Reputation: 0
Cool

Same thing hapened to me. Today uncommented wrong line with slack64 in /etc/slackpg/mirrors.
Here's a quick How-To resolve this problem:

1. Boot from slackware CD, mount your slack partitions and copy bash.

mkdir /slack
mount /dev/sda1 /slack
cp /bin/bash /slack/bin/bash

Reboot

2. Now you can login. Error appears that file system is read only, remount your root partition

mount -n -o remount /

Ok! Now you have write access to your partition.

3. Mount cdrom and reinstall system packages, i reinstalled them all. Nothing bad will hapen.

cd /mnt/cdrom/slackware
installpkg *

4. Packages installed. Great! Now type:

lilo

else your system won't boot.
Reboot

5. Comment back that wrong line in

/etc/slackpkg/mirrors

uncomment right one.
Now you can do update. Thats all!
 
Old 05-24-2011, 04:20 PM   #12
caffeinebot
Member
 
Registered: Feb 2004
Location: Lexington, MA
Distribution: Gen2
Posts: 39

Rep: Reputation: 15
busybox

For the archives: In the embedded world and with busybox, this happens if you haven't got anything in your proc directory.
Hope that helps someone out there.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
"Can't access tty, job control turned off"-Sony p2 laptop beachboy2 Linux - Laptop and Netbook 7 05-02-2009 01:12 AM
Nvidia driver install script: "Unable to determine the version of the kernel sources" lumix Linux - Software 9 12-18-2008 06:40 AM
lilo says, "L 01 01 01" and fdisk says, "Unable to seek on /dev/hda1" clausawits Linux - General 3 12-31-2007 09:33 PM
error "unable to load tty" after adding HDD to Ubuntu mrlankey0486 Linux - Hardware 3 04-27-2006 08:31 PM
Common problems explained: "kernel panic - not syncing", "unable to mount..." sundialsvcs Linux - Newbie 2 03-01-2006 12:17 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration