LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-15-2016, 06:22 PM   #1
tb75252
Member
 
Registered: Oct 2010
Distribution: Slackware 14.2 (64-bit)
Posts: 158

Rep: Reputation: Disabled
Unable to Burn .ISO File to DVD With K3B


I am using Slackware 14.2, 64-bit.

With Dolphin I right-click an .iso file and then select Actions -> Write image to disk with K3b -> Start.

I get the following errors:
Quote:
cd record has no permission to open the device.
You may use K3bsetup to solve this problem.
So I go to K3b -> Settings -> Setup System Permissions...

No matter what I select, I still cannot burn the .iso file to a DVD. I keep on getting the same errors.

I think that I have to set up a "burning" group and make myself member of it, but I don't know how to do it.

Can somebody please get me out of this bind?
 
Old 07-15-2016, 06:33 PM   #2
montagdude
Member
 
Registered: Apr 2016
Distribution: Slackware
Posts: 946

Rep: Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670
Hm, I remember having this problem before and solving it by changing something in k3bsetup, but I can't remember exactly what I did. If it helps, here is a screenshot of my k3bsetup window. Maybe you can see if yours is different? FWIW, my user account is not a member of any "burning" group.
Attached Thumbnails
Click image for larger version

Name:	k3bsetup.png
Views:	144
Size:	82.8 KB
ID:	22475  
 
Old 07-15-2016, 06:48 PM   #3
tb75252
Member
 
Registered: Oct 2010
Distribution: Slackware 14.2 (64-bit)
Posts: 158

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by montagdude View Post
Hm, I remember having this problem before and solving it by changing something in k3bsetup, but I can't remember exactly what I did. If it helps, here is a screenshot of my k3bsetup window. Maybe you can see if yours is different? FWIW, my user account is not a member of any "burning" group.
The only apparent difference to me is the "cdrdao" line. Under the New Permissions column yours says "4711 root.root". Mine says "no change" and I don't understand how to change that. I don't see anything else being different.
 
Old 07-15-2016, 08:05 PM   #4
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.2
Posts: 1,512

Rep: Reputation: 343Reputation: 343Reputation: 343Reputation: 343
I see how you said above your user is not a part of any "burning" group. Have you tried adding your user to the "cdrom" group and seeing if that fixes the issue?
 
Old 07-15-2016, 08:17 PM   #5
tb75252
Member
 
Registered: Oct 2010
Distribution: Slackware 14.2 (64-bit)
Posts: 158

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Daedra View Post
I see how you said above your user is not a part of any "burning" group. Have you tried adding your user to the "cdrom" group and seeing if that fixes the issue?
Yes, the user is already part of the "cdrom" group.
 
Old 07-16-2016, 02:28 PM   #6
gda
Member
 
Registered: Oct 2015
Posts: 115

Rep: Reputation: 25
You could try this:

Code:
chown root:cdrom /usr/bin/cdrecord /usr/bin/cdrdao

chmod 4750 /usr/bin/cdrecord /usr/bin/cdrdao
If you don't want all members of the 'cdrom' group to be able to execute the two suid binaries, then create a special group (for example 'burning'), use it instead of 'cdrom' in the line above. Don't forget to include in this group the users you wish to have access to cdrecord and cdrdao.

I hope this helps!

Last edited by gda; 07-16-2016 at 04:48 PM.
 
4 members found this post helpful.
Old 07-16-2016, 08:47 PM   #7
Gordie
Member
 
Registered: Aug 2007
Distribution: Slackware
Posts: 359

Rep: Reputation: 98
I just went through this the other day on my other laptop. k3bsetup seems to be able to add users to an already existing group but somehow cannot make a new group. At least that is how I ended up understanding it. I just used a terminal, su to root and make a group "burning" with addgroup, then went back to k3bsetup and let it doo its thing and all was well.
 
2 members found this post helpful.
Old 07-17-2016, 07:11 AM   #8
tb75252
Member
 
Registered: Oct 2010
Distribution: Slackware 14.2 (64-bit)
Posts: 158

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by gda View Post
You could try this:

Code:
chown root:cdrom /usr/bin/cdrecord /usr/bin/cdrdao

chmod 4750 /usr/bin/cdrecord /usr/bin/cdrdao
It worked! Thank you very much for your help. This thread can be considered as solved.

Last edited by tb75252; 07-17-2016 at 07:13 AM.
 
Old 07-17-2016, 04:11 PM   #9
gda
Member
 
Registered: Oct 2015
Posts: 115

Rep: Reputation: 25
Glad I could help!
 
Old 09-22-2016, 11:56 AM   #10
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, and whatever VMs I happen to be playing with
Posts: 13,562
Blog Entries: 20

Rep: Reputation: 3568Reputation: 3568Reputation: 3568Reputation: 3568Reputation: 3568Reputation: 3568Reputation: 3568Reputation: 3568Reputation: 3568Reputation: 3568Reputation: 3568
I want to add my thanks, too, gda. I was having the same issue and your post enabled me to fix it.
 
Old 01-21-2017, 04:44 AM   #11
StreamThreader
Member
 
Registered: Mar 2012
Location: Ukraine/Odesa
Distribution: Slackware
Posts: 130

Rep: Reputation: 13
Quote:
Originally Posted by gda View Post
You could try this:

Code:
chown root:cdrom /usr/bin/cdrecord /usr/bin/cdrdao

chmod 4750 /usr/bin/cdrecord /usr/bin/cdrdao
If you don't want all members of the 'cdrom' group to be able to execute the two suid binaries, then create a special group (for example 'burning'), use it instead of 'cdrom' in the line above. Don't forget to include in this group the users you wish to have access to cdrecord and cdrdao.

I hope this helps!
Thanks, but strange, in slackware 14.1 this problem not appeared.
 
Old 01-08-2018, 08:52 AM   #12
troqnec
LQ Newbie
 
Registered: May 2013
Posts: 11

Rep: Reputation: Disabled
Hi friends, I just try to find how to resolve my problem with K3b, but after:

chown root:cdrom /usr/bin/cdrecord /usr/bin/cdrdao

chmod 4750 /usr/bin/cdrecord /usr/bin/cdrdao

I have this errors:

Unable to find cdrecord executable
K3b uses cdrecord to actually write CDs.
Solution: Install the cdrtools package which contains cdrecord.

and

Unable to find cdrdao executable
K3b uses cdrdao to actually write CDs.
Solution: Install the cdrdao package.

So can I undo this two commands that I think is not for me
Sorry for my English skills

Last edited by troqnec; 01-08-2018 at 08:56 AM.
 
Old 01-08-2018, 10:13 AM   #13
gda
Member
 
Registered: Oct 2015
Posts: 115

Rep: Reputation: 25
First check if the following two Slackware packages

-cdrtools
-cdrdao

are installed on your system. If they are missing just install them (both are included 'ap' slackware package collection).

If they are installed just check the two executables /usr/bin/cdrdao and /usr/bin/cdrecord are executable for the group "cdrom" (the chmod and chown commands listed above should ensure that).

Finally be sure the user you are using to burn (the user that runs K3b) is included in the "cdrom" group.

Last edited by gda; 01-08-2018 at 10:23 AM.
 
Old 01-08-2018, 12:39 PM   #14
troqnec
LQ Newbie
 
Registered: May 2013
Posts: 11

Rep: Reputation: Disabled
Thank you for reply gda..I really don't know where was my mistake but I know that all this packages had installed on my system but for some reason (I think that I make something wrong when I try to make configure permissions with k3b frontend) k3b detected that this packages is not installed. So I reinstalled them and also reinstalled dvd+rw-tools package (I am not sure if I have this package may be I don't need cdrtools and cdrdao) but now everything is ok.
 
Old 05-06-2018, 07:54 AM   #15
js76599
LQ Newbie
 
Registered: May 2018
Posts: 1

Rep: Reputation: Disabled
Thumbs up Worked for me, 2018/05/08

Thank you gda this solved the problem for me.

Regards
js76599


Quote:
Originally Posted by gda View Post
You could try this:

Code:
chown root:cdrom /usr/bin/cdrecord /usr/bin/cdrdao

chmod 4750 /usr/bin/cdrecord /usr/bin/cdrdao
If you don't want all members of the 'cdrom' group to be able to execute the two suid binaries, then create a special group (for example 'burning'), use it instead of 'cdrom' in the line above. Don't forget to include in this group the users you wish to have access to cdrecord and cdrdao.

I hope this helps!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to burn bootable ISO to CD-ROM in K3B or cdrecord davedorm Linux - Software 2 02-14-2008 08:37 PM
unable to burn dvd using k3b or gnome-baker dreamerchawla Linux - Software 18 02-01-2008 11:56 PM
how to burn an dvd .iso image using k3b extendedping Linux - Software 2 11-11-2007 04:45 PM
K3b failing to burn DVD ISO Mandriva dolphans1 Mandriva 22 10-21-2007 07:34 PM
How to use K3b to burn an install DVD iso? coolbreeze7000 Linux - Software 2 02-12-2005 11:50 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration