LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 04-21-2004, 10:52 AM   #1
dushkinup
Member
 
Registered: Feb 2004
Location: Alpha Quadrant, sol system, earth, asia, Israel.
Distribution: Computer I : Slackware 9.1 ; Computer II : Windows XP
Posts: 144

Rep: Reputation: 15
Unable to burn CDs - cdrecord reports no writers


From some reason I can't write CDs on Slackware, while on other distros (such as SuSE and Redhat) CD writing works pretty much out of the box. It may be kernel modules I will have to compile, and no, I don't mind recompiling the kernel - just tell me which ones.
Or is it a setting I should apply?

'cdrecord -scanbus' reports:
Code:
Cdrecord 2.00.3 (i686-pc-linux-gnu) Copyright (C) 1995-2002 Jörg Schilling
cdrecord: No such file or directory. Cannot open '/dev/pg*'. Cannot open SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you are root.
cdrecord: For possible transport specifiers try 'cdrecord dev=help'.
Even as root.
 
Old 04-21-2004, 11:05 AM   #2
Thrasher
Member
 
Registered: Oct 2003
Location: Riverside, CA
Distribution: Slackware/RedHat
Posts: 79

Rep: Reputation: 15
First u need to add to your lilo.conf file
image="/boot/vmlinuz"
root="/dev/hda2"
label="Linux"
read-only
append="hdd=ide-scsi"

note the append="hd?=ide-scsi"
make sure this points to your burner.

then reboot and as root run
cdrecord -scanbus
that should show your cdburner
if all else fails post yer fstab contents too
 
Old 04-21-2004, 11:11 AM   #3
Azmeen
Senior Member
 
Registered: May 2003
Location: Malaysia
Distribution: Slackware, LFS, CentOS
Posts: 1,307

Rep: Reputation: 47
You no longer need ide-scsi for cd-writing... Even Linus himself says that it is absolutely stupid.

I'd recommend trying cdrecord -scanbus -dev=/dev/hd?

Where ? should be replaced with b or c or d or whatever device your writer is.
 
Old 04-21-2004, 11:11 AM   #4
dushkinup
Member
 
Registered: Feb 2004
Location: Alpha Quadrant, sol system, earth, asia, Israel.
Distribution: Computer I : Slackware 9.1 ; Computer II : Windows XP
Posts: 144

Original Poster
Rep: Reputation: 15
This might sound stupid - but how do I know which one is my burner?
 
Old 04-21-2004, 11:16 AM   #5
Thrasher
Member
 
Registered: Oct 2003
Location: Riverside, CA
Distribution: Slackware/RedHat
Posts: 79

Rep: Reputation: 15
hda = primary device on first ide controller
hdb = secondary device on first ide controller
hdc = primary device on second ide contoller
hdd = secondary device on second ide controller
 
Old 04-21-2004, 11:21 AM   #6
dushkinup
Member
 
Registered: Feb 2004
Location: Alpha Quadrant, sol system, earth, asia, Israel.
Distribution: Computer I : Slackware 9.1 ; Computer II : Windows XP
Posts: 144

Original Poster
Rep: Reputation: 15
There, /dev/hdc is my recorder. Now how do I burn stuff, alright?
 
Old 04-21-2004, 11:26 AM   #7
Thrasher
Member
 
Registered: Oct 2003
Location: Riverside, CA
Distribution: Slackware/RedHat
Posts: 79

Rep: Reputation: 15
did you add the append statement to your lilo.conf?
if so,
did cdrecord -scanbus show positive results?
if so, below is a small list of a few ways to burn cd's.
make sure you read the man page (man cdrecord) for details of what you want to do.

cdrecord -v speed=12 dev=0,0 xxx.iso --burns ISO to standard FS
mount xxx.iso -r -t iso9660 -O loop /mnt/cdrom --mounts ISO
mkisofs -R -o xxx.iso /mnt/cdrom -- create ISO of cdrom
cdda2wav -D0,0,0 -B Owav --converts cd music to wav files
cdrecord -v dev=0,0,0 -dao -useinfo *.wav -- burns wave to cd
 
Old 04-21-2004, 11:54 AM   #8
dushkinup
Member
 
Registered: Feb 2004
Location: Alpha Quadrant, sol system, earth, asia, Israel.
Distribution: Computer I : Slackware 9.1 ; Computer II : Windows XP
Posts: 144

Original Poster
Rep: Reputation: 15
That's all nice, but... I don't think that fixed the problem.

I have modified my lilo.conf with the append stuff and it shows exactly the same thing as it did before. it also said that it couldn't load the module 'ide_scsi', but it says that every-time even without the append setting.
 
Old 04-21-2004, 01:24 PM   #9
Thrasher
Member
 
Registered: Oct 2003
Location: Riverside, CA
Distribution: Slackware/RedHat
Posts: 79

Rep: Reputation: 15
Here is what I posted:
append="hdc=ide-scsi"

Here is what you put inyour lilo.conf:
append="hdc=ide_scsi"

Do you see anything that doesnt match there?
Make the appropriete changes and try again.
 
Old 04-21-2004, 05:58 PM   #10
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Boise, ID
Distribution: Mint
Posts: 6,642

Rep: Reputation: 87
Quote:
Originally posted by Azmeen
You no longer need ide-scsi for cd-writing... Even Linus himself says that it is absolutely stupid.

It's true you no longer need ide-scsi under kernel 2.6 but Slack v9.1 is using 2.4. Unless you've upgraded the kernel yourself to 2.6.x, I think you do still need it. -- J.W.
 
Old 04-21-2004, 06:03 PM   #11
ringwraith
Senior Member
 
Registered: Sep 2003
Location: Indiana
Distribution: Slackware 15.0
Posts: 1,272

Rep: Reputation: 65
So.... if using 2.4 kernel you will need to do the append line in lilo.conf. YOu will need to edit your /etc/fstab file to account for the scsi names of your drives.
 
Old 04-21-2004, 07:53 PM   #12
Azmeen
Senior Member
 
Registered: May 2003
Location: Malaysia
Distribution: Slackware, LFS, CentOS
Posts: 1,307

Rep: Reputation: 47
Actually, ide-scsi was never needed since 2.4.24 if I'm not mistaken... I have been using it for that long, if not slightly earlier (2.4.23 days).

Here's how you burn ISOs (just follow Thrasher's instructions but substitute the SCSI device strings with your IDE address):

Example for burning ISOs:
Code:
cdrecord -v speed=12 dev=/dev/hdc xxx.iso
 
Old 04-22-2004, 02:38 AM   #13
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Boise, ID
Distribution: Mint
Posts: 6,642

Rep: Reputation: 87
Well that may be true, but the stock Slackware v9.0 installation uses kernel 2.4.20, and the stock Slackware v9.1 installation uses kernel 2.4.22, and for both of those the "append" clause was needed in order to get the CD-RW to work. (Heck, in the Welcome Email, Patrick even described how to add it step by step.) As I indicated before I believe that you actually do need the "append" clause, unless you have manually upgraded your kernel to a more recent version. At least in my experience that was true. -- J.W.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to burn cds with K3b wellander Linux - Software 11 11-02-2005 05:59 PM
Unable to burn CDs with Mandrake10.0 linuxpista Linux - Newbie 6 12-03-2004 09:55 AM
unable to burn cds in k3b zoings Linux - Software 2 11-01-2004 09:01 PM
unable to burn music cds with cdrecord php Slackware 5 10-20-2004 08:42 PM
How do I burn a cd with cdrecord? Joey.Dale Linux - General 9 03-22-2004 05:57 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 11:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration